Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Ricerca personalizzata

Riparazione amplificatore audio: brutta esperienza

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto UtenteBrunoValente, Foto UtenteIsidoroKZ, Foto Utentecarloc, Foto Utenteg.schgor, Foto UtenteDirtyDeeds

21
voti

[1] Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto UtenteBrunoValente » 24 feb 2018, 12:38

Be', oltre al mio amico Vittorio, con il quale condivido l'interesse per l'elettronica, voglio raccontarla anche a voi.

In genere evito di eseguire riparazioni ma a volte lo faccio, solo per gli amici, gli ex colleghi... questa volta ho riparato un vecchio amplificatore stereo da 250W B&K Components Reference 2220 che mi ha fatto penare.

Come al solito niente schema e neanche reperibile in rete, inizialmente pensavo di poterne fare a meno ma poi le cose si sono messe male e ho deciso a ricavarmelo.



Come vedete niente di strano, tranne un inutile complicazione di un comando "mute" che spegne i finali e il differenziale.

Uno dei mosfet N in uno dei due canali risultava in cortocircuito da tutte le parti e la R da 0.47 ohm in serie al source risultava aperta, insomma il solito guasto degli amplificatori... cosa da prima elementare.

Durante la sostituzione dei componenti rotti del canale difettoso ho notato che gli isolatori al silicone tra i dieci mosfet TO247 e il dissipatore si erano leggermente deteriorati, si staccavano con difficoltà, si erano quasi incollati e leggermente scrostati, evidentemente per conseguenza del continuo surriscaldamento nel corso degli anni, per cui ho pensato bene di sostituirli su entrambi i canali con dei nuovi in mica, anche perché so che al mio amico, il proprietario dell'amplificatore, piace ascoltare la musica ad alto volume e da prove fatte in passato mi sono convinto che quelli di mica trasmettano meglio il calore al dissipatore.

Dopo la sostituzione degli isolatori in entrambi i canali e la sostituzione dei componenti rotti nel canale difettoso, durante le prove, fatte con cautela (variac sull'alimentazione, oscilloscopio in uscita, tester vari collegati per verificare tensioni di alimentazione e correnti nei finali..) si è evidenziata da subito, in assenza di segnale audio, la presenza di debole rumore a 50Hz in uscita dal canale riparato, circa 200mVpp... che però puzzava di autooscillazione ad alta frequenza... è stato qui che ho deciso di ricavarmi lo schema.

E infatti, guardando meglio, c'era dell'alta frequenza, credo a varie decine di Mhz, sul source di tre dei dieci mosfet, ma anche da altre parti si notava il tipico ispessimento della traccia dovuto all'alta frequenza e quel debole segnale a 50Hz presente su tutto l'anello tranne che in ingresso.

Non ho avuto modo di stimare la frequenza ma sono convinto fosse davvero alta perché il segnale, che non si agganciava, lo vedevo con difficoltà sull'oscilloscopio da 50MHz e inoltre variava di ampiezza spostando la sonda di qualche centimetro sulla stessa pista.

I componenti del canale difettoso, che era quello che avevo riparato, risultavano tutti funzionanti, collegando il carico fittizio in uscita le cose peggioravano molto, applicando un segnale sinusoidale 400Hz in ingresso nasceva una componente continua in uscita proporzionale all'ampiezza del segnale, sintomo evidente di una intermodulazione con il segnale di alta frequenza.

Ci ho sbattuto un giorno e mezzo convinto che il difetto fosse da attribuire alla avvenuta sostituzione dei componenti rotti oppure ad altri componenti deteriorati come gli elettrolitici ma parallelandoli con altri non cambiava nulla.
Poi un fatto mi ha aperto gli occhi: ho notato che anche l'altro canale, quello non manomesso che fino a quel momento avevo tenuto scollegato dall'alimentazione, aveva tendenza ad oscillare ma in maniera meno evidente, oscillava solo in presenza del segnale audio, per questo in prima battuta mi era sembrato esente dal problema.

A questo punto era evidente che quella oscillazione non poteva dipendere dal precedente guasto e/o dalla riparazione effettuata.

Per farla breve la colpa era degli isolatori in mica che rispetto a quelli in silicone introducevano una maggiore capacità parassita tra il case dei mosfet e il dissipatore collegato a massa e anche al riferimento, infatti rimontando i vecchi isolatori in silicone tutto è andato a posto.

La sfiga ha voluto che i mosfet TO247 utilizzati in quell'amplificatore fossero particolari: hanno il case connesso al source, non al drain, cosa che non mi era mai capitato di vedere prima.
Se fossero stati dei normali mosfet di potenza TO247 avrebbero avuto il piedino del drain al centro collegato con il case, quindi la capacità parassita offerta dall'isolatore sarebbe finita tra l'alimentazione e il riferimento e non avrebbe dato fastidio a nessuno, invece questi maledetti mosfet 2SK1058 e 2SJ162 hanno il piedino del source al centro e connesso al case, quindi la capacità parassita finisce tra source e il riferimento cioè in parallelo al segnale di uscita e tra l'altro prima della resistenza di equalizzazione da 0.47ohm che, essendo a filo, chissà cosa diventa alle alte frequenze...

Le mie riparazioni prendono quasi sempre una piega simile a questa, per questo cerco di evitare... Io alla sfiga non ci credo ma alla legge di Murphy ci credo fermamente, mi perseguita da sempre :(

Succede anche a voi?
Avatar utente
Foto UtenteBrunoValente
29,0k 6 10 13
G.Master EY
G.Master EY
 
Messaggi: 5647
Iscritto il: 8 mag 2007, 14:48

0
voti

[2] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto Utenterichiurci » 24 feb 2018, 12:48

io non faccio riparazioni... ma vedila positivamente mica è sfiga, hai imparato qualcosa di nuovo :mrgreen:
Avatar utente
Foto Utenterichiurci
24,3k 6 11 13
G.Master EY
G.Master EY
 
Messaggi: 6980
Iscritto il: 2 apr 2013, 16:08

3
voti

[3] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto Utenteabusivo » 24 feb 2018, 14:19

BrunoValente ha scritto:...Succede anche a voi?

Purtroppo si e non solo con i Mosfet da te citati.
Anche gli IRF hanno i loro problemi strani ed inspiegabili.
Avatar utente
Foto Utenteabusivo
6.225 3 4 6
Master
Master
 
Messaggi: 3855
Iscritto il: 16 ott 2012, 18:43
Località: L'Aquila

0
voti

[4] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto UtenteLancillotto » 24 feb 2018, 16:18

Mai visti con il source collegato al case, penso anche contro ogni logica.

Una cosa la posso però aggiungere e credo ti possa anche fare una debole luce sul problema e sopratutto con l'apparente inspiegabile soluzione.
Tempo fa avevamo fatto dei test proprio su quel isolante siliconico grigio, che credo sia lo stesso del tuo caso.

Dovendo certificare un apparecchio ne abbiamo misurato l'isolamento e lo abbiamo trovato leggermente conduttivo, niente di importante, ma rilevabile e nell'ordine di diverse decine di MΩ mi sembra di ricordare che si arrivava ad un centinaio, per altro non stabile, resistenza forse dovuta al materiale composito.
Avatar utente
Foto UtenteLancillotto
792 2 6
Stabilizzato
Stabilizzato
 
Messaggi: 418
Iscritto il: 13 ott 2017, 14:47
Località: ۞ ₯ ۞

1
voti

[5] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto Utenteelfo » 24 feb 2018, 16:44

The signal ground is connected to the case metal ground close to the input RCA jack. Also connected to the metal case is the heatsink. Because of the 2SK1058/2SJ162 pinout (the source is connected to the heatsink plate) there is a significant capacitive load (measured to 420pF for six output devices) between the output node (before the Zobel network) and the power ground. This capacitance is defined by the heatsink insulating pads (we are using Berquist Sil-Pads), together with the parasitic series inductance of the power wiring (if over 0.5uH each) can lead to nasty stability issues. It is therefore recommended that the amp output to be floating, while the input reference is the signal ground. To clarify the situation, in the schematic above we represented all the parasitic elements and the connection to the Amber 5500 distortion analyzer. A single ended Amber 5500 output is used to feed the amp, while for the analyzer input, an Amber 5500 floating input is use


http://www.synaesthesia.ca/Wiring.html
Avatar utente
Foto Utenteelfo
1.759 3 6
Expert EY
Expert EY
 
Messaggi: 593
Iscritto il: 15 lug 2016, 13:27

4
voti

[6] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto UtenteBrunoValente » 24 feb 2018, 18:55

Lancillotto ha scritto:Una cosa la posso però aggiungere e credo ti possa anche fare una debole luce sul problema e sopratutto con l'apparente inspiegabile soluzione.
Tempo fa avevamo fatto dei test proprio su quel isolante siliconico grigio, che credo sia lo stesso del tuo caso.

Dovendo certificare un apparecchio ne abbiamo misurato l'isolamento e lo abbiamo trovato leggermente conduttivo, niente di importante, ma rilevabile e nell'ordine di diverse decine di MΩ mi sembra di ricordare che si arrivava ad un centinaio, per altro non stabile, resistenza forse dovuta al materiale composito.


Mi pare non ci sia nulla di inspiegabile: gli isolatori in mica sono molto più sottili di quelli al silicone, quindi introducono una capacità parassita molto più grande che, a causa dei mosfet fatti in quel modo, si ritrova in parallelo al source e risonando con qualche induttanza parassita, probabilmente quella delle resistenze a filo collegate al source o forse quella delle piste, crea le condizioni per l'instabilità.

L'eventuale resistenza di perdita di quelli originali al silicone dovuta al problema da te evidenziato, finendo in parallelo al carico, non avrebbe comportato alcun problema, infatti con quelli funziona tutto regolarmente.

Foto Utenteelfo grazie del link, vedo che i problemi derivanti da quella conformazione inusuale di quei mosfet sono stati considerati anche da altri, comunque nel mio caso non si trattava di margine di fase insufficiente del'anello principale dell'amplificatore, ho avuto modo di verificare che l'oscillazione nasceva nei mosfet, quindi in qualche modo si generava una reazione positiva localmente intorno ai mosfet, altrimenti la frequenza non sarebbe stata così alta.
Avatar utente
Foto UtenteBrunoValente
29,0k 6 10 13
G.Master EY
G.Master EY
 
Messaggi: 5647
Iscritto il: 8 mag 2007, 14:48

0
voti

[7] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto UtenteLancillotto » 24 feb 2018, 19:52

Intendevo dire che se ci fosse stata una debole perdita nell'isolante siliconico avrebbe contribuito a spegnere l'eventuale auto-oscillazione, per questo con quello andava regolarmente e con quello a mica oscillava
Avatar utente
Foto UtenteLancillotto
792 2 6
Stabilizzato
Stabilizzato
 
Messaggi: 418
Iscritto il: 13 ott 2017, 14:47
Località: ۞ ₯ ۞

0
voti

[8] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto UtenteKagliostro » 25 feb 2018, 0:12

Grazie per la condivisione Foto UtenteBrunoValente

non credo che mi azzarderò mai nella riparazione di apparecchi BF SS ma sapere certe cose

può essere, in ogni caso, molto utile

Grazie

K
Avatar utente
Foto UtenteKagliostro
2.948 3 5 7
Expert EY
Expert EY
 
Messaggi: 1981
Iscritto il: 19 set 2012, 11:32

8
voti

[9] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto Utentecarloc » 25 feb 2018, 11:03

Io per un problema simile mi sono trovato molto bene con gli isolatori ceramici :D

Qualcosa in ossido d'alluminio tipo questo ma ci sono anche con il foro per la vite e di altre forme e misure.

Da un punto di vista della capacità, visto che \varepsilon_\mathrm{r}\approx 9 e lo spessore è 1mm si può stimare qualcosa nell'ordine di 25pF/dispositivo per un TO247

Da un punto di vista termico invece si hanno circa 0,3K/W che sono totalmente in linea con altre soluzioni (silpad o miche).
Consigliabile (sempre) il fissaggio di MOS e accessori con clip elastica piuttosto che con vite.

[ot]
certo che con 3,3kohm in serie al gate di un MOS TO247 :roll: :roll: ... un po' di coscienza sporca il progettista ce la doveva avere :D :D
[/ot]

Alternativamente si potrebbe millerare via la capacità con una guardia, una lamina conduttiva al potenziale dell'uscita che separi fisicamente il MOS dal dissipatore


pilotando la guardia magari direttamente con l'uscita tramite resistenza opportuna, da studiare un po' insomma. :roll:

Naturalmente questa seconda è altamente sconsigliabile, proprio un'ultima spiaggia direi, con due isolanti minimo raddoppi la resistenza termica e poi ci sono le ovvie complicazioni di ordine meccanico....
Se ti serve il valore di beta: hai sbagliato il progetto!
Avatar utente
Foto Utentecarloc
33,0k 5 11 13
G.Master EY
G.Master EY
 
Messaggi: 2121
Iscritto il: 7 set 2010, 19:23

2
voti

[10] Re: Riparazione amplificatore audio: brutta esperienza

Messaggioda Foto UtentePiercarlo » 25 feb 2018, 11:18

Storia istruttiva... anche troppo! :(
Avatar utente
Foto UtentePiercarlo
20,3k 5 10 13
G.Master EY
G.Master EY
 
Messaggi: 5487
Iscritto il: 30 mar 2010, 19:23
Località: Milano

Prossimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 62 ospiti