Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Ricerca personalizzata

XUBUNTU 16.04: non apre alcuni siti.

Moderatori: Foto UtenteMassimoB, Foto Utentexyz

0
voti

[31] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto Utentemrc » 11 ott 2017, 15:03

Sven ha scritto:...Riguardo al problema iniziale....sembra essere stato risolto con questo metodo (era un problema di IPv6).....

Foto UtenteSven grazie, ho provato ad eseguire il metodo da te indicato ma purtroppo non ha risolto il problema.

In relazione al mio dubbio:
mrc ha scritto:....Chissà se facendo l' installazione l' inconveniente viene superato con i vari aggiornamenti....

Ho letto che tutti i S.O. free che mettono a disposizione la versione live, hanno la possibilità di accedere ad internet senza problemi e senza dover essere installati.
Quindi i miei dubbi aumentano.


Foto UtenteMassimoB, grazie.
MassimoB ha scritto:........Se ci si avvicina all'ambiente linux consiglio caldamente di installare distribuzioni come per esempio ..fedora...

Come ho accennato nel mio post n°23 ho provato anche Fedora ma senza successo:
mrc ha scritto:...Fedora invece. dopo che ho eseguito la configurazione, a mio parere in maniera corretta, per accedere a internet, non si collega.....


MassimoB ha scritto:....è meglio installare un bel win xx che è molto più semplice.
...Linux si installa per imparare o per lavorare e non perché è di moda...

Visto che ho a disposizione un PC "anziano" ma comunque funzionante, in cui è installato xp ( che però con il fatto che è stato declassato e certe cose non vengono più aggiornate, è destinato a "perire" ), la mia intenzione sarebbe quella di riuscire ad utilizzarlo finché l' hardware lo consente. Per fare ciò sicuramente non posso utilizzare un' altra versione di Windows che richiederebbe un hardware più moderno ed inoltre non ho intenzione di spendere denaro per un S.O. da dedicare ad una macchina "obsoleta".
Lo stesso discorso vale per il PC che uso come computer "principale"; anche quest' ultimo non è nuovo ma ha qualche anno in meno rispetto all' altro. Anche in questo vi era installato xp e l' ho sotituito, circa un anno fa, con Ubuntu 14.04. Fino ad ora l' ho utilizzato senza nessun problema.
Comunque sono ancora un principiante nell' uso di questi S.O.. Mi sono avvicinato ad essi per necessità, ( per il momento non vorrei comperare un PC nuovo ), e per cercare di imparare ad usarli e non per moda.

MassimoB ha scritto:....Attenzione al fatto che Firefox distribuito da Debian non è firefox distribuito in ambiente Win come default.....

Non so se quello che ho notato è legato a questo discorso, comunque in XP è installato FireFox 52.4 e, per il momento, funziona ( anche se con delle limitazioni dovute alla mancanza di certi aggiornamenti ), invece in Xubuntu/Lubuntu è installata la versione 54 che mi dà il problema in oggetto.
Avatar utente
Foto Utentemrc
9.294 5 11 13
Expert EY
Expert EY
 
Messaggi: 3590
Iscritto il: 16 apr 2009, 8:32

0
voti

[32] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto UtenteMassimoB » 11 ott 2017, 22:45

Installa firefox esr e vedi se funziona.
Di solito quando si riscontrano problemi simili sono i plug-in a dare plomemi, con la versione esr molte opzioni bloccate dal normale firefox funzionano.

Ps.

Link:

https://www.mozilla.org/en-US/firefox/o ... tions/all/

Versione 32 o 64 bit ovviamente per linux

Io uso questa versione e apro tutto...netflix, e company compresi.
A volte è meglio star zitti piuttosto che dire stupidate
Avatar utente
Foto UtenteMassimoB
12,4k 6 12 13
Expert free
 
Messaggi: 2885
Iscritto il: 28 ott 2012, 8:56
Località: Milano

0
voti

[33] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto Utentemrc » 13 ott 2017, 16:11

Come avevo scritto nei post n°6 e n°23 su suggerimento di @egbit ho già provato un paio di volte ad installare ( se così si può dire utilizzando un dvd live ) firefox ma senza successo.

Seguendo il tuo consiglio Foto UtenteMassimoB, ho voluto riprovarci scaricando FireFox esr.

Elenco le tre prove che ho effettuato, senza successo.
Per queste prove ho utilizzato il dvd live di Lubuntu, perché è più leggero di Xubuntu e sarebbe più adatto per il mio PC.
Visto che Xubuntu e Lubuntu sono molto simili e adottano lo stesso tipo di comandi penso di non andare OT.

1°prova:
Dal link, da te gentilmente segnalatomi, ho scaricato il file di FireFox esr .tar.bz2 tramite XP, poi, tramite chiavetta., l' ho "trasferito" in Lubuntu live.
Ho scompattato il file.
Ho notato che tra le varie cartelle e file ci sono due file denominati "FIREFOX" e "FIREFOX-bin" e sono due file eseguibili. Li ho mandati in esecuzione, naturalmente in tempi diversi, ed entrambi hanno aperto il browser FireFox. Purtroppo anche in questo caso si presenta lo stesso problema cioè, accedo ad internet ma alcuni siti non vengono comunque aperti.

2°prova:
Ho provato ad "installare" FireFox da terminale.
Seguendo le indicazioni presenti in internet, in cui consigliano di installare prima Build Essential poi CheckInstall, come prima operazione ho voluto "installare" Build Essential, dando il comando:
Codice: Seleziona tutto
sudo apt-get install build-essential

Nel terminale si sono presentate, tra le tante, le seguenti scritte:
"Lettura elenco pacchetti....Fatto
......
Generazione albero delle dipendenze
......
Lettura informazioni sullo stato...Fatto
.....
Connessione non riuscita
.....
1% [In attesa degli header]"


A questo punto rimane eternamente in attesa di questi header.
Quindi non ho potuto procedere con l' installazione di CheckInstall.

3°prova:
ho voluto tentare di installare FireFox, senza prima installare Build-Essential e CheckInstall, con i seguenti comandi:
Codice: Seleziona tutto
sudo ./config
sudo make
sudo checkinstall

Dando il primo comando:
Codice: Seleziona tutto
sudo ./configure

sul terminale si è presentata la seguente scritta: "command not found"

Quindi ricapitolando:
non riuscendo ad accedere a certi siti tra cui quelli di Ubuntu, non è possibile "installare" dei software, nello specifico FireFox, da terminale.
Come ho scritto nel mio post n°23 dando il comando ping, riferito ad un sito che non si riesce ad aprire, funziona, quindi sembra un problema legato al browser e la comunicazione sembra comunque funzionante.

Sembrerebbe comunque che l' inconveniente sia presente anche senza l' uso del browser, infatti, nella seconda prova, il PC tramite il terminale non riesce a collegarsi al sito di Ubuntu per scaricare quello che servirebbe per installare Build Essential.
Avatar utente
Foto Utentemrc
9.294 5 11 13
Expert EY
Expert EY
 
Messaggi: 3590
Iscritto il: 16 apr 2009, 8:32

1
voti

[34] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto Utentexyz » 13 ott 2017, 16:43

Scusa non ho capito cosa vuoi fare con questo comando:

Codice: Seleziona tutto
sudo ./configure

è utilizzato da chi vuole compilare un programma che usa autoconf, con sudo davanti diventa qualcosa di assurdo da evitare, se poi ti dice "command not found" significa che non sei in una directory con dei sorgenti da compilare.

Se vuoi installare Firefoix esr basta fare:

Codice: Seleziona tutto
sudo apt-get install firefox-esr

naturalmente nei repositori remoti attivi ci deve essere almeno uno con quel pacchetto.
Avatar utente
Foto Utentexyz
3.790 2 4 5
Master EY
Master EY
 
Messaggi: 1063
Iscritto il: 5 dic 2009, 17:37
Località: Italy Turin

1
voti

[35] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto UtenteMassimoB » 13 ott 2017, 23:00

Dai repository ufficiali di debian.....basta digitare seguenti comandi:

Come root ovviamente

Codice: Seleziona tutto
apt-get update
apt-get install firefox-esr


sudo altrimeti (io odio usare un user non root se non necessario...ma questo è un mio parere)

Se non lo avessi gia fatto consiglio in alternativa:

Codice: Seleziona tutto
apt -get update && apt -get upgrade
apt-get install firefox-esr
A volte è meglio star zitti piuttosto che dire stupidate
Avatar utente
Foto UtenteMassimoB
12,4k 6 12 13
Expert free
 
Messaggi: 2885
Iscritto il: 28 ott 2012, 8:56
Località: Milano

0
voti

[36] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto Utentemrc » 14 ott 2017, 10:21

Foto Utentexyz grazie.
xyz ha scritto:Scusa non ho capito cosa vuoi fare con questo comando:
Codice: Seleziona tutto
sudo ./configure

E' stato solamente un tentativo maldestro per tentare di installare FireFox bypassando l' installazione di Build Essential e CheckInstall.

xyz ha scritto:Se vuoi installare Firefoix esr basta fare:
Codice: Seleziona tutto
sudo apt-get install firefox-esr

Ho provato ma Il terminale scrive:
"E: impossibile trovare il pacchetto firefox-esr"

MassimoB ha scritto:
Codice: Seleziona tutto
apt-get update
apt-get install firefox-esr

MassimoB, ho eseguito il primo dei comandi che mi hai suggerito, il terminale scrive:
"E: impossibile aprire il file di blocco.....
......
E: imposibile bloccare la directory.....
......
Remote caches ( 13: permission denied )



Credo, correggetemi se sbaglio, che i punti fondamentali dell' inconveniente, alla luce di tutte le prove che ho fatto fino ad ora, siano:
1) FireFox 54 preinstallato, ( nel dvd live ), non apre alcuni siti.
2) FireFox 52.4 ESR, che ho fatto funzionare senza bisogno di installarlo, si comporta come il 54; non apre alcuni siti,
3) nella prova n°2 ( vedi post n°33 ), tentando di installare FireFox da terminale, quest' ultimo scrive:
"Connessione non riuscita".

Quindi considerando che la prova relativa al punto 3 è stata eseguita con FireFox ( preinstallato ) chiuso, c' è nascosto, da qualche parte, una specie di blocco per cui quando il sistema cerca di collegarsi con i repository non gli è consentito il collegamento.
Il blocco non consente di far funzionare in maniera corretta il browser e il collegamento con i repository di Ubuntu.

A questo punto, se la mia ipotesi è corretta, occorerebbe riuscire a capire da cosa nasce questo blocco.
Avatar utente
Foto Utentemrc
9.294 5 11 13
Expert EY
Expert EY
 
Messaggi: 3590
Iscritto il: 16 apr 2009, 8:32

1
voti

[37] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto Utentexyz » 14 ott 2017, 15:10

mrc ha scritto:"E: impossibile trovare il pacchetto firefox-esr"

In nessun tuo repository è presente il pacchetto "firefox-esr" quindi viene semplicemente segnalato.

mrc ha scritto:"E: impossibile aprire il file di blocco.....
......
E: imposibile bloccare la directory.....
......
Remote caches ( 13: permission denied )


Il comando "apt-get" è un comando privilegiato, solo l'utente root può eseguirlo, per questo si usa il comando "sudo" prima del comando.

Controlla il file "/etc/apt/sources.list" mancano i repository, Consiglio di leggere la documentazione di Ubuntu sui repository e aggiungere quello desiderato:

https://wiki.ubuntu-it.org/Repository
Avatar utente
Foto Utentexyz
3.790 2 4 5
Master EY
Master EY
 
Messaggi: 1063
Iscritto il: 5 dic 2009, 17:37
Località: Italy Turin

0
voti

[38] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto Utenteangus » 14 ott 2017, 19:57

Premetto che ho letto molto velocemente il thread.
A me sembra un po' strano che il problema "non apre alcuni siti" sia legato al browser.

Io verificherei prima la bontà della rete.
Possibile problema di MTU? Pacchetti persi? Driver non ottimale per la eth?
Ti capita che i siti che apre, si "aprano a metà"? o comunque che manchino di qualche contenuto?

Quando "non apre i siti" cosa fa? Sta lì, ci pensa per un po' e poi ti restituisce un errore? (Quale?)
Oppure esce subito un errore? (Quale?)
in /dev/null no one can hear you scream
Avatar utente
Foto Utenteangus
7.621 4 6 8
G.Master EY
G.Master EY
 
Messaggi: 3558
Iscritto il: 20 giu 2008, 16:25

0
voti

[39] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto UtenteMax2433BO » 15 ott 2017, 10:03

In [1] l'OP dice che con la versione live di UBUNTU 14.04 non ha problemi...

... facendo il paragone dei principali pacchetti tra UBUNTU 14.04 e XUBUNTU 16.04, da qui si rileva che la versione di FIREFOX è passata dalla 28.0 alla 45.0.2...

... in basso è presente anche la lista completa dei pacchetti disponibili nelle due versioni, io, da inesperto che sono, noto che la versione UBUNTU 14.04 ha un maggior numero di pacchetti rispetto alla versione XUBUNTU 16.04, possibile che lì in mezzo ci siano, effettivamente, alcuni driver necessari alla corretta gestione di internet, presenti sulla vecchia versione e mancanti (o talmente diversi) sulla nuova?

O_/ Max
Disapprovo quello che dite, ma difenderò fino alla morte il vostro diritto di dirlo [attribuita a Voltaire]

Sapere sia di sapere una cosa, sia di non saperla: questa è conoscenza. [Confucio, "I colloqui"]
Avatar utente
Foto UtenteMax2433BO
4.788 2 5 9
Master
Master
 
Messaggi: 1405
Iscritto il: 25 set 2013, 15:29
Località: Un puntino insignificante nell'universo!!

0
voti

[40] Re: XUBUNTU 16.04: non apre alcuni siti.

Messaggioda Foto Utenteegbit » 15 ott 2017, 11:39

il numero di pacchetti puoi paragonarlo solo tra due Xu o due U :mrgreen:
è fisiologico che ci siano grosse differenze paragonando Mele e Cipolle o in questo caso una capretta selvaggia e uno scoiattolo alleggerito
no tacchino/struzzo :P
Avatar utente
Foto Utenteegbit
338 1 3
Frequentatore
Frequentatore
 
Messaggi: 190
Iscritto il: 16 dic 2016, 18:47

PrecedenteProssimo

Torna a Linux

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite