Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

LM317 corrente pulsante

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteBrunoValente

0
voti

[111] Re: LM317 corrente pulsante

Messaggioda Foto Utentespud » 21 nov 2014, 12:56

Ah non avrei mai pensato a queste cose :!: , grazie mille, farò le prove e vi informo di quello che succede :ok:
Atlant.

Behind every great man is a woman rolling her eyes.
Avatar utente
Foto Utentespud
3.767 3 10 12
free expert
 
Messaggi: 1593
Iscritto il: 1 feb 2012, 14:26
Località: Udine

0
voti

[112] Re: LM317 corrente pulsante

Messaggioda Foto Utentespud » 28 nov 2014, 13:24

Eccomi, scusate i tempi biblici ma ho avuto la possibilità di venire in lab solo oggi.
Dunque ho fatto le misure adattando l'ingresso dell'opamp e in effetti il gradino non presentava oscillazioni, questi sono i risultati.

Risposta al gradino con la Imax in uscita:
gradinoImaxAdattato.jpg

tramite matlab avevo stimato un tempo di salita dell'ordine dei 200ns, dalla misura conto circa 300ns.

Risposta al gradino con la Imed in uscita:
gradinoImedAdattato.jpg

Qui i tempi sono come sopra, sia su matlab che misurati.


Risposta al gradino con la Imin in uscita:
gradinoIminAdattato.jpg

qui è difficile, perché c'è quella gobba iniziale che non mi spiego, se la trascuro e faccio finta che il gradino parta da zero quando finisce la gobba, avrei anche qui sui 300ns misurati, contro i 150ns di matlab.

Non so perché ci sono quelle sovraelongazioni all'inizio, che nel punto di minimo sono evidentissime, con l'impedenza di ingresso adattata si attenuano ma solo nella parte iniziale poi è tutto uguale. Io credo che sia per il fatto che l'impedenza di ingresso abbia delle pesanti componenti capacitive dovute ai parassiti della breadboard. Però anche li, secondo me sarebbe più logico averle dopo che il segnale è arrivato a regime.

Le misure sono state prese nel caso peggiore ovvero a f=100kHz, a frequenze più basse le transizioni sono uguali a occhio.

p.s. non si vede bene dal grafico ma la scala orizzontale è in 10^{-7}
Atlant.

Behind every great man is a woman rolling her eyes.
Avatar utente
Foto Utentespud
3.767 3 10 12
free expert
 
Messaggi: 1593
Iscritto il: 1 feb 2012, 14:26
Località: Udine

1
voti

[113] Re: LM317 corrente pulsante

Messaggioda Foto Utentespud » 1 dic 2014, 19:47

Mi sono reso conto che il tempo di salita che vedo sullo schermo dell'oscilloscopio non è solo quello del sistema che vogliamo caratterizzare, c'è di mezzo anche la sonda e lo stadio di ingresso dell'oscilloscopio stesso, quello che vedo io è t_m

t_m = \sqrt{t_r^2 + t_c^2 + t_{osc}^2}

dove t_c dipende dalla banda della sonda e dallo stadio di ingresso dell'oscilloscopio, t_{osc} dipende dalla banda dell'oscilloscopio, t_r è il tempo di salita del sistema sotto esame.

t_r = \sqrt{t_m^2-t_c^2-t_{osc}^2}

Lo avrò fatto mille volte questo conto per l'esame di misure, non so perché non mi sia venuto in mente in questo caso :oops: Domani vado a vedere le caratteristiche delle sonde che ho usato e provo a fare il calcolo, per ora so solo le caratteristiche dell'oscilloscopio...
Atlant.

Behind every great man is a woman rolling her eyes.
Avatar utente
Foto Utentespud
3.767 3 10 12
free expert
 
Messaggi: 1593
Iscritto il: 1 feb 2012, 14:26
Località: Udine

0
voti

[114] Re: LM317 corrente pulsante

Messaggioda Foto Utentefabio8690 » 3 dic 2014, 0:39

Secondo me se usi un ne555 come generatore di onda quadra che pilota un mosfet sei
apposto A POSTO;)
Ultima modifica di Foto UtentePietroBaima il 3 dic 2014, 8:58, modificato 2 volte in totale.
Motivazione: basta con questi "apposto"
Avatar utente
Foto Utentefabio8690
13 2
 
Messaggi: 15
Iscritto il: 12 ott 2014, 0:56

0
voti

[115] Re: LM317 corrente pulsante

Messaggioda Foto Utentespud » 4 dic 2014, 20:58

Ho provato a prendere il riferimento da una beaglebone black, ho lo stesso problema, solo che questa volta è proprio la tensione generata dalla beagle ad avere le sovraelongazioni, questo è il risultato:

MATLAB.jpg

La misura è stata fatta con un oscilloscopio di banda 100\,\text{MHz}, C_{in}=13\,\text{pF} e R_{in} = 1\,\text{M}\Omega

t_c \simeq 9\,\text{ns}

t_{osc} \simeq \frac{0.35}{100\cdot 10^{-9}} \simeq 10\,\text{ns}

t_m \simeq 260\,\text{ns}

da questo ho ricavato

t_r \simeq 259\,\text{ns}

Ho trascurato il contributo dello stadio di ingresso dell'oscilloscopio perché la sua R_{in} è in parallelo con la resistenza interna del generatore con cui si rappresenta la V_s.

Ora la discrepanza tra il valore teorico è quello misurato è abbastanza grande ma mi chiedo se non sia normale, voglio dire, le capacità del circuito equivalente del mosfet sono state estrapolate a occhio dai grafici del datasheet e allo stesso modo la g_m e \lambda. Non è normale avere delle differenze anche notevoli tra modello e circuito reale?
Atlant.

Behind every great man is a woman rolling her eyes.
Avatar utente
Foto Utentespud
3.767 3 10 12
free expert
 
Messaggi: 1593
Iscritto il: 1 feb 2012, 14:26
Località: Udine

2
voti

[116] Re: LM317 corrente pulsante

Messaggioda Foto Utentespud » 22 dic 2014, 0:09

Ciao :D scrivo quest'ultima cosa poi non stresso più.
Ultimamente ho dovuto fare un po' di cose in parallelo e sto diventando matto, però almeno ho risolto questo problema.

Ho collegato una resistenza da 10k in serie all'ingresso della tensione di riferimento, pensando che combinata alla capacità di ingresso dell'operazionale avrei avuto un filtro passa basso che avrebbe appiattito le oscillazioni causate dal disadattamento di impedenza tra cavo e ingresso dell'ampli. In effetti cosi è stato, questo è il risultato:

StepImedRe.jpg

Questo filtro non sarà presente nel circuito reale, poiché ho verificato che dando il riferimento tramite arduino non ho questo problema, la risposta è più lenta ovviamente ma comunque nelle specifiche iniziali.

Tenendo conto di:
  • tempo di salita del generatore + ritardo introdotto dal cavo,
  • ritardo introdotto dal filtro in ingresso,
  • ritardo ed effetto di carico delle sonde,
  • effetto di carico dello stadio di ingresso dell'oscillo e il suo tempo di salita,
ottengo una risposta di 130 ns contro i circa 90 ns teorici.
Credo che sia un risultato soddisfacente, che dite?

P.S. Ho fritto uno dei diodi #-o Cercando di portare l'onda quadra di riferimento con arduino (acceso ||O ) tramite un cavetto molto corto )O( ho sfiorato la finestrella da dove esce la luce, il risultato è stato un lampetto di luce rossa, quella che si vede nel funzionamento normale, ma molto più forte, poi il nulla :mrgreen:
Atlant.

Behind every great man is a woman rolling her eyes.
Avatar utente
Foto Utentespud
3.767 3 10 12
free expert
 
Messaggi: 1593
Iscritto il: 1 feb 2012, 14:26
Località: Udine

Precedente

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 35 ospiti