Pagina 1 di 1

Lettore DVD o HD non riconosciuto

MessaggioInviato: 11 apr 2016, 23:44
da schumy91
Salve, io vorrei aggiungere un HD al mio PC ma quando provo a collegarlo ad una delle due porte SATA rimaste vuote non viene letto, se invece lo collego alla porta cui è collegato il lettore DVD viene letto...però poi non viene letto il lettore DVD...cosa può essere? Come posso risolvere? Grazie

Re: Lettore DVD o HD non riconosciuto

MessaggioInviato: 13 apr 2016, 10:56
da flori2
Domanda stupida: Colleghi anche l'alimentazione? Dal bios si vedono?

Re: Lettore DVD o HD non riconosciuto

MessaggioInviato: 13 apr 2016, 17:44
da schumy91
Si collego anche l'alimentazione...da bios si vede ma dal PC no

Re: Lettore DVD o HD non riconosciuto

MessaggioInviato: 14 apr 2016, 10:03
da flori2
Cioe il sistema operativo non vede quello che vede il bios, ma secambi posta SATA si? Hai i driver aggiornati della scheda madre?

Re: Lettore DVD o HD non riconosciuto

MessaggioInviato: 14 apr 2016, 10:22
da Brianz
Se il disco è visto dal BIOS vuol dire che l'interfaccia funziona e il disco probabilmente anche.
Se non è visto dal s.o. sarà probabilmente perché non è inizializzato.
Ad esempio, in XP:
Pannello di controllo->Strumenti di amministrazione->Gestione computer->Gestione disco
e crei la partizione voluta

Da considerare anche che se il s.o. è XP o precedente il disco deve essere impostato nel BIOS come IDE o Legacy e non come AHCI. Da 7 in avanti il driver AHCI è integrato nel s.o.

Re: Lettore DVD o HD non riconosciuto

MessaggioInviato: 14 apr 2016, 12:16
da flori2
Brianz ha scritto:Se il disco è visto dal BIOS vuol dire che l'interfaccia funziona e il disco probabilmente anche.
Se non è visto dal s.o. sarà probabilmente perché non è inizializzato.
Ad esempio, in XP:
Pannello di controllo->Strumenti di amministrazione->Gestione computer->Gestione disco
e crei la partizione voluta

Da considerare anche che se il s.o. è XP o precedente il disco deve essere impostato nel BIOS come IDE o Legacy e non come AHCI. Da 7 in avanti il driver AHCI è integrato nel s.o.

L'utente dice che cambiando porta Sata il disco viene visto perciò dovrebbe la partizione dovrebbe esserci.

Re: Lettore DVD o HD non riconosciuto

MessaggioInviato: 14 apr 2016, 18:25
da Brianz
Vediamo allora i dettagli:
"provo a collegarlo ad una delle due porte SATA rimaste vuote non viene letto"

1. - Cosa voglia dire "non viene letto" lo sa dio. Diciamo che non viene visto dal s.o.?
Se è così, ma è visto dal BIOS, è evidente che o le porte sata non funzionano o fanno parte di uno di quegli assurdi accrocchi che fingono di effettuare un raid attraverso un chip addizionale. In questo caso potrebbe essere necessario un driver.

2. -"se invece lo collego alla porta cui è collegato il lettore DVD viene letto"
Ora. è evidente che, sempre intendendo per "letto" quanto prima, il port e il disco funzionano.

3. - "...però poi non viene letto il lettore DVD"
Siamo sempre nel lisergico. I port sata sono singoli e quindi o è collegato il DVD o è collegato il disco...
Se si deve lavorare di fantasia e intendere che è stato collegato il disco al port sata dove era collegato il dvd e collegato il dvd ad uno dei port liberi (che non funzionavano con il disco..); questo conferma quanto ho detto al punto 1.

La cosa può essere facilmente verificata conoscendo il modello della m/b.

Se i port liberi non necessitano di driver addizionale (cosa molto rara e presente solo in m/b vecchiotte), a parte qualsiasi altro tipo di errore dell' utente, non si può che dire che i port non funzionano.

Aggiungerei nella casistica delle mainboard vecchiotte quelle che avevano una condivisone delle risorse tra alcuni port sata e ide per cui da BIOS occorreva optare per una o l'altra interfaccia.

Basta leggere il manuale della m/b per risolvere la cosa.

Re: Lettore DVD o HD non riconosciuto

MessaggioInviato: 16 apr 2016, 18:58
da schumy91
Ho risolto eseguendo dal prompt dei comandi l'istruzione sfc /scannow

Re: Lettore DVD o HD non riconosciuto

MessaggioInviato: 16 apr 2016, 20:20
da Jno
schumy91 ha scritto:Ho risolto eseguendo dal prompt dei comandi l'istruzione sfc /scannow


:mrgreen: azz.... devo provare il comando con le chiavette USB ...visto mai che finalmente me le vede?

O_/