Pagina 77 di 78

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 23 lug 2020, 1:04
da DarwinNE
Grazie mille, Foto Utentedimaios!!!

Tengo in caldo il file, appena qualcuno confermerà che va tutto bene, lo pubblicherò molto volentieri.

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 23 lug 2020, 1:21
da claudiocedrone
Aggiungo una informazione solo a beneficio di inventario: per gli utenti (come me) con Windows 8.1 Java si è da poco aggiornato alla versione 8 aggiornamento 261 (build 1.8.0_261-b12);
chissà se prima che lo dismettano arriverà alla versione 9...

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 23 lug 2020, 8:39
da PietroBaima
grazie Foto Utentedimaios, sei veramente gentile, indipendentemente dal fatto che, purtroppo, una volta installato (l'installazione va a buon fine) il programma mi restituisca questo errore, quando clicco sull'icona per avviarlo:

java.jpg


Se posso rendermi ulteriormente utile sono ovviamente disponibile, dovete solo dirmi cosa devo fare.

Ciao,
Pietro.

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 23 lug 2020, 11:03
da dimaios
È il problema di cui ti ho parlato.
Se oltre alla Java JRE installi la SE il problema permane?
A me è sparito ma la soluzione è tutta da verificare.

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 23 lug 2020, 12:18
da PietroBaima
Devo installare la JRE (che ovviamente già avevo) ma anche il SE JDK, non capisco perché.

Comunque installandolo il problema si risolve.

Grazie!

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 23 lug 2020, 13:44
da DarwinNE
Questa versione di FidoCadJ richiede almeno Java 9, può essere che sia un problema di versioni?
Si può avere il testo dell'eccezione generata? Magari è scritto in qualche log.

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 25 lug 2020, 1:13
da dimaios
Ecco il log che ho ricavato utilizzando la versione 1.8.0_251 e 1.8.0_261-b12 della JRE.
Ho evidenziato il problema in rosso.

JavaError.png


Penso che Foto UtenteDarwinNE riesca a correggerlo.

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 25 lug 2020, 17:04
da DarwinNE
No, non posso correggerlo, FidoCadJ richiede come minimo Java 9.
E' stata una scelta ponderata, ci sono molti vantaggi ed abbiamo buttato via cose brutte e retaggi dal passato di cui non sentiremo la mancanza.
Java 9 è in giro da parecchi anni, non so per che ragione su Windows gli aggiornamenti si fermino alla versione precedente.

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 25 lug 2020, 19:56
da dimaios
Dunque .....
Sulla pagina link 1

C'è scritto quanto segue :

01 JRE.png


Andando quindi alla pagina link 2

Si può trovare la JRE 9 ....

02 JRE.png


Oppure in alternativa si può installare una Java SE recente ed "automagicamente" tutto funziona.

A questo punto non so se sia meglio scrivere delle istruzioni oppure fare l'embedding di ciò che serve in un unico file ma con la pubblicazione di software Oracle al di fuori del dominio Oracle come la mettiamo?

Forse sono meglio le istruzioni per non cercarsi rogne.

Re: Collaborate allo sviluppo FidoCadJ!

MessaggioInviato: 25 lug 2020, 22:21
da DarwinNE
Io opterei per la soluzione più semplice e meno rognosa per tutti!

Comunque, già che ci siamo, consiglierei di scegliere Java 14, che è l'ultima versione disponibile.