Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Amplificatore JLH (Linsley Hood) del 1969

hi-fi, luci, suoni, effetti speciali, palcoscenici...

Moderatori: Foto UtenteIsidoroKZ, Foto UtentePaolino

4
voti

[61] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto UtenteBrunoValente » 28 ago 2019, 11:35

Piercarlo ha scritto:A parte che per me non è un enigma ma, nei limiti in cui ci si può fidare di quanto viene prodotto da un simulatore, di un fatto che va spiegato e non eluso dando la colpa ad altro, ti vedo quasi a prendermi a martellate pur di convincermi della tua posizione....Il mio esortarti a prenderti una calmata è semplicemente dovuto al vederti infervorarti troppo su qualcosa che può essere visto in modi differenti


A parte il fatto che qui non si sta discutendo di politica ma di elettronica e che perciò le cose non possono essere viste in due modi differenti se le conclusioni a cui portano sono diverse, non mi pare proprio io abbia provato a convincerti di qualcosa, bensì ho solo cercato di esporre il mio punto di vista, che ritengo sia quello giusto altrimenti mi sarei astenuto, cercando di provare a dimostrarlo nel modo migliore che so fare... scusa se mi sono infervorato ma l'elettronica mi appassiona, credevo conoscessi questo mio difetto.

Piercarlo ha scritto:E il tirare in ballo Kirchhoff dove non centra niente mi convince sempre di più che tu stai vedendo questo circuito in maniera molto diversa da come la vedo io (che tra l'altro non vedo alcuna violazione di principi di chicchessia: in questo circuito quanto risulta nel grafico del messaggio [31] è perfettamente legittimo...


Che io stia vedendo quel circuito in maniera molto diversa da come lo stai vedendo tu è poco ma sicuro! E siccome credo che il mio modo di vederlo, a differenza del tuo, sia corretto, allora lo scrivo cercando di dimostrare le mie tesi, è forse vietato?

Per quanto riguarda Kirchhoff: ma ti pare possibile lo abbia potuto tirare in ballo solo per farti dispetto? Mi pare sia stato tu a riconoscere per primo quanto quei grafici siano assurdi, hai utilizzato addirittura l'aggettivo "imbarazzante"! Quindi credevo tu per primo ti riferissi alla violazione del primo principio di Kirchhoff... invece scopro ora che non stavi pensando a Kirchhoff e la cosa mi meraviglia alquanto.



Secondo Kirchhoff I3=I1-I2 Invece:

Grafico.png


Avresti potuto semplicemente chiedere chiarimenti o argomentare in qualche modo le tue perplessità invece di fare quella sparata del tutto inopportuna.
Avatar utente
Foto UtenteBrunoValente
32,3k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6243
Iscritto il: 8 mag 2007, 14:48

0
voti

[62] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto UtentePiercarlo » 28 ago 2019, 12:18

Boh, vedila come vuoi; io non penso di aver fatto "sparate" su niente. I grafici non me li sono inventati, li ho presi dalle schermate del mio PC e le ho postate, fine della storia. Ho scritto qui per capire come stavano le cose; alcune cose me le sono chiarite, per altre continuerò a cercare per conto mio... Tutto qui.

Buona giornata O_/
Avatar utente
Foto UtentePiercarlo
21,8k 6 10 13
CRU - Account cancellato su Richiesta utente
 
Messaggi: 5951
Iscritto il: 30 mar 2010, 19:23
Località: Milano

0
voti

[63] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto UtentePiercarlo » 28 ago 2019, 17:05

Faccio un ultimissimo tentativo per farmi capire non tanto da Bruno Valente quanto dagli altri che magari, bonta loro, vogliono capirci qualcosa come lo voglio io. Rispetto alle situazioni precedenti sono cambiate alcune piccole cose: 1) è stato inserito direttamente nello schema il modello del transistor finale che più si avvicina all'originale (il BD537 e il suo equivalente americano 2N6292) fornito da Onsemi. 2) il bootstrap è stato sostituito da un generatore di corrente. 3) il carico minimo da 100 ohm, prima facente parte della rete bootstrap è stato riarrangiato in modo da essere il solo carico effettivo in uscita propriamente connesso a massa.

Il modello inserito fornisce nel simulatore una corrente di riposo di circa 1.89 A, superiore di 600 mA rispetto a quanto prestabilito ma questo è quanto mi son trovato nel piatto e me lo tengo. Tra l'altro, diversamente da quanto mi aspettavo, il circuito NON risulta sensibile a resistenze inserite in serie all'emettitore di Q1.

Schema.png


Nell'oscillogramma, come in precedenza, è stata eliminata la componente continua di riposo uscente ed entrante nei transistor finali. Inoltre, per mostrare che la buonanima di Kirchhoff può riposare in pace come ha sempre fatto, è stata invertita la traccia di una delle variazioni di corrente sui finali in modo da sottolineare come la corrente sul carico in uscita da 100 ohm sia l'esatta differenza tra le correnti circolanti nei transistori finali - nelle quali sta l'inghippo vero e proprio: perché nonostante l'amplificatore sia retroazionato e le correnti circolanti nel carico (60 mA di picco) siano quelle richieste, sullo stadio di uscita "ballano" sincrone con il segnale, ben 150 mA? Da chi vengono richiesti?

Oscillogramma.png


Ho fatto inoltre un'altra prova prima di inviare il messaggio togliendo ogni carico effettivo (è rimasto solo quello, minino al limite del ridicolo,della corrente richiesta per alimentare la rete di retroazione). Il risultato è quello visibile nella figura sottostante:

Carico nullo.png


La leggerissima differenza tra le correnti residue è dovuta naturalmente a quanto assorbito dalla rete di retroazione. Per il resto vi sono qualcosa come circa 165 mA per una semionda e circa 90 miliampere per la semionda seguente che non sono giustificati da nessun carico che non siano i transistori finali stessi. Qualcuno ha una spiegazione per questo? Rimango in ascolto, grazie.
Avatar utente
Foto UtentePiercarlo
21,8k 6 10 13
CRU - Account cancellato su Richiesta utente
 
Messaggi: 5951
Iscritto il: 30 mar 2010, 19:23
Località: Milano

0
voti

[64] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto Utenteelfo » 28 ago 2019, 17:50

Piercarlo ha scritto: Per il resto vi sono qualcosa come circa 165 mA per una semionda e circa 90 miliampere per la semionda seguente che non sono giustificati da nessun carico che non siano i transistori finali stessi. Qualcuno ha una spiegazione per questo?

Ci sarebbero da fare millemila premesse tra cui - la piu' importante - che non ho - per mia sola incapacita' - capito bene il problema, ma avrei una domanda (iniziale):

A fronte del risultato della tua simulazione, quale sarebbe - invece - il risultato che ti saresti aspettato (diverso da quello della simulazione)?
Avatar utente
Foto Utenteelfo
2.924 2 4 7
Master
Master
 
Messaggi: 1282
Iscritto il: 15 lug 2016, 13:27

0
voti

[65] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto UtentePiercarlo » 28 ago 2019, 18:00

Mah, vista l'insistenza di Bruno, mi aspettavo che non ci fosse proprio nulla. Una sorta di prova dei fagioli contro possibili autoabbagli... Il fatto che anche nel caso più estremo (assenza completa del carico) invece qualcosa c'è, mi costringe a chiedere spiegazioni convincenti a chi ne sappia molto più di me.
Avatar utente
Foto UtentePiercarlo
21,8k 6 10 13
CRU - Account cancellato su Richiesta utente
 
Messaggi: 5951
Iscritto il: 30 mar 2010, 19:23
Località: Milano

0
voti

[66] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto Utenteelfo » 28 ago 2019, 18:05

Ti ringrazio per la risposta, ma ti chiedo cortesemente di esplicitare meglio il "nulla".

Sto cercando di capire meglio (e provare a trovare una spiegazione) il risultato della tua simulazione - che non mi sembra cosi' "strano" - ma al momento ho le idee confuse (e la possibile spiegazione lo e' ancora di piu' (confusa) :( )
Avatar utente
Foto Utenteelfo
2.924 2 4 7
Master
Master
 
Messaggi: 1282
Iscritto il: 15 lug 2016, 13:27

0
voti

[67] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto UtentePiercarlo » 28 ago 2019, 18:52

Elfo, ti rispondo con una prova appena fatta al simulatore con uno stadio di uscita in push-pull. Stessa condizione di lavoro, cioè carico di lavoro nullo.

Lo schema:

Schema PP.png


L'oscillogramma

Carico nulo in PP.png


Stesso fenomeno: circolano correnti nello stadio finale NONOSTANTE l'assenza di ogni carico. Anche qui urgono spiegazioni per un fenomeno che, se non è un artefatto di LTspice, probabilmente interessa tutti gli stadi finali a "totem" con transistori in serie tra le alimentazioni, o almeno quelli equipaggiati con bipolari che lavorano in classe A.
Avatar utente
Foto UtentePiercarlo
21,8k 6 10 13
CRU - Account cancellato su Richiesta utente
 
Messaggi: 5951
Iscritto il: 30 mar 2010, 19:23
Località: Milano

0
voti

[68] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto UtenteIsidoroKZ » 28 ago 2019, 19:33

BrunoValente ha scritto:Secondo Kirchhoff I3=I1-I2 Invece:


Nel grafico che hai riportato la curva azzurra non e` I1, ma -I1. Spice considera positive le correnti entranti nei morsetti dei transistori, quindi se prendi la corrente di emettitore Ie, questa e` positiva entrante nell'emettitore, quindi per un npn Ie e` negativa.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
104,0k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18479
Iscritto il: 17 ott 2009, 0:00

0
voti

[69] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto UtenteBrunoValente » 28 ago 2019, 20:22

Ok, grazie della precisazione, purtroppo non conosco Spice e non ho pensato ad una possibile inversione.
A questo punto però se I1 è invertita non riesco a capire cosa ci sia di strano in quel grafico.
Le differenze tra le due correnti nei transistor credo siano dovute al fatto che i transistor sono diversi e forse anche alla presenza di R3.
Avatar utente
Foto UtenteBrunoValente
32,3k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6243
Iscritto il: 8 mag 2007, 14:48

0
voti

[70] Re: Amplificatore JLH (Linsley Hood) del 1969

Messaggioda Foto UtentePiercarlo » 29 ago 2019, 18:34

elfo ha scritto:Ti ringrazio per la risposta, ma ti chiedo cortesemente di esplicitare meglio il "nulla".


Per "nulla" intendo esattamente dire "nulla". Una volta eliminato il carico e sottratte le correnti statiche di riposo, sull'oscillogramma doveva rimanere SOLO la corrente assorbita dalla rete di retroazione (cioè qualcosa in meno di mezzo milliampere). Invece ne rimane un bel po' di più che può solo provenire da un finale e finire direttamente dentro l'altro, come se uno fungesse da carico parassita dell'altro (peraltro di valore diverso per le due semionde di ciascun periodo).

Il tutto, si noti bene, in presenza di retroazione.
Avatar utente
Foto UtentePiercarlo
21,8k 6 10 13
CRU - Account cancellato su Richiesta utente
 
Messaggi: 5951
Iscritto il: 30 mar 2010, 19:23
Località: Milano

PrecedenteProssimo

Torna a Elettronica e spettacolo

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti