Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Opamp bruciati

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteBrunoValente, Foto Utentecarloc

0
voti

[1] Opamp bruciati

Messaggioda Foto UtenteFrenzi » 4 gen 2022, 1:14

Ciao a tutti, sto studiando la teoria relativa agli op-amp e ho cercato di sperimentare praticamente qualche conto che ho fatto, ma dopo aver fritto un paio di opamp credo di non aver capito qualcosa.
In particolare sto studiando la configurazione come amplificatore invertente; ho realizzato il circuito seguente con un opamp di recupero (mitsubishi 5218A) :


In uscita mi aspettavo una tensione di Vout = Vinput(-R2/R1) = -1.33V

finché non ho caricato l'uscita con RL i valori letti corrispondevano a quanto atteso. Quando ho applicato RL, l'uscita si è mantenuta al livello calcolato per un po' (diciamo circa 1 minuto), dopodiché l'opamp ha smesso di funzionare, senza surriscaldarsi o fare fumi strani; l'altro opamp contenuto nell'IC era ancora funzionante, ma anche questo ha avuto lo stesso identico comportamento. Ho riprovato con un secondo IC e anche lui ha fatto la medesima fine. Prima di distruggerne un 3° volevo capire cosa sto facendo di sbagliato.

Con il carico applicato, dovrebbe valere che:
>Vout = VL
>per il principio del cortocircuito virtuale V+ = V- == GND, quindi V2 = VOut

Chiamando I la corrente circolante sull'uscita dell'opamp, se scrivo la KCL del nodo di uscita ottengo:
I=IL-I2 = VOut(1/RL-1/R2) = 7.36mA
Quindi secondo i miei calcoli l'opamp sta assorbendo dall'uscita una corrente di 7.36 mA; dal datasheet riporta 90mW come potenza dissipabile tipica, ed io (se non capisco male) ne devo dissipare solo 1.33V*7.36mA=9.79mW . Allora perché si sono fusi?
Cosa sto sbagliando? Sono sicuro di non vedere qualcosa nei conti o di utilizzare un modello troppo semplice o sbagliato, ma non capisco il problema dove stia. Grazie a tutti per l'aiuto come sempre :)
Avatar utente
Foto UtenteFrenzi
183 6
Frequentatore
Frequentatore
 
Messaggi: 121
Iscritto il: 4 giu 2015, 11:52

2
voti

[2] Re: Opamp bruciati

Messaggioda Foto UtenteMarcoD » 4 gen 2022, 9:26

Bel letto Frenzi, provo a rispondere.
Chiamando I la corrente circolante sull'uscita dell'opamp, se scrivo la KCL del
nodo di uscita ottengo:
I=IL-I2 = VOut(1/RL-1/R2) = 7.36mA
Quindi secondo i miei calcoli l'opamp sta assorbendo dall'uscita una corrente di 7.36 mA; dal datasheet riporta 90mW come potenza dissipabile tipica, ed io (se non capisco male) ne devo dissipare solo 1.33V*7.36mA=9.79mW .

Provo a correggere i calcoli:

Vout = - 2 x (1k/1.5k) = - 1.33 V
I = 1,33 x( 1/ R2 + 1/RL ) = -1,33 x ( 1/1k + 1/150) = 0,010 A = 10 mA

Nell'operazionale, il transistor che " tiene giù l'uscita" alimentato dal -5V, dissipa
(-5 - (-1,33))x (- 0,01) = 3,67 x 0,01 = 0,0367 W = 36 mW
Verificate il procedimento e i conti.
Non ho cercato le caratteristiche del 5218A,
ma a cosa ti serve un carico di 150 ohm ?, relativamente gravoso.
E per R1 e R2, non puoi mettere 10k, e 15 k ?

Riguardo la causa del guasto non saprei, guardo nella palla di cristallo:
La RL è proprio da 150 ohm ?
Aumentala a 300 ohm , mettendo un secondo 150 ohm in serie.
Tensione di alimentazione maggiore di 5 V ?
O_/
Avatar utente
Foto UtenteMarcoD
10,3k 5 9 13
Master EY
Master EY
 
Messaggi: 5157
Iscritto il: 9 lug 2015, 16:58
Località: Torino

0
voti

[3] Re: Opamp bruciati

Messaggioda Foto Utentemicdisav » 4 gen 2022, 12:00

Ciao,
tra l'altro, il BJT "semi_push-pull" collegato a +Vcc ha un compito ancora più gravoso,
modificando opportunamente l'ultima relazione di MarcoD:
Pd_{(+5V)} = (+5 - (-1,33))\cdot (- 0,01) = 6.33 \cdot (-0,01) = 0.0633 W = 63.3 mW
In totale: 63.3 + 36 = 99.3 mW, riportando il ds una P_D tipica di 90 mW, il destino dell'operazionale era segnato.

Saluti, Michele.
Avatar utente
Foto Utentemicdisav
126 5
New entry
New entry
 
Messaggi: 96
Iscritto il: 17 giu 2020, 16:40

1
voti

[4] Re: Opamp bruciati

Messaggioda Foto UtenteMarcoD » 4 gen 2022, 13:07

Foto Utentemicdisav,
non sono certo che si applichi la somma delle potenze.
Il carico è connesso al comune alimentazioni.
Forse sono uno stadio complementare in classe B o AB, quando un transistor "tira" verso il basso assorbendo dal -5V , l'altro è interdetto (o conduce poco) e non dissipa.
Lo stesso quando un tr "tira in alto" assorbendo dal +5, l'altro non dissipa.
Ma occorre esaminare bene lo schema elettrico interno dell'operazionale. O_/
Avatar utente
Foto UtenteMarcoD
10,3k 5 9 13
Master EY
Master EY
 
Messaggi: 5157
Iscritto il: 9 lug 2015, 16:58
Località: Torino

0
voti

[5] Re: Opamp bruciati

Messaggioda Foto UtenteFrenzi » 4 gen 2022, 13:17

Grazie mille, non avevo assolutamente capito come calcolare la potenza dissipata; in pratica è come se internamente avessi un drop su una coppia di resistenze, una riferita all'alimentazione positiva ed una all'alimentazione negativa:
P_D=((V_{ss}-V_{out})+(V_{ee}-V_{out})) I
----------------------------
edit: ho visto ora il messaggio di MarcoD (che ringrazio).. in pratica bisogna studiare lo schema interno dell'opamp di caso in caso per capire come calcolare la potenza dissipata.
----------------------------
In qualsiasi caso (per rispondere al primo post di MarcoD) i valori scelti sono stati abbastanza "casuali" (ho preso le prime resistenze che ho trovato nel cassetto), era solo una prova pratica per vedere le differenze tra la teoria che sto studiando e la realtà delle cose.
Un'unica cosa... io ho sbagliato a calcolare la corrente Iperché ho usato il valore di R1 invece che di R2 (il valore corretto sarebbe 7.54 mA), ma i segni della KCL mi sembravano giusti, perché hai cambiato il verso di I_2?
Grazie per l'aiuto :ok:

P.S.: la potenza tipica dichiarata era di 90mW, ma la massima dissipabile era di 180mW, che comunque mi pare ben lontana dai valori in gioco (https://pdf1.alldatasheet.com/datasheet-pdf/view/908/MITSUBISHI/M5218.html)
Inoltre il datasheet riporta +-50mA come massima corrente assorbibile
Avatar utente
Foto UtenteFrenzi
183 6
Frequentatore
Frequentatore
 
Messaggi: 121
Iscritto il: 4 giu 2015, 11:52

2
voti

[6] Re: Opamp bruciati

Messaggioda Foto UtenteMarcoD » 4 gen 2022, 13:56

La direzione delle correnti è una convenzione,
per me le correnti ( con segno positovo) scorrono dal positivo al negativo.


La corrente I2 scorre da 0 V a -1,33 V come la corrente IL
la corrente I (somma di I2 e IL) va da -1,33 a -5V
Avatar utente
Foto UtenteMarcoD
10,3k 5 9 13
Master EY
Master EY
 
Messaggi: 5157
Iscritto il: 9 lug 2015, 16:58
Località: Torino

0
voti

[7] Re: Opamp bruciati

Messaggioda Foto UtenteFrenzi » 4 gen 2022, 17:29

#-o Scusami ho fatto confusione con la caduta di R2 e ovviamente è corretto come dici tu :ok:
Detto questo, continuo a non capire perché si sia bruciato, quando in teoria dovrebbero essere valori di corrente che rientrano nelle specifiche (per quanto siano alti ed "inusuali" per un opamp).

Ho provato a guardare lo schema interno dell'opamp e mi pare di capire che sia una specie di push-pull (vedi immagine in allegato) ma non ne sono sicuro...
In particolare mi sembra che nel caso l'ingresso invertente venga polarizzato assorbendo una piccolissima corrente, questo porti a polarizzare il transitor Q12 (suppendo di usare l'opamp numero 1), assorbendo quindi corrente dall'output 1 attraverso R7, riferendosi a -Vcc; ecco quindi la dissipazione di potenza interna all'opamp che calcolavi tu, come caduta su R7 (-Vcc-Vout) per la corrente assorbita (10mA).
Sempre nelle stesse condizioni, mi sembra che il transistor Q11 non venga polarizzato e non ci sia quindi nessun assorbimento dovuto al passaggio di corrente in R6; dovrei poter verificare questo fatto misurando la corrente assorbita su +Vcc e -Vcc (a meno delle correnti di polarizzazione dello "stadio amplificatore" interno) giusto?
In qualsiasi caso non capisco perché si sia bruciato
Allegati
M5218.png
Avatar utente
Foto UtenteFrenzi
183 6
Frequentatore
Frequentatore
 
Messaggi: 121
Iscritto il: 4 giu 2015, 11:52

0
voti

[8] Re: Opamp bruciati

Messaggioda Foto UtenteFrenzi » 4 gen 2022, 18:27

Potrebbe forse essere stato causato dal fatto che lasciavo scollegati i pin dell'altro opamp contenuto nell'IC?
Comunque ho simulato il circuito su circuitj, ed effettivamente tutto torna come da calcoli di MarcoD (nella simulazione ho utilizzato un Lm741 che mi sembra abbia uno schema elettrico compatibile con l'opamp che ho utilizzato io) .
Avatar utente
Foto UtenteFrenzi
183 6
Frequentatore
Frequentatore
 
Messaggi: 121
Iscritto il: 4 giu 2015, 11:52

0
voti

[9] Re: Opamp bruciati

Messaggioda Foto UtenteMarcoD » 4 gen 2022, 19:10

Potrebbe forse essere stato causato dal fatto che lasciavo scollegati i pin dell'altro opamp contenuto nell'IC?
E' possibile, ma improbabile.
Prova con un carico di 300 ohm e vedi come si comporta.
I cavi di connessione fra il +5V, -5V e comune con un alimentatore sono corti ?
Sei sicuro che la tensione sia +5 e -5 ?
Se no, meglio mettere condensatori da 1..10 uF fra i pin 4 e 8 e il comune per filtrare alimentazione ed evitare possibile innesco oscillazioni.
Montato su breadboard? Invia una immagine del circuito.
Compra componenti nuovi, magari LM358, tanto costano pochissimo.
Avatar utente
Foto UtenteMarcoD
10,3k 5 9 13
Master EY
Master EY
 
Messaggi: 5157
Iscritto il: 9 lug 2015, 16:58
Località: Torino

1
voti

[10] Re: Opamp bruciati

Messaggioda Foto Utentelelerelele » 4 gen 2022, 20:17

premesso lo danno per 50mA massimi di uscita, (quindi non continui), suppongo che il problema sia la deriva termica, essendo la potenza dissipata inversamente proporzionale alla temperatura, dopo un po salta, anche se i valori sono entro i limiti ammessi.

saluti.
Avatar utente
Foto Utentelelerelele
3.207 3 7 9
Master
Master
 
Messaggi: 3681
Iscritto il: 8 giu 2011, 8:57
Località: Reggio Emilia

Prossimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 54 ospiti