Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Progetto di un amplificatore: qualche parere?

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteBrunoValente

1
voti

[1] Progetto di un amplificatore: qualche parere?

Messaggioda Foto UtenteBerello » 26 mar 2009, 14:10

Salve!!! :mrgreen:
Mi sto addentrando da poco nell'elettronica; ho studiato sul libro Sedra-Smith, forse molti di voi lo conoscono.
Dopo la teoria, ho deciso di passare alla pratica e così come prima cosa ho pensato di fare un semplice amplificatore.

Prima di tutto ho preso un progetto di amplificatore trovato in un libro che avevo, ma tale progetto richiedeva un transistore che non ho trovato nei negozi e così l'ho sostituito con un altro simile al suo posto. Sbagliando, perché in tal modo l'amplificazione risultava rumorosa e con il taglio dei picchi.

Dopo questo primo intoppo, ho deciso di progettare un mio amplificatore con le conoscenze acquisite dalla teoria, basato sulle caratteristiche del transistore che avevo a disposizione al momento e aggiungendo un amplificatore "buffer", dato che il carico (un paio di cuffiette) è molto piccolo.

Ciò che ne è uscito fuori è questo:
http://berello.altervista.org/zztmp/amplificatore.htm
(spero che riusciate a vedere il circuito che ho disegnato)

Mi pare che funzioni bene, l'amplificazione c'è ed è abbastanza forte!
Perciò sono abbastanza soddisfatto, considerando che è il primo circuito che realizzo e allo stesso tempo anche il primo che progetto! 8) (scusate gli occhialetti, ma per un principiante è una piccola soddisfazione :mrgreen: )

Ora ecco il punto: si sente un rumore di sottofondo, una specie di fruscio, che non riesco ad eliminare (ho provato a mettere un condensatore in parallelo al carico, che è una cuffietta stereo da 32 ohm, quindi in totale 64 ohm mono, ma non è servito a niente).

Ho supposto che tale rumore potesse essere dovuto all'amplificazione e non al cattivo progetto, perché le interferenze del cellulare si sentono parecchio nelle cuffiette, ma restano i miei dubbi, soprattutto sapendo che sono un principiante e poi perché il fruscio non è il tipico rumore che si sente in una radio non rintonizzata, ma è (forse) leggermente più metallico o comunque diverso da quello di una radio.

Sapreste darmi suggerimenti?
Non solo riguardo al rumore, ma anche in generale accetto consigli e accorgimenti di ogni genere, per migliorare! :)

Grazie a tutti! :wink:
Avatar utente
Foto UtenteBerello
105 1 3 7
Expert EY
Expert EY
 
Messaggi: 449
Iscritto il: 3 mar 2009, 23:53
Località: Roma

0
voti

[2] Re: Progetto di un amplificatore: qualche parere?

Messaggioda Foto UtenteBrunoValente » 26 mar 2009, 16:00

Ciao Berello,
anzitutto posso dirti che per questo genere di circuiti non è assolutamente necessario essere così precisi con le resistenze: è sufficiente accontentarsi del valore commerciale più vicino a quello calcolato e non è necessario arrivare ad essere così precisi da montarne due in parallelo o in serie e poi c'è comunque di mezzo la loro tolleranza che in genere è del 5%.
Domande: il fruscio di cui parli si ascolta anche senza collegare nulla in ingresso? La resistenza Rsig è una resistenza vera montata nel tuo circuito o schematizza quella interna della sorgente del segnale? Da cosa prelevi il segnale? sapresti dire quanto è ampio il segnale di ingresso?
Avatar utente
Foto UtenteBrunoValente
31,9k 6 10 13
G.Master EY
G.Master EY
 
Messaggi: 6149
Iscritto il: 8 mag 2007, 14:48

0
voti

[3] Re: Progetto di un amplificatore: qualche parere?

Messaggioda Foto UtenteBerello » 26 mar 2009, 17:18

Una domandina: mi hai detto che non serve essere tanto precisi con le resistenze... Ma di quanto posso allontanarmi dai valori che calcolo? Per esempio: per la resistenza resistenza da 60 kohm del circuito in questione, avrei potuto approssimare con una da 47 kohm (è la più vicina che ho a disposizione) o è un valore troppo lontano? (a me sembra lontano, ma non avendo esperienza... Oppure potrei mettere in serie 47 e 10 kohm, così è più vicino)

Rispondo alle domande che mi hai fatto:
1) Il fruscio aumenta quando scollego il cavo da cui proviene l'audio!
2) La resistenza Rsig non è reale, l'ho messa nel circuito per rappresentare la resistenza interna del generatore di segnale. Aggiungere una resistenza lì avrebbe peggiorato l'amplificatore, vero?
3) Il segnale lo prelevo da un computer portatile, uscita per le cuffiette.
4) Non so dire quanto è ampio il segnale di ingresso, ma con l'amplificatore riesco ad ascoltarlo bene (senza sforzarmi, si sente bene) anche quando il volume del portatile è al minimo (il più basso volume prima del "muto"). Il fruscio rimane comunque.

Aggiungo che attualmente il circuito che sto provando è montato su una "breadboard", senza saldature, e che per verificare la differenza tra "amplificato e non amplificato" ho messo un deviatore che invia il segnale direttamente alle cuffiette oppure lo invia all'amplificatore che è poi collegato alle stesse cuffiette.
Quando sposto il deviatore su "senza amplificatore", il rumore dell'amplificatore aumenta tanto (come quando scollego il segnale in ingresso) e per sentire bene il segnale "non amplificato" devo scollegare l'alimentazione dell'amplificatore (che in quel momento genera solo rumore).

Emerge qualcosa? :mrgreen:
Vedo che mi hai chiesto se il rumore aumenta quando scollego il segnale di ingresso... Essendo "si" la risposta, mi sa che avrai qualcosa da dirmi! :mrgreen: :roll:
Avatar utente
Foto UtenteBerello
105 1 3 7
Expert EY
Expert EY
 
Messaggi: 449
Iscritto il: 3 mar 2009, 23:53
Località: Roma

0
voti

[4] Re: Progetto di un amplificatore: qualche parere?

Messaggioda Foto UtenteBrunoValente » 26 mar 2009, 18:04

Berello ha scritto:Una domandina: mi hai detto che non serve essere tanto precisi con le resistenze... Ma di quanto posso allontanarmi dai valori che calcolo? Per esempio: per la resistenza resistenza da 60 kohm del circuito in questione, avrei potuto approssimare con una da 47 kohm (è la più vicina che ho a disposizione) o è un valore troppo lontano?..

E' troppo lontano! infatti esiste un valore commerciale di 68K che andrebbe benissimo.


Berello ha scritto:Aggiungo che attualmente il circuito che sto provando è montato su una "breadboard", senza saldature, e che per verificare la differenza tra "amplificato e non amplificato" ho messo un deviatore che invia il segnale direttamente alle cuffiette oppure lo invia all'amplificatore che è poi collegato alle stesse cuffiette.
Quando sposto il deviatore su "senza amplificatore", il rumore dell'amplificatore aumenta tanto (come quando scollego il segnale in ingresso) e per sentire bene il segnale "non amplificato" devo scollegare l'alimentazione dell'amplificatore (che in quel momento genera solo rumore).

Questo mi lascia intendere che quando azioni il deviatore per escludere l'amplificatore l'uscita del portatile finisce in parallelo all'uscita dell'amplificatore, ho capito bene? se è così non va bene: devi utilizzare un doppio deviatore in modo da deviare anche l'uscita oltre che l'ingresso. Potresti completare lo schema aggiungendo il deviatore come è collegato ora?
Se tocchi il circuito con le mani il fruscio aumenta?
Si tratta effettivamente di fruscio (sssssss) o di ronzio (rrrrrr)?
Con cosa alimenti il circuito?
Avatar utente
Foto UtenteBrunoValente
31,9k 6 10 13
G.Master EY
G.Master EY
 
Messaggi: 6149
Iscritto il: 8 mag 2007, 14:48

0
voti

[5] Re: Progetto di un amplificatore: qualche parere?

Messaggioda Foto UtenteBerello » 28 mar 2009, 0:11

bruno valente ha scritto:E' troppo lontano! infatti esiste un valore commerciale di 68K che andrebbe benissimo.


Deduco che posso allontanarmi di circa il 10% dai valori calcolati. Grazie! :wink:



Come mi hai detto, ho collegato un secondo deviatore (non ho a disposizione un doppio deviatore, ma tanto al momento mi accontento di questo, solo per i tentativi "didattici").
Effettivamente accadeva come hai detto: l'uscita del portatile andava in parallelo all'uscita dell'amplificatore.

Siccome mi hai chiesto con cosa alimento il circuito, ho provato a sostituire l'alimentazione (che era un alimentatore con tensione regolabile da 3 V a 12 V, impostato su 9 V) con una batteria da 9 V (che però è abbastanza scarica: a vuoto restituisce 7,8 V, collegata all'amplificatore tra 5 e 6 V). Il fruscio è sparito! In realtà ce n'è uno molto leggero che a malapena si sente, ma credo che sia normale.

Attualmente, se ascolto l'uscita dell'amplificatore con l'ingresso scollegato, sento un ronzio abbastanza forte (anche alimentando con la batteria).
Mi viene una curiosità: se l'ingresso del mio amplificatore è scollegato, non dovrebbe essere equivalente a "segnale nullo"? Dunque l'amplificatore non dovrebbe amplificare un segnale nullo e quindi riportare a sua volta in uscita un segnale quasi nullo?



Prima di sostituire l'alimentatore con la batteria succedeva questo:
-Se toccavo la parte metallica del cavo che trasporta il segnale di ingresso il fruscio aumentava, diventava un ronzio e la sua tonalità diventava più bassa (più grave).
-Qualcosa di molto simile accadeva toccando i condensatori del circuito, soprattutto il primo.
-Provando a collegare l'uscita dell'amplificatore alla linea IN (azzurra) di un computer (per provare a registrare il suono) il fruscio aumentava notevolmente.
-Provando a scollegare l'interruttore della ciabatta a cui è attaccato l'alimentatore e provando a registrare dalla linea IN il segnale che esce dall'amplificatore, si sente comunque il ronzio! (senza alimentazione???)
-Provando a scollegare l'interruttore della ciabatta a cui è attaccato l'alimentatore e provando a registrare dalla linea IN il segnale che esce direttamente dall'alimentatore, si sente ancora lo stesso ronzio... (e allora è colpa dell'alimentatore!)
-Scollegando del tutto l'alimentatore dalla presa non si sente nulla (eh, beh! Mi pareva strano se avesse fatto ronzio anche in questo caso! La ciabatta deve avere qualche difetto nell'interruttore)...
-Ho provato l'alimentatore senza ciabatta e su un'altra presa di casa, ma si sente comunque il fruscio (e adesso sto notando che è più un ronzio che un fruscio).
-Ho pensato che potesse essere una forma di ripple, ma collegando un condensatore (1000 uF) all'alimentazione (un terminale al polo + e l'altro al polo -), in parallelo all'amplificatore, non cambia nulla, il rumore rimane.

Siccome ho comprato questo alimentatore per usarlo quando preparo circuiti "sperimentali", vorrei risolvere il problema, altrimenti non avrò modo di usarlo (e sarò costretto ad usare batterie su batterie per i miei "esperimenti"). Che posso fare?

Suppongo che potrei comprare un diodo zener per stabilizzare la tensione, ma l'alimentatore ne avrà sicuramente uno interno, perché aggiungendone uno dovrebbe cambiare qualcosa??? :oops:

Da cosa può dipendere il problema?

Grazie ancora!
Avatar utente
Foto UtenteBerello
105 1 3 7
Expert EY
Expert EY
 
Messaggi: 449
Iscritto il: 3 mar 2009, 23:53
Località: Roma

1
voti

[6] Re: Progetto di un amplificatore: qualche parere?

Messaggioda Foto UtenteBrunoValente » 28 mar 2009, 13:35

Da quello che dici, visto che si tratta un po' di ronzio, un po' di fruscio e poi le cose cambiano quando tocchi il circuito, credo che potrebbe dipendere tutto da una autooscillazione ad alta frequenza.
Procurati anzitutto una pila da 9V carica in modo da riportare l'ampl. alle normali condizioni di funzionamento e verifica cosa si ascolta di diverso rispetto all'alimentatore.
Mi pare che il guadagno dell'ampl. sia eccessivo rispetto a quello che serve e questo favorisce senz'altro le autooscillazioni dei circuiti che danno poi come effetto proprio la presenza di fruscio, del ronzio e una certa distorsione del segnale audio.
A questo, forse, si unisce un cablaggio non fatto a regola d'arte rispetto a questi problemi: hai chiuso il circuito in un contenitore metallico collegato con la massa? Hai usato un cavo schermato per il segnale di ingresso?
Il tuo circuito, così come lo hai disegnato, è teorico e in pratica necessita di qualche ulteriore accorgimento come puoi vedere dallo schema che segue.
ampl.cuffia.jpg
ampl.cuffia.jpg (10.01 KiB) Osservato 1074 volte

Ti ho aggiunto dei condensatori e delle resistenze che servono a filtrare l’alimentazione dal ronzio ma anche e soprattutto a disaccoppiare gli stadi: il difetto più comune è dovuto ad un accoppiamento indesiderato tra gli stadi attraverso l’alimentazione che porta i transistor ad oscillare.
I condensatori devi montarli vicino al circuito con collegamenti brevi.
Ho aggiunto anche una resistenza in serie al condensatore di emettitore del primo transistor che serve a diminuire il guadagno: potrai trovare il valore adatto sperimentalmente cercando di rendere il guadagno più basso possibile in funzione delle tue esigenze, dovrai cioè far suonare l’amplificatore al massimo volume con i controlli di volume dei circuiti a monte regolati per il massimo e non a metà corsa o per il minimo come immagino avvenga ora con un guadagno troppo alto.
Un commento all’amplificatore: è una soluzione che poco si adatta a pilotare carichi a bassa impedenza come le cuffie. E’ vero che l’inseguitore di emettitore esce a bassa impedenza ma se, come in questo caso, il valore della resistenza che polarizza l’emettitore è molto più alto di quello del carico (solitamente le cuffiette hanno impedenza che va da 10 a 50ohm) allora si riduce molto la dinamica: vuol dire che appena si tenta di alzare il volume inizia a distorcere.
Con questo non voglio disprezzare il circuito che, se come mi sembra di capire è uno dei tuoi primi progetti, va più che bene, voglio solo dire che per pilotare carichi a bassa impedenza con una maggiore dinamica esistono altre soluzione, ovviamente più complicate.
Ciao
Avatar utente
Foto UtenteBrunoValente
31,9k 6 10 13
G.Master EY
G.Master EY
 
Messaggi: 6149
Iscritto il: 8 mag 2007, 14:48


Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 40 ospiti