Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Problema con relè 12V

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto Utenteg.schgor, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto UtenteBrunoValente

0
voti

[51] Re: Problema con relè 12V

Messaggioda Foto UtenteDaMMaN » 12 apr 2020, 14:05

Ditemi cos'è che non vi torna che ve lo spiego senza problemi...
Avatar utente
Foto UtenteDaMMaN
0 2
 
Messaggi: 26
Iscritto il: 4 apr 2020, 1:56

0
voti

[52] Re: Problema con relè 12V

Messaggioda Foto UtentePietroBaima » 12 apr 2020, 14:55

mi disegni sullo schema, il diodo che scalda?
Generatore codice per articoli:
nomi
emoticon
citazioni
formule latex

Io capisco le cose per come le scrivete. Per esempio: K sono kelvin e non chilo, h.z è la costante di Planck per zepto o per la zeta di Riemann e l'inverso di una frequenza non si misura in siemens.
Avatar utente
Foto UtentePietroBaima
79,5k 6 12 13
G.Master EY
G.Master EY
 
Messaggi: 9960
Iscritto il: 12 ago 2012, 1:20
Località: Londra

0
voti

[53] Re: Problema con relè 12V

Messaggioda Foto UtenteDaMMaN » 12 apr 2020, 16:52

Eccolo qua, l'ho indicato con D3:



In pratica se io invece del diodo metto un filo, a macchina spenta sembra funzionare tutto correttamente, mentre a macchina accesa, quando accendo la plafoniera, il relè sfarfalla 5-6 volte e poi si spegne e non riparte più fino al successivo riavvio dell'auto. Se invece metto un diodo al posto del collegamento diretto (come da schema sopra) sembra funzionare anche a macchina accesa, ma il diodo scalda tanto.

Volevo quindi sapere se era il collegamento ad essere sbagliato oppure il tipo di diodo utilizzato che non è corretto.

Grazie mille per l'aiuto.
Avatar utente
Foto UtenteDaMMaN
0 2
 
Messaggi: 26
Iscritto il: 4 apr 2020, 1:56

0
voti

[54] Re: Problema con relè 12V

Messaggioda Foto UtentePietroBaima » 12 apr 2020, 16:59

Adesso ho capito.
Utilizza un relay a doppio scambio, in modo da togliere gli schottky.
Generatore codice per articoli:
nomi
emoticon
citazioni
formule latex

Io capisco le cose per come le scrivete. Per esempio: K sono kelvin e non chilo, h.z è la costante di Planck per zepto o per la zeta di Riemann e l'inverso di una frequenza non si misura in siemens.
Avatar utente
Foto UtentePietroBaima
79,5k 6 12 13
G.Master EY
G.Master EY
 
Messaggi: 9960
Iscritto il: 12 ago 2012, 1:20
Località: Londra

0
voti

[55] Re: Problema con relè 12V

Messaggioda Foto UtenteDaMMaN » 12 apr 2020, 18:38

Ma il problema non sono i due Schottky, il problema è il relè. Dici che con un relè a doppio scambio potrei risolvere? Come dovrei collegarlo?
Avatar utente
Foto UtenteDaMMaN
0 2
 
Messaggi: 26
Iscritto il: 4 apr 2020, 1:56

0
voti

[56] Re: Problema con relè 12V

Messaggioda Foto UtentePietroBaima » 12 apr 2020, 19:35

Perdonami, ma adesso non riesco a disegnarti uno schema, perché sono da cellulare.
Devi collegare il secondo scambio in modo che commuti fra 12V plafoniera e 12V sotto chiave.
Generatore codice per articoli:
nomi
emoticon
citazioni
formule latex

Io capisco le cose per come le scrivete. Per esempio: K sono kelvin e non chilo, h.z è la costante di Planck per zepto o per la zeta di Riemann e l'inverso di una frequenza non si misura in siemens.
Avatar utente
Foto UtentePietroBaima
79,5k 6 12 13
G.Master EY
G.Master EY
 
Messaggi: 9960
Iscritto il: 12 ago 2012, 1:20
Località: Londra

0
voti

[57] Re: Problema con relè 12V

Messaggioda Foto UtenteDaMMaN » 12 apr 2020, 20:32

Ok, ho capito come dici di collegarlo, ma non capisco perché in quel modo dovrebbe funzionare. Non ho comunque il solito collegamento sul GND che mi dava problemi, quello con il diodo D3?
Avatar utente
Foto UtenteDaMMaN
0 2
 
Messaggi: 26
Iscritto il: 4 apr 2020, 1:56

0
voti

[58] Re: Problema con relè 12V

Messaggioda Foto UtenteDaMMaN » 14 apr 2020, 11:38

Nessuno che mi sappia spiegare qual è il problema?
Avatar utente
Foto UtenteDaMMaN
0 2
 
Messaggi: 26
Iscritto il: 4 apr 2020, 1:56

0
voti

[59] Re: Problema con relè 12V

Messaggioda Foto UtenteBrunoValente » 14 apr 2020, 13:28

Non ti risponde nessuno perché non si capisce niente, devi essere più chiaro: quale è il segnale PVM? Quando arriva la tensione "12V sottochiave", quella "12V plafoniera" rimane o no? Perché quel regolatore di velocità è collegato in quel modo? Il regolatore di luminosità regola sul polo negativo o sul polo positivo? Se regola sul negativo vuol dire che il positivo è passante? E, viceversa, se regola sul positivo vuol dire che il negativo è passante? Hai verificato se i led hanno la resistenza in serie di limitazione della corrente? Sono in grado di funzionare regolarmente anche a 14V o succede che la corrente aumenta molto?

Se non ti sei posto queste domande vuol dire che non stai capendo né come sta o non sta funzionando, né come dovrebbe funzionare e se non dai a noi queste informazioni vuol dire che non possiamo capire neanche noi.
Avatar utente
Foto UtenteBrunoValente
33,0k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6430
Iscritto il: 8 mag 2007, 14:48

0
voti

[60] Re: Problema con relè 12V

Messaggioda Foto UtenteDaMMaN » 14 apr 2020, 17:12

Ma come non si capisce niente?? Se non avete capito chiedete pure no, se nessuno mi risponde come faccio a chiarirvi i dubbi?

Allora...ci riprovo...

I segnali sono i seguenti:

- 12V sotto-chiave: segnale (non PWM) che normalmente è 0V e che va a 12V-12,5V quando la macchina viene accesa

- 12V plafoniera: segnale preso dalla plafoniera dell'auto. Quando la plafoniera è spenta è 0V, quando la plafoniera è accesa sale gradualmente a circa 12,5V a macchina spenta e a circa 14,5V a macchina accesa.
Quando la luce viene spenta torna gradualmente a 0V. E' un segnale PWM.

- GND: è in pratica la carrozzeria della macchina, usata come massa.

Ovviamente può succedere che le tensioni sotto-chiave e quella della plafoniera siano presenti entrambe, nel caso in cui io accenda la plafoniera con la macchina accesa.

Io vorrei comandare le 4 strisce LED (che hanno già le loro resistenze integrate e sono comandate direttamente a 12V) sia a macchina accesa tramite un regolatore di luminosità (impostando così la luminosità da 0% al 100%), sia tramite il segnale da plafoniera, accendendo in questo caso le strisce LED al massimo della luminosità.

Vi spiego per punti il funzionamento:

- a macchina spenta e chiusa i LED sono spenti, non appena apro la macchina con la chiave si accende la luce di cortesia (questo lo fa la centralina della macchina) e quindi i LED si accendono al massimo tramite il segnale della plafoniera. Il regolatore non è ancora alimentato perché la macchina è ancora spenta.

- salgo in macchina, chiudo lo sportello e la luce di cortesia si spegne, quindi si spengono anche le strisce LED.

- metto in moto la macchina, il segnale sotto-chiave va a 12V e il regolatore viene così alimentato. A questo punto è quindi possibile accendere e spegnere le strisce LED tramite la manopola del regolatore e impostarne la luminosità da 0% a 100%.

- se mentre la macchina è in moto (magari con le strisce LED impostate al 30%) accendo la plafoniera, le strisce LED devono andare al massimo della luminosità tramite il segnale della plafoniera.

- se mentre la macchina è in moto e le strisce LED sono spente dalla manopola del regolatore, accendo la plafoniera, le strisce LED devono andare al massimo della luminosità tramite il segnale della plafoniera.

- quando spengo la macchina il regolatore non è più alimentato perché non c'è più tensione sul sotto-chiave e quindi le strisce LED si spengono, ma non appena tolgo la chiave si riaccende la luce di cortesia (questo lo fa la centralina della macchina) che mi fa così accendere al massimo le strisce LED.

- appena scendo dall'auto e la chiudo la luce di cortesia di spegne e di conseguenza anche le strisce LED.

Questo è il funzionamento che vorrei ottenere.

Il regolatore di luminosità è collegato in quel modo perché regola sul negativo, quindi ho portato al positivo dei LED sia l'uscita positiva del regolatore, sia il 12V della plafoniera (ho messo i dui Schottky per evitare ritorni di corrente su regolatore o plafoniera). Poi tramite il relè (comandato dal segnale della plafoniera) vado a commutare tra l'uscita negativa del regolatore (che è quella che regola) e il negativo generale (carrozzeria della macchina).

Quindi normalmente alle strisce LED è collegato il negativo del regolatore (tramite il contatto NC del relè), mentre quando accendo la plafoniera la bobina del relè viene eccitata, il regolatore viene disconnesso e alle strisce LED mi trovo collegato il 12V della plafoniera e il GND generale (tramite il contatto NO del relè).

Per il momento sembra funzionare tutto come descritto sopra, l'unico problema è quello che avevo scritto negli altri post e cioè che a macchina spenta funziona tutto regolarmente, mentre a macchina accesa la parte di regolazione sotto-chiave funziona correttamente, mentre quando accendo la plafoniera il relè sfarfalla (i LED si accendono e si spengono velocemente per 5-6 volte) e poi i LED si spengono definitivamente per non accendersi più (se non al successivo riavvio dell'auto).

Ho notato che questo problema non lo da se tolgo il ponticello tra il GND della bobina e il contatto NO del relè, ma ovviamente il quel caso il circuito è interrotto e quindi i LED non si accendono con la luce di cortesia.

Se invece quel ponticello lo sostituisco con un diodo (quello indicato nello schema con D3) sembra funzionare tutto perfettamente, ma il diodo scalda un casino (un 1N4148 è arrivato a più di 100°, mentre provando con un 1N4007 ho misurato circa 70°).

Ecco, questo è tutto...stavolta spero di essere stato abbastanza chiaro, ma per qualsiasi altro dubbio chiedete pure.

Grazie mille a chi potrà aiutarmi.
Avatar utente
Foto UtenteDaMMaN
0 2
 
Messaggi: 26
Iscritto il: 4 apr 2020, 1:56

PrecedenteProssimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 39 ospiti