Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Sensing di corrente con media

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteBrunoValente

2
voti

[141] Re: Sensing di corrente con media

Messaggioda Foto UtenteEnChamade » 28 mag 2012, 23:13

Ste75 ha scritto:Però mi aspettavo che le due tensioni sui pin invertente e non invertente del OPAMP che fa la compensazione, fossero "virtualmente uguali".... invece no (4.8V e 900mV) ?!?!?!?! :shock: :shock: :shock:

?% ?% ?%
Sei sicuro delle misure che hai postato? Come le hai eseguite? Quell'operazionale, con una diferenziale d'ingresso così alta, deve essere per forza saturo. Ammetto di non averci pensato molto, ma non mi spiego per quale assurdo motivo decida di portarsi a 4V in uscita con un ingresso così sbilanciato. Però, come mi hanno sempre detto, "il circuito ha sempre ragione!" (piccolo momento di venerazione iOi ) e quindi stiamo trascurando qualcosa.

Ste75 ha scritto:Non so in che modo strano stava funzionando il circuito... sta di fatto che regolava benissimo.
Nonostante il variare di Vref l'uscita non si muoveva al decimo di volt!!!

Non so se sia una caratteristica positiva ne tantomeno se sia affidabile come comportamento. Il fatto poi che tu debba impostare la resistenza di controllo (il trimmer per intenderci) intorno a 300ohm la dice lunga...

Ste75 ha scritto:Ora invece, che ho messo a posto il circuito realizzato, tutto è come da teoria:
i due ingressi del comparatore, si inseguono, la resistenza R2 devo metterla intorno a 5K.
PERO' ora al variare della Vin, la Vzener si muove di qualche mV e quindi anche l'uscita (6V) si muove di conseguenza...(passo da una Vin di 10V a 16V e Vout da 5.9V a 6.4V).
Ok, è giusto che sia cosi perché lo zener non è superpreciso e stabile, però la cosa che fa ridere è che era meglio prima...

In effetti, ora mi sembra abbastanza sensato il discorso e il comportamento sembra, come dire, più reale! :mrgreen: :mrgreen:
Hai per caso provato a ripristinare la resistenza del compensatore come da primo progetto? Te lo chiedo perché, da rapidi calcoli, dovresti diminuire il margine di fase quando alzi la Vin ma rimanere comunque stabile. Altra cosa, hai provato a variare il carico nel prototipo corretto? Tutto ok?
Avatar utente
Foto UtenteEnChamade
5.838 2 8 12
G.Master EY
G.Master EY
 
Messaggi: 507
Iscritto il: 18 giu 2009, 12:00
Località: Padova - Feltre

1
voti

[142] Re: Sensing di corrente con media

Messaggioda Foto UtenteSte75 » 29 mag 2012, 8:47

Ciao.

EnChamade ha scritto:Sei sicuro delle misure che hai postato? Come le hai eseguite? Quell'operazionale, con una diferenziale d'ingresso così alta, deve essere per forza saturo.


Le misure delle due tensioni ai pin invertente e non invertente del compensatore le ho fatte sia con oscillo che con multimetro. Tra riferimento negativo del circuito e quei due punti. Ho anche misurato, con multimetro, la tensione "differenziale" tra i due ingressi del comparatore ... ed effettivamente era cosi... sbilanciata! mah!

Avevo pensato ad un errore nella realizzazione del circuito... ho iniziato a guardare, ed ho beccato l'inversione dei due pin. L'ho sistemato, ed ora è come "da teoria". Quindi non so se ora ci possano essere altri errori nel circuito realizzato, però controllo.


EnChamade ha scritto: Ammetto di non averci pensato molto, ma non mi spiego per quale assurdo motivo decida di portarsi a 4V in uscita con un ingresso così sbilanciato. Però, come mi hanno sempre detto, "il circuito ha sempre ragione!" (piccolo momento di venerazione iOi ) e quindi stiamo trascurando qualcosa.


Dai... non ci credo che non vuoi andare a fondo su questa cosa.... :D :D
Magari ne salta fuori qualcosa di interessante.
Io sono la tua mano, tu guidamela, e vediamo se capiamo cosa succedeva! ;-) ;-)

EnChamade ha scritto:Non so se sia una caratteristica positiva ne tantomeno se sia affidabile come comportamento. Il fatto poi che tu debba impostare la resistenza di controllo (il trimmer per intenderci) intorno a 300ohm la dice lunga...


Effettivamente...

EnChamade ha scritto:In effetti, ora mi sembra abbastanza sensato il discorso e il comportamento sembra, come dire, più reale! :mrgreen: :mrgreen:
Hai per caso provato a ripristinare la resistenza del compensatore come da primo progetto? Te lo chiedo perché, da rapidi calcoli, dovresti diminuire il margine di fase quando alzi la Vin ma rimanere comunque stabile. Altra cosa, hai provato a variare il carico nel prototipo corretto? Tutto ok?


Se rimetto la resistenza originale del compensatore (era da 1K) e aumento Vin a circa 14-15V all'accensione del circuito, o al passaggio da NO load a pieno carico, l'uscita oscilla intorno al valore di 6V con una freq di 16kHz e ampiezza di 2V.
Se scendo con la Vin, l'oscillazione sparisce e rimane solo il 200mV della fsw.
Oppure se rimetto 500R, l'oscillazione non c'è più.

Ora, lasciando la 500 ohm e variando il carico rimango stabile da no load a pieno carico (370mA). Quando chiedo una corrente media in uscita minore di circa 100mA, passo in discontinuo.

Altro dato misurato con il prototipo attuale (corretto) e con resistenza sul compensatore da 500 ohm: al passaggio da no load a pieno carico, ho un "buco" sulla vout di circa 1.5V con qualche ocillazione che poi entro 1ms si ristabilizza a 6V.

Ciao
"perché un uomo è grande, GRANDE davvero, quando ritorna bambino di nuovo". Zecchino d'oro '87
Avatar utente
Foto UtenteSte75
2.450 7 13
Master
Master
 
Messaggi: 214
Iscritto il: 7 dic 2007, 12:31
Località: Monza e Brianza

2
voti

[143] Re: Sensing di corrente con media

Messaggioda Foto UtenteEnChamade » 30 mag 2012, 12:17

Ste75 ha scritto:Dai... non ci credo che non vuoi andare a fondo su questa cosa.... :D :D
Magari ne salta fuori qualcosa di interessante.
Io sono la tua mano, tu guidamela, e vediamo se capiamo cosa succedeva! ;-) ;-)

Non ho detto questo, anzi... Ho solo osservato che il circuito ha ragione a funzionare in quel modo è che a noi sfugge qualcosa. Quando ho un po' più di tempo, ci ragioniamo.

Ste75 ha scritto:Se rimetto la resistenza originale del compensatore (era da 1K) e aumento Vin a circa 14-15V all'accensione del circuito, o al passaggio da NO load a pieno carico, l'uscita oscilla intorno al valore di 6V con una freq di 16kHz e ampiezza di 2V.
Se scendo con la Vin, l'oscillazione sparisce e rimane solo il 200mV della fsw.
Oppure se rimetto 500R, l'oscillazione non c'è più.

Io, onestamente, mi sentirei più sicuro se riprogetti il compensatore considerando la massima V_{in} prevista per tale circuito.Così da avere tutto sotto controllo...
Ora, se puoi, procurati le cose che ti ha detto Foto UtenteIsidoroKZ e procediamo alla misura del crossover. Cerchiamo di arrivare in fondo al progetto :mrgreen: :mrgreen:.

Ste75 ha scritto:Altro dato misurato con il prototipo attuale (corretto) e con resistenza sul compensatore da 500 ohm: al passaggio da no load a pieno carico, ho un "buco" sulla vout di circa 1.5 V con qualche ocillazione che poi entro 1ms si ristabilizza a 6V.

Questo è corretto. :ok: Quando sei a no load, il convertitore funziona in DCM e di fatto il controllo impone un dutycycle allo scopo di mantenere l'uscita alla tensione prevista. Nel momento in cui tu attacchi il pieno carico, il controllo, che poverino ha una banda limitata, ha bisogno di un po' di tempo per portare il sistema a regime sul nuovo punto di lavoro. Ma nel frattempo il carico richiede energia. E allora dove viene recuperata questa energia? Ovviamente dal condensatore che non può fare altro che abbassare la tensione ai suoi capi... Ma nel frattempo il sistema di controllo tenta di compensare questo calo instaurando così un piccolo transitorio oscillatorio.
Nel passaggio da full-load a no-load dovresti notare un overshoot dato invece dal trasferimento dell'energia nell'induttore sul condensatore.
Avatar utente
Foto UtenteEnChamade
5.838 2 8 12
G.Master EY
G.Master EY
 
Messaggi: 507
Iscritto il: 18 giu 2009, 12:00
Località: Padova - Feltre

Precedente

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Google Feedfetcher, MSN [Bot] e 15 ospiti