Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Problemi amplificatore audio TDA2009

hi-fi, luci, suoni, effetti speciali, palcoscenici...

Moderatori: Foto UtenteIsidoroKZ, Foto UtentePaolino

0
voti

[11] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utentesteve95 » 29 dic 2012, 16:29

Innanzitutto grazie per le risposte; ho usato molte volte la breadboard a scuola, ma di quei particolari accorgimenti non sapevo quasi nulla...ho raschiato con una lama i reofori dei componenti (a parte l'integrato), e ho notato che subito sono diventati molto più lucidi; addirittura sulle resistenze ho trovato tracce di colla...poi ho messo a massa il piedino 7, che dovrebbe essere "morto" ma che vedo collegato così nella figura 2 del datasheet. Apparentemente nessuna differenza nel non-funzionamento...
Ho infine unito, sempre secondo il layout del PCB, la massa del segnale audio con quella dell'alimentatore: avevo già provato ieri un paio di volte, con l'unico risultato di ottenere un fracasso insopportabile dalle casse. Ora si sente decisamente meglio, e a volume più alto, ma ancora distante da quello che si ottiene escludendo l'amplificatore e collegando le casse direttamente all'uscita audio.
Ho verificato con il multimetro e i pin 6 e 9 sono rispettivamente a ground e a Vcc (15V al momento), come dovrebbero essere. La corrente circolante però rimane molto bassa, circa 80mA...
Avatar utente
Foto Utentesteve95
166 3
New entry
New entry
 
Messaggi: 55
Iscritto il: 28 dic 2012, 17:39

0
voti

[12] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utenteclaudiocedrone » 29 dic 2012, 16:51

:shock: Ho letto bene :?: Stai entrando in un finale con l'uscita di un altro finale :?: Non puoi farlo ! Devi almeno interporre un partitore resistivo (da calcolare); inoltre da quello che hai scritto (p. es. sulle masse) deduco che hai fatto il passo più lungo della gamba, non hai basi teoriche sufficienti e al tuo livello conviene pensare ai montaggi in kit più che ai datasheet, con i kit e i loro schemi puoi intraprendere l'analisi dei circuiti e delle soluzioni adottate dai progettisti per farti il know-how necessario a "muoverti con le tue gambe", studia ! O_/
"Non farei mai parte di un club che accettasse la mia iscrizione" (G. Marx)
Avatar utente
Foto Utenteclaudiocedrone
14,7k 4 6 9
Master EY
Master EY
 
Messaggi: 10156
Iscritto il: 18 gen 2012, 13:36

0
voti

[13] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utentesteve95 » 29 dic 2012, 17:41

claudiocedrone ha scritto::shock: Ho letto bene :?: Stai entrando in un finale con l'uscita di un altro finale :?: Non puoi farlo ! Devi almeno interporre un partitore resistivo (da calcolare); inoltre da quello che hai scritto (p. es. sulle masse) deduco che hai fatto il passo più lungo della gamba, non hai basi teoriche sufficienti e al tuo livello conviene pensare ai montaggi in kit più che ai datasheet, con i kit e i loro schemi puoi intraprendere l'analisi dei circuiti e delle soluzioni adottate dai progettisti per farti il know-how necessario a "muoverti con le tue gambe", studia ! O_/

Bè, non sono certo esperto...ma non pensavo servissero tutte queste conoscenze, una volta che si ha il circuito dal datasheet; ovvio che con un po' di esperienza si eviterebbero errori banali...prima di iniziare il lavoro mi sono comunque informato, non sono andato a caso sperando che poi in qualche modo funzionasse. Comunque mi interesserebbe far funzionare il circuito, dato che ho delle casse inutilizzate e quelle del PC stanno tirando le cuoia, facendo ovviamente esperienza con l'elettronica in generale, per poi magari realizzare qualche altro progetto che ho in mente...
Ho collegato l'uscita delle cuffie del PC direttamente alle casse passive (che, visto che non l'ho ancora scritto, sopportano 8W massimi e hanno impedenza di 4ohm), giusto per verificare il collegamento jack-breadboard e per farmi un'idea di quanto dovrebbe amplificare...l'amplificatore :-)
Per il discorso delle masse, avevo letto in un forum (inglese mi pare), ancora prima di acquistare il materiale, che era meglio tenerle separate, non ricordo più per quale motivo, cosa che io ho fatto...
Avatar utente
Foto Utentesteve95
166 3
New entry
New entry
 
Messaggi: 55
Iscritto il: 28 dic 2012, 17:39

0
voti

[14] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utenteabusivo » 29 dic 2012, 18:02

steve95 ha scritto:...avevo letto in un forum inglese mi pare...

Ma io faccio ancora fatica con l'italiano!
Avatar utente
Foto Utenteabusivo
8.875 4 4 7
Master
Master
 
Messaggi: 4953
Iscritto il: 16 ott 2012, 18:43
Località: L'Aquila

0
voti

[15] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utentesteve95 » 29 dic 2012, 18:05

abusivo ha scritto:
steve95 ha scritto:...avevo letto in un forum inglese mi pare...

Ma io faccio ancora fatica con l'italiano!

:?:
Non ho capito il senso del tuo intervento ?%
Avatar utente
Foto Utentesteve95
166 3
New entry
New entry
 
Messaggi: 55
Iscritto il: 28 dic 2012, 17:39

0
voti

[16] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utenteabusivo » 29 dic 2012, 18:15

Non metto in dubbio la tua conoscenza della lingua inglese.
Quello che voglio dire è che quando ci si imbatte in un argomento che non è proprio, è meglio abbattere alcuni ostacoli.
Sovente mi capitano interlocutori in lingua inglese ed intervengo solo se la materia la conosco bene.
In tutti gli altri casi rimango in silenzio passando per scemo piùttosto che aprire bocca e fugare ogni dubbio!
Avatar utente
Foto Utenteabusivo
8.875 4 4 7
Master
Master
 
Messaggi: 4953
Iscritto il: 16 ott 2012, 18:43
Località: L'Aquila

0
voti

[17] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utenteclaudiocedrone » 29 dic 2012, 18:16

:D Studia :!: :mrgreen: O_/
"Non farei mai parte di un club che accettasse la mia iscrizione" (G. Marx)
Avatar utente
Foto Utenteclaudiocedrone
14,7k 4 6 9
Master EY
Master EY
 
Messaggi: 10156
Iscritto il: 18 gen 2012, 13:36

0
voti

[18] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utentesteve95 » 29 dic 2012, 18:47

abusivo ha scritto:Non metto in dubbio la tua conoscenza della lingua inglese.
Quello che voglio dire è che quando ci si imbatte in un argomento che non è proprio, è meglio abbattere alcuni ostacoli.
Sovente mi capitano interlocutori in lingua inglese ed intervengo solo se la materia la conosco bene.
In tutti gli altri casi rimango in silenzio passando per scemo piùttosto che aprire bocca e fugare ogni dubbio!

Ah, ok, ora mi è più chiaro il discorso, e non posso fare altro che concordare :D
Vorrei aggiungere però che sono relativamente abituato a leggere documentazione tecnica in inglese, dato che nel campo che è di mio primario interesse (l'informatica) spessissimo ci si ritrova a leggere manuali e quant'altro che nessuno si sognerebbe mai di tradurre...io stesso commento i miei programmi personali in inglese (anche se solo per una questione di esercizio).
Ciò non toglie che io possa aver capito male...

claudiocedrone ha scritto::D Studia :!: :mrgreen: O_/

Beh...grazie.
Ti assicuro che lo faccio già, e credo anche molto più della maggior parte dei miei coetanei...
Comunque, qualcuno potrebbe darmi qualche suggerimento più...pratico? Il circuito non mi sembra così complesso, sto seguendo quello che c'è già fatto e non mi sono inventato nulla...per cui non so quanto c'entri la parte teorica in questo caso; qui si tratta principalmente di mettere insieme dei componenti basandosi su uno schema già fatto (e so che non è certo questa l'elettronica, così come non è informatica mettere insieme 10 righe di codice).
Cos'altro dovrei sapere? Funzionamento completo di un integrato? Teorie sull'influenza dei raggi cosmici nella trasmissioni di dati su rame? Non so, ditemi voi...forse sto sbagliando l'approccio alla questione...ma non credo sia necessario essere ingegneri per poter fare quello che vorrei io; tanto più che un po' di esperienza con l'elettronica già ce l'ho, ho confidenza con gli strumenti e non mi imbarco in imprese che so già essere sicuramente fuori dalla mia portata.

Per marco438, che diceva di provare a montare il tutto su millefori: grazie, farò ancora qualche test e poi eventualmente ci proverò... :ok:
Avatar utente
Foto Utentesteve95
166 3
New entry
New entry
 
Messaggi: 55
Iscritto il: 28 dic 2012, 17:39

0
voti

[19] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utenteclaudiocedrone » 29 dic 2012, 19:20

Non devi certo diplomarti in astrologia :mrgreen: documentati però sul trattamento dei segnali audio (amplificazione di segnale o preamplificazione, amplificazione di potenza o finale e connessioni) se a un out ci colleghi delle cuffie o degli speaker e si sentono (bene o male ma si sentono) è un out di potenza e non puoi mandarlo tout court a pilotare un altro stadio finale o peggio un altro pre perché come minimo otterrai un... oscillatore e non un impianto audio ! Per il fatto delle masse dipende dalle configurazioni degli stadi di alimentazione e amplificazione, ad es. nel tuo caso se non collegavi insieme i riferimenti di alimentazione e segnale mi spieghi dove accidenti si sarebbe chiuso il circuito :?: Ribadisco che devi vedere e capire un bel po' di esempi perché risultati simili in campo elettronico si possono ottenere con miriadi di configurazioni differenti tra loro tra le quali occorre discriminare quelle tra loro compatibili per poterle assemblare con successo (e vedi le definizioni di terra massa e riferimento) ci sono i segnali bilanciati, quelli sbilanciati (single ended), le alimentazioni singole , le duali, le simmetrie complementari, le simmetrie quasi-complementari e i single ended e i bridge mode... SE non è tutto compatibile dalla sorgente di segnale ai trasduttori, passando per tutti i circuiti occorre saper valutare eventuali modifiche o sostituzioni; non ha alcun senso dire "ho letto da qualche parte che è meglio separare le masse" perché messa in questi termini... è una boiata pazzesca :!: :mrgreen: O_/
"Non farei mai parte di un club che accettasse la mia iscrizione" (G. Marx)
Avatar utente
Foto Utenteclaudiocedrone
14,7k 4 6 9
Master EY
Master EY
 
Messaggi: 10156
Iscritto il: 18 gen 2012, 13:36

0
voti

[20] Re: Problemi amplificatore audio TDA2009

Messaggioda Foto Utentesteve95 » 29 dic 2012, 20:57

Ok, grazie, ora ho capito quello che intendi; non ero proprio a conoscenza di discorsi simili, se ne avessi saputo l'esistenza mi sarei sicuramente documentato... :D
Detto ciò, mi potete quindi aiutare almeno a mettere in chiaro le "basi"?
Riassumedo con ordine:
Lo scopo del progetto è realizzare un amplificatore audio a basso costo, compatto e di modesta potenza; gli verranno collegate casse passive da 8W massimi e 4 Ohm. Dovrà avere due input: uno per collegamento alla televisione, e uno per il PC (magari in futuro con scheda audio dedicata), ognuno con propria regolazione del volume; per questo ho già un commutatore rotativo e due potenziometri doppi, che collegherò secondo quanto detto qui nella "part 1". Il circuito amplificatore si basa su TDA2009A, secondo lo schema riportato in figura 1 del datasheet. L'alimentazione è singola, regolabile tra 1.25 e 16V, con una corrente massima di circa 4A. Un abbozzo del circuito è il seguente (abbiate pietà, è uno dei miei primi disegni in
FidoCadJ...spero si capisca comunque):


Come spero si intuisca gli ingressi sono diversi: jack da 3.5mm stereo per uno e RCA (forse con cavo RCA/jack) per l'altro; la televisione sarà connessa attraverso l'uscita delle cuffie, l'unica disponibile.
Quindi, ora so che le masse audio devono essere collegate insieme a quelle dell'alimentazione; per l'alimentatore non ci dovrebbero essere problemi, in quanto stabile (almeno apparentemente, so che l'ideale sarebbe un controllo con oscilloscopio, magari anche con un certo carico collegato, ma purtroppo non mi è possibile eseguire simili test). Cosa altro mi occorre sapere? Se avete magari qualche link con spiegazioni precise...
Grazie per l'aiuto O_/
Avatar utente
Foto Utentesteve95
166 3
New entry
New entry
 
Messaggi: 55
Iscritto il: 28 dic 2012, 17:39

PrecedenteProssimo

Torna a Elettronica e spettacolo

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti