Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Ponte H & PIC 16F1503

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utenteg.schgor, Foto UtenteBrunoValente, Foto UtenteIsidoroKZ, Foto Utentecarloc

0
voti

[1] Ponte H & PIC 16F1503

Messaggioda Foto UtenteFrancescoFP » 15 lug 2013, 18:45

Ciao a tutti, popolo di Electroyou :D

Avrei bisogno di un aiuto/consiglio per quanto riguarda un ponte H che sembra non funzionare, o perlomeno lo fa in una maniera non "normale".

Venendo al dunque, il ponte H è questo qui

Il ponte è alimentato con quattro pile stilo da 1.5V ciascuna. Il problema è il seguente: Se gli ingressi A e B sono collegati direttamente all'alimentazione(positivo e negativo) allora il ponte funziona perfettamente, sia facendo girare il motore in avanti, sia facendolo girare indietro. Se invece gli ingressi A e B sono collegati a due pin di un microcontrollore(in questo caso un PIC 16F1503) il motore resta fermo, non va ne avanti ne indietro. Non credo sia un problema di circuito in quanto è uno schema stra-testato in rete e qualsiasi sito di robotica quasi lo riporta.

Non ho idea di dove sia il problema, quindi chiedo a qualcuno più esperto di me, anche solo qualche consiglio :D
Avatar utente
Foto UtenteFrancescoFP
834 4 10
 
Messaggi: 32
Iscritto il: 17 ott 2012, 10:53

1
voti

[2] Re: Ponte H & PIC 16F1503

Messaggioda Foto Utentesimo85 » 15 lug 2013, 18:59

Ho cancellato perché non avevo letto bene.

Misurerei tutto, tensione di output dei pin (accertati che siano configurati correttamente), tensioni sui terminali dei transistori, soprattutto i PNP, linka anche i datasheet.
Avatar utente
Foto Utentesimo85
30,8k 7 12 13
Disattivato su sua richiesta
 
Messaggi: 9927
Iscritto il: 30 ago 2010, 4:59

0
voti

[3] Re: Ponte H & PIC 16F1503

Messaggioda Foto UtenteFrancescoFP » 15 lug 2013, 19:02

D'accordo Foto Utentesimo85, grazie anche di aver risposto :D Ora devo andare, provvederò stasera ad effettuare le misurazione che mi hai chiesto! Intanto ti linko i due datasheet, almeno se vuoi puoi dargli un'occhiata: TIP102 TIP107

Grazie, appena torno posto tutto :ok:
Avatar utente
Foto UtenteFrancescoFP
834 4 10
 
Messaggi: 32
Iscritto il: 17 ott 2012, 10:53

5
voti

[4] Re: Ponte H & PIC 16F1503

Messaggioda Foto UtenteBrunoValente » 15 lug 2013, 19:53

Ciao Foto UtenteFrancescoFP,
quel ponte, per funzionare correttamente, ha bisogno che i livelli delle tensioni di pilotaggio siano identici o un po' più alti del valore della tensione di alimentazione del ponte stesso. Se fossero più bassi, anche di poco, si chiuderebbero contemporaneamente i due transistor di un ramo cortocircuitando l'alimentazione.
E' quindi importante che il micro sia alimentato con una tensione uguale o un po' più alta di quella del ponte o, in ogni caso, si deve garantire che le tensioni di pilotaggio non siano inferiori a quella di alimentazione del ponte.
Avatar utente
Foto UtenteBrunoValente
38,4k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 7621
Iscritto il: 8 mag 2007, 14:48

2
voti

[5] Re: Ponte H & PIC 16F1503

Messaggioda Foto UtenteDirtyDeeds » 15 lug 2013, 20:21

Inoltre i transistor scelti sono dei darlington con tensione V_\text{CE(sat)} piuttosto alta (come tutti i darlington). Non mi sembra una scelta adatta per un ponte ad H.
It's a sin to write sin instead of \sin (Anonimo).
...'cos you know that cos ain't \cos, right?
You won't get a sexy tan if you write tan in lieu of \tan.
Take a log for a fireplace, but don't take log for \logarithm.
Avatar utente
Foto UtenteDirtyDeeds
55,9k 7 11 13
G.Master EY
G.Master EY
 
Messaggi: 7012
Iscritto il: 13 apr 2010, 16:13
Località: Somewhere in nowhere

0
voti

[6] Re: Ponte H & PIC 16F1503

Messaggioda Foto UtenteFrancescoFP » 15 lug 2013, 23:24

Grazie ad entrambi per le risposte e le osservazioni :D

@Foto UtenteBrunoValente grazie mille, tutto risolto :ok: Il problema era quello che avevi "diagnosticato" tu, la tensione di pilotaggio inferiore a quella dei motori. Ho risolto utilizzando un pacco di batterie da 5.5V preso da un vecchio giocattolo!

@Foto UtenteDirtyDeeds posso dirti che li ho scelti in quanto, non solo sono presenti in molti schemi amatoriali, ma anche per la corrente di collettore abbastanza elevata(8A). Vorrei chiederti allora se hai qualche consiglio da darmi in merito alla scelta del transistor(ad esempio con quale V_{CE(sat)} sceglierli) oppure in base alla corrente di collettore I_{c}.


Edit: Il sito dal quale ho preso più informazioni è questo
Avatar utente
Foto UtenteFrancescoFP
834 4 10
 
Messaggi: 32
Iscritto il: 17 ott 2012, 10:53

1
voti

[7] Re: Ponte H & PIC 16F1503

Messaggioda Foto Utentecarloc » 15 lug 2013, 23:32

Ti potrei chiedere il favore di misurare la tensione ai capi del motore mentre lo fai girare, magari caricandolo un po' meccanicamente (facendolo sforzare) ? :D

Solo curiosità :D , a proposito che corrente assorbe quel motore?
Se ti serve il valore di beta: hai sbagliato il progetto!
Avatar utente
Foto Utentecarloc
33,7k 6 11 13
G.Master EY
G.Master EY
 
Messaggi: 2147
Iscritto il: 7 set 2010, 19:23

0
voti

[8] Re: Ponte H & PIC 16F1503

Messaggioda Foto UtenteFrancescoFP » 15 lug 2013, 23:34

@Foto Utentecarloc certo che puoi chiedere :ok: Il tempo di prendere il multimetro e faccio le misure! Ps, per la corrente assorbita non saprei dirti, è di una vecchia Jeep telecomandata marca cinese, non ha dati di targa :cry:
Avatar utente
Foto UtenteFrancescoFP
834 4 10
 
Messaggi: 32
Iscritto il: 17 ott 2012, 10:53

0
voti

[9] Re: Ponte H & PIC 16F1503

Messaggioda Foto UtenteFrancescoFP » 15 lug 2013, 23:41

@Foto Utentecarloc Misure effettuate:
Tensione ai capi del motore lasciato girare liberamente: 1,13 V
Tensione ai capi del motore sotto sforzo(route bloccate): 0,25 V

Le misure sono il risultato di una media aritmetica tra 10 diverse misure. Non so se rientrino nei valori "canonici", però ho notato che il PNP di sopra scalda parecchio quando viene bloccata la ruota, credo sia dovuto al maggiore assorbimento di corrente da parte del motore. Vado errato per caso?
Avatar utente
Foto UtenteFrancescoFP
834 4 10
 
Messaggi: 32
Iscritto il: 17 ott 2012, 10:53

3
voti

[10] Re: Ponte H & PIC 16F1503

Messaggioda Foto Utentecarloc » 15 lug 2013, 23:47

Urca :shock: pensavo ci fosse una bella caduta, ma così è veramente troppo :cry: :cry:

Non è che la batteria da 5,5V è un po' "andata" e si siede?

Altrimenti direi proprio che sarebbe meglio rivedere un pochino il progetto :-) entrano 5,5V escono diciamo 1V (la prova a ruote bloccate forse è un po' troppo "violenta") ... comunque sprechi diciamo almeno l'80% dell'energia nella batteria :cry: :cry:

Edit: se uno dei darlington scalda molto di più degli altri significa che è quello con la "saturazione" più debole e probabilmente sotto sforza esce proprio
Se ti serve il valore di beta: hai sbagliato il progetto!
Avatar utente
Foto Utentecarloc
33,7k 6 11 13
G.Master EY
G.Master EY
 
Messaggi: 2147
Iscritto il: 7 set 2010, 19:23

Prossimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 67 ospiti