Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Problema con Arduino Uno

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utenteg.schgor, Foto UtenteBrunoValente, Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ

0
voti

[1] Problema con Arduino Uno

Messaggioda Foto Utentegddvll6 » 31 ott 2013, 18:45

Ho il software Arduino 1.0.5
Ho provato ad eseguire un semplice programma che fa lampeggiare un led, però quando vado a compilarlo mi viene questa scritta:
sketch: 1.084 bytes (su un massimo di 32.256 bytes)
avrdude: stk500_getsync(): not in sync: resp=0x00

La seconda riga è in rosso, ed è proprio quella che disturba il programma. Ho provato a cambiare la porta seriale ma non ci sono riuscito.
Avatar utente
Foto Utentegddvll6
52 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 246
Iscritto il: 22 nov 2012, 18:25

0
voti

[2] Re: Problema con Arduino Uno

Messaggioda Foto UtentePioz » 31 ott 2013, 20:59

Che sistema operativo usi?
Scommetterei su XP.
Comunque il problema penso stia nell'installazione dei driver. Devi installarli manualmente.
Su youtube ci sono diversi tutorial che spiegano bene come fare. Prova a cercare
Avatar utente
Foto UtentePioz
395 4 8
Expert
Expert
 
Messaggi: 508
Iscritto il: 11 ago 2011, 21:56

0
voti

[3] Re: Problema con Arduino Uno

Messaggioda Foto Utentemavesla » 1 nov 2013, 16:17

Ciao a tutti !! ( scrivo così dato che questo è il mio primo post!! ) Riesci a postare una foto del circuito?
Avatar utente
Foto Utentemavesla
175 2 3
New entry
New entry
 
Messaggi: 72
Iscritto il: 19 ott 2013, 11:45

0
voti

[4] Re: Problema con Arduino Uno

Messaggioda Foto Utentegddvll6 » 7 nov 2013, 19:44

Nella versione 1.0.5 che ho ci sono vari bug di compilazione, dove posso scaricare la versione 1.0.1? Ho cercato sul sito ufficiale ma ho trovato soltanto la versione che ho io.
Avatar utente
Foto Utentegddvll6
52 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 246
Iscritto il: 22 nov 2012, 18:25

0
voti

[5] Re: Problema con Arduino Uno

Messaggioda Foto UtentePioz » 7 nov 2013, 20:54

gddvll6 ha scritto:Nella versione 1.0.5 che ho ci sono vari bug di compilazione

L'hai dedotto tu? Te l'ha detto qualcuno?
Se la rendono ancora disponibile sul sito allora penso che sia un problema più tuo che del software di sviluppo.

Se fossi più chiaro nell'esporre i tuoi problemi sarebbe più facile aiutarti.
Avatar utente
Foto UtentePioz
395 4 8
Expert
Expert
 
Messaggi: 508
Iscritto il: 11 ago 2011, 21:56

0
voti

[6] Re: Problema con Arduino Uno

Messaggioda Foto Utentegddvll6 » 7 nov 2013, 20:57

Io ho il software di Arduino su windows 8. Il bug che mi dà è quello che ho scritto nel post precedente. Ho saputo dal mio prof che la versione 1.0.1 è "migliore" rispetto a quella che ho io, nel senso che non riscontra questi bug.
Avatar utente
Foto Utentegddvll6
52 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 246
Iscritto il: 22 nov 2012, 18:25

0
voti

[7] Re: Problema con Arduino Uno

Messaggioda Foto Utentemavesla » 7 nov 2013, 21:06

E' difficile aiutarti dalle poche informazioni che dai, se mostrassi una foto del circuito o spieghi come hai fatto i collegamenti forse qualcuno riesce a darti una mano...
Avatar utente
Foto Utentemavesla
175 2 3
New entry
New entry
 
Messaggi: 72
Iscritto il: 19 ott 2013, 11:45

0
voti

[8] Re: Problema con Arduino Uno

Messaggioda Foto Utentegddvll6 » 7 nov 2013, 21:17

Provo a spiegarmi meglio. Allora, ho installato la versione 1.0.5 di Arduino su windows 8. Già quando apro il programma di Arduino compare una finestra con scritto:
"Consentire al programma seguente con autore sconosciuto di apportare modifiche al computer?" Le scelte che posso fare sono "si" e "no".
Per verificare che il software funzionasse correttamente ho caricato un programma già fatto andando su File-->esempi-->basics--->blink.
(Questo è un programma che permette di far accendere e spegnere un led all'infinito). Quando ho provato a caricare il programma per farlo funzionare mi ha dato questo tipo di errore:
sketch:1.084 bytes(su un massimo di 32.256 bytes)
avrdude:stk500_getsync():not in sync:resp0x00
La seconda riga è in rosso sulla finestra del programma. Quello è il bug.
Per risolvere questo bug ho provato a cambiare la porta seriale, a controllare vari errori nel programma, ma non è servito a niente. Adesso credo che sia un errore dei driver di arduino riguardo al non funzionamento del programma. Sapete dirmi cosa posso fare?
Avatar utente
Foto Utentegddvll6
52 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 246
Iscritto il: 22 nov 2012, 18:25

0
voti

[9] Re: Problema con Arduino Uno

Messaggioda Foto UtentePioz » 7 nov 2013, 22:56

Bene..Ora è chiaro.
Il problema sta nell'installazione dei driver come dici tu. Se avessi la versione che dici tu non cambierebbe nulla, i driver devi comunque installarli manualmente.

Prova a seguire questo tutorial
Avatar utente
Foto UtentePioz
395 4 8
Expert
Expert
 
Messaggi: 508
Iscritto il: 11 ago 2011, 21:56

0
voti

[10] Re: Problema con Arduino Uno

Messaggioda Foto Utentegddvll6 » 8 nov 2013, 17:42

Ho provato a fare quello che dice nel video, però quando vado su Gestione dispositivi, sull'icona porte com e lpt...Arduino uno(com 11) non ha il punto interrogativo, quindi non sembra che non viene riconosciuto dal PC. Ho provato a fare l'aggiornamento software driver, facendo "sfoglia" e ho cercato la cartella di Arduino. Ho cliccato su ok e poi "avanti", dopo questa operazione mi è venuto scritto "dispositivo installato". Però non cambia nulla, perché il software non funziona comunque come prima..
Avatar utente
Foto Utentegddvll6
52 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 246
Iscritto il: 22 nov 2012, 18:25


Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 23 ospiti