Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Problema guadagno, rumore distorsione

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteBrunoValente

3
voti

[1] Problema guadagno, rumore distorsione

Messaggioda Foto Utentesimo85 » 24 feb 2016, 2:59

Ho un problema con un amplificatore operazionale invertente di cui ancora non riesco a darmi una spiegazione precisa, anche se ho già qualche idea in testa su quale possa essere la causa del problema..

Lo schema è quello che segue, un amplificatore invertente con regolazione di guadagno e regolazione di offeset con filtro passivo sull'uscita e segnale di entrata proveniente da un MAX038.



Per il filtro non mi sono complicato più di tanto la vita ed ho seguito quello che viene rappresentato sul DS del MAX038: http://www.researchgate.net/file.PostFi ... 0263161688

nell'ultimo schema.
Datasheet LM7171: http://www.ti.com/lit/ds/symlink/lm7171.pdf

La regolazione di offset funziona bene. Il problema viene con la regolazione di guadagno.

Se mantengo il guadagno \approx 3 l'uscita è quella desiderata, dove il segnale di uscita è misurato dopo il filtro di uscita:
OK.JPG

(scusate per la pessima foto ma me ne sono reso conto adesso):

Se invece abbasso il guadagno, l'uscita è qualcosa di orribilmente squallido che fa venire il mal di stomaco:
NO-OK.JPG

E a quanto sembra anche l'uscita del MAX038 ne risente.

Il potenziometro è collegato con quei cavi non troppo spessi che però, internamente, sono attorcigliati, quindi secondo fanno anche un po' pena (componenti parassiti a più non posso) ed ho già intenzione di cambiarli.

Ma oltre a questo, mi sembra che l'operazionale, lasci passare tutta la porchería in uscita dal MAX038 e perché no, magari anche dall'alimentazione, anche se i 5 V arrivano da due semplici regolatori 78/7905 la fonte di alimentazione è una classica duale. Avevo provato in passato con una alimentazione commutata ottenendo picchi di disturbi sull'uscita, ma non cosi come nella foto che non mi era mai successo.

Ho anche pensato che il potenziometro (multigiro) sia una porcheria e che sia molto rumoroso..

Sicuramente sto sottovalutando qualcosa ma al momento non mi viene in mente quale possa essere veramente la causa.
La cosa divertente è che in passato, durante le prove su breadboard tutto ha funzionato regolarmente. :? :? :?

A saperlo prima lo lasciavo li..
Avatar utente
Foto Utentesimo85
30,8k 7 12 13
Disattivato su sua richiesta
 
Messaggi: 9930
Iscritto il: 30 ago 2010, 4:59

1
voti

[2] Re: Problema guadagno, rumore distorsione

Messaggioda Foto UtenteMarcoD » 24 feb 2016, 9:25

Hai illustrato il problema in modo chiaro.
Bel problema! :!:
In modo qualitativo, lo spiegherei nel seguente modo:
Più riduci il valore di RV, più aumenti il guadagno della reazione negativa, che provoca la riduzione del guadagno dello stadio amplificatore. L'aumento del guadagno della reazione negativa porta alla instabilità riscontrata.
Come risolverlo ?:
Accorciare le connessioni per ridure capacità/induttanza parassite?
Provare con una rete di compensazione?, ma quale e dove applicarla?
Inserire un resistore fisso in serie a RV per limitare la riduzione di guadagno? (In ogni modo non puoi scendere a 0 con RV). Compensare la mancata riduzione di guadagno attenuando con un partitore l'uscita del generatore?
Attendo di leggere altri suggerimenti.
Avatar utente
Foto UtenteMarcoD
6.195 4 8 13
Master EY
Master EY
 
Messaggi: 2441
Iscritto il: 9 lug 2015, 16:58
Località: Torino

0
voti

[3] Re: Problema guadagno, rumore distorsione

Messaggioda Foto Utentesimo85 » 24 feb 2016, 10:01

MarcoD ha scritto:Accorciare le connessioni per ridure capacità/induttanza parassite?

Quello sicuro, ed anche con dei cavi migliori. Sto cercando dei cavi abbastanza buoni che non siano intrecciati, tipo cavi coassiali.

Se hai/avete qualche suggerimento a riguardo, ben venga. :-)

MarcoD ha scritto:Inserire un resistore fisso in serie a RV per limitare la riduzione di guadagno?

Non ricordo bene se la prova su breadboard era con resistore fisso o no. Devo imparare ad annotare TUTTO anche a casa, non solo al lavoro.

Riproverò con un trimmer... :? :?
Avatar utente
Foto Utentesimo85
30,8k 7 12 13
Disattivato su sua richiesta
 
Messaggi: 9930
Iscritto il: 30 ago 2010, 4:59

1
voti

[4] Re: Problema guadagno, rumore distorsione

Messaggioda Foto UtenteEcoTan » 24 feb 2016, 10:49

Che funzione ha la resistenza da 1 k? Se non hai bisogno di guadagno, a che serve l'amplficatore? Se un guadagno vicino a 1 è difficile da ottenere, allora metterei un attenuatore per poi amplificare di più.
Avatar utente
Foto UtenteEcoTan
5.340 4 10 13
Expert EY
Expert EY
 
Messaggi: 3190
Iscritto il: 29 gen 2014, 8:54

2
voti

[5] Re: Problema guadagno, rumore distorsione

Messaggioda Foto UtenteMarcoD » 24 feb 2016, 10:51

Concordo conFoto UtenteEcoTan.
Se monti RV1 come potenziometro attenuatore in ingresso dovresti avere meno problemi.
RV da 1k puoi adoperarlo per la taratura del valore massimo dell'uscita.
(..sono diventato un aspirante mago nell'uso di fidocadj :mrgreen: )

Avatar utente
Foto UtenteMarcoD
6.195 4 8 13
Master EY
Master EY
 
Messaggi: 2441
Iscritto il: 9 lug 2015, 16:58
Località: Torino

0
voti

[6] Re: Problema guadagno, rumore distorsione

Messaggioda Foto Utentesimo85 » 24 feb 2016, 11:00

MarcoD ha scritto:Che funzione ha la resistenza da 1 k? Se non hai bisogno di guadagno, a che serve l'amplficatore?

È parte della rete di retroazione.
Il filtro RC l'ho messo per attenuare le porcherie sull'uscita del MAX038:
xxx.png
xxx.png (15.2 KiB) Osservato 2169 volte

(simulazione con Geogebra)
altrimenti l'amplificatore amplifica anche quelle.
Avatar utente
Foto Utentesimo85
30,8k 7 12 13
Disattivato su sua richiesta
 
Messaggi: 9930
Iscritto il: 30 ago 2010, 4:59

5
voti

[7] Re: Problema guadagno, rumore distorsione

Messaggioda Foto UtenteAlbertoBianchi » 24 feb 2016, 11:18

Ciao Foto Utentesimo85, il datasheet recita: "The LM7171is stable for gains as low as +2 or −1."
potrebbe essere che tu stia impostando un guadagno inferiore a -1? (RV < R2)
Se sostituisci il trimmer con una res fissa uguale ad R2 (magari senza fili lunghi) cosa succede?
Alberto
La vita è come una bicicletta, devi sempre pedalare per rimanere in equilibrio

Annuncio sempre valido: http://www.electroyou.it/forum/viewtopic.php?f=10&t=62668
Avatar utente
Foto UtenteAlbertoBianchi
1.999 3 5
Master
Master
 
Messaggi: 836
Iscritto il: 4 dic 2014, 18:30
Località: Lastra a Signa (FI)

0
voti

[8] Re: Problema guadagno, rumore distorsione

Messaggioda Foto Utentesimo85 » 24 feb 2016, 11:31

Ciao Alberto, è probabile, ieri non ho misurato la resistenza del potenziometro dopo la distorsione a circuito spento (all'una e mezza di notte ne avevo anche un po' le scatole piene :-) ) anche se la distorsione fotografata è visibile ruotando minimamente il potenziometro per ridurre il guadagno.

Mi era sfuggita la descrizione citata #-o ma quando avevo fatto le prove su breadboard viewtopic.php?f=1&t=53365&hilit=+LM7171#p518687 non avevo riscontrato questo problema.

Un' altra cosa che ho notato è che muovendo leggermente i fili in alcuni casi spariva (ed in altri si attenuava notevolmente) la distorsione.
Ho collegato i potenziometri con quei fili che vendono con i connettori incorporati con passo 2.54 mm. Il rivenditore ancora una volta mi disse "sono per Arduino" al quale volevo rispondergli qualcosina ma ho preferito stare zitto..

Chiedi un cavo e compri una induttanza con condensatore incluso e mi aspettavo qualche problemino, ma cosi tanto no.
Avatar utente
Foto Utentesimo85
30,8k 7 12 13
Disattivato su sua richiesta
 
Messaggi: 9930
Iscritto il: 30 ago 2010, 4:59

0
voti

[9] Re: Problema guadagno, rumore distorsione

Messaggioda Foto UtenteAlbertoBianchi » 24 feb 2016, 12:17

Quelle bread-board con i fili rigidi le comprai anch'io e le ho buttate da almeno vent'anni - molto prima di arduino :mrgreen: :mrgreen:
Secondo me è meglio 'pasticciare' con le millefori, almeno con quelle la parte critica del layout in qualche modo te la puoi sempre arrangiare abbastanza bene.
Alberto
La vita è come una bicicletta, devi sempre pedalare per rimanere in equilibrio

Annuncio sempre valido: http://www.electroyou.it/forum/viewtopic.php?f=10&t=62668
Avatar utente
Foto UtenteAlbertoBianchi
1.999 3 5
Master
Master
 
Messaggi: 836
Iscritto il: 4 dic 2014, 18:30
Località: Lastra a Signa (FI)

0
voti

[10] Re: Problema guadagno, rumore distorsione

Messaggioda Foto Utentesimo85 » 24 feb 2016, 12:24

Per il momento proverò a cambiare i fili e cavi, tutti, per poi rivedere il guadagno.

Mal che vada proverò la soluzione di Foto UtenteEcoTan e Foto UtenteMarcoD, anche se mi piacerebbe lasciare il circuito cosi come è.

Aggiornerò il thread appena posso, anche perché oggi comincia il semestre quindi il tempo che potró dedicargli si riduce. :cry:
Avatar utente
Foto Utentesimo85
30,8k 7 12 13
Disattivato su sua richiesta
 
Messaggi: 9930
Iscritto il: 30 ago 2010, 4:59

Prossimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Google [Bot], Google Adsense [Bot] e 26 ospiti