Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Problema con LED rossi ad alta luminosità

Circuiti e campi elettromagnetici

Moderatori: Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteEdmondDantes

0
voti

[1] Problema con LED rossi ad alta luminosità

Messaggioda Foto Utentesabre » 3 set 2018, 12:29

Salve a tutti, ho una domanda da novellino dell'elettrotecnica da porre a qualcuno più esperto di me, spero mi possiate illuminare: da poco tempo ho iniziato a "giocherellare" con diodi LED da 5mm ad alta luminosità di vari colori (rossi, verdi, blu) nel tentativo di personalizzare il mio PC e la mia scrivania. Il mio obbiettivo sarebbe quello di creare una sorta di "mini lampade" alimentate via USB per rendere il tutto più luminoso e appariscente, quindi ho fatto varie prove collegando in parallelo quattro LED verdi (3.2V, 20mA) con una singola resistenza da 100Ω alla porta USB e fin qui tutto funzionava bene, ma con lo stesso numero di LED rossi (4 x 1.8V, 20mA) e resistenza da 150Ω sto avendo qualche problema. In pratica, una volta collegati alla porta USB, i LED rossi si accendono a piena luminosità solo per un millesimo di secondo e poi calano drasticamente rimanendo a malapena illuminati da una luce molto debole. Questo accade solo quando collego il tutto alle porte USB del PC, mentre se utilizzo un alimentatore USB da 5V alimentato dalla presa a muro il problema non si presenta. La cosa mi incuriosisce molto e mi chiedevo quale potesse esserne la causa. Qualcuno saprebbe dirmi? Grazie in anticipo dell'aiuto!
Avatar utente
Foto Utentesabre
0 2
 
Messaggi: 6
Iscritto il: 3 set 2018, 9:53

0
voti

[2] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto UtenteIlGuru » 3 set 2018, 12:54

La corrente erogata dalle porte USB del PC viene gestita dal software.
Prova a misurare che tensione c'è sulla porta quando cala la luminosità
\Gamma\nu\tilde{\omega}\theta\i\ \sigma\epsilon\alpha\upsilon\tau\acute{o}\nu
Avatar utente
Foto UtenteIlGuru
3.920 1 9 13
Master
Master
 
Messaggi: 1240
Iscritto il: 31 lug 2015, 23:32

0
voti

[3] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto UtenteJAndrea » 3 set 2018, 13:50

Per una questione di protezione della porta dalle sovracorrenti e corto circuiti, questa viene limitata a 100mA di base nel protocollo 1.0 e 2.0.

A meno che non avvenga un riconoscimento del device connesso tramite comunicazione sulle linee dati, portando la corrente massima erogabile a 500mA su 2.0 ed 1A su 3.0.

Ovviamente perché il device possa "presentarsi" al PC, occorre alimentarlo, quindi il PC eroga i 5V alla massima corrente per un breve intervallo di tempo (decine di ms), salvo poi, se nessuno si presenta applicare la limitazione più bassa.


Gli alimentatori a 5V, spesso danno corrente e basta, senza tante comunicazioni e protocolli vari.
Avatar utente
Foto UtenteJAndrea
2.757 2 5 9
Master
Master
 
Messaggi: 1454
Iscritto il: 16 giu 2011, 15:25
Località: Rovigo

0
voti

[4] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto Utentesabre » 3 set 2018, 13:59

L'unico inconveniente è che non credo di avere la strumentazione adatta per ricavare quel genere di informazione dalle mie porte USB... Servirebbe un tester o puo essere fatto anche tramite software dal PC? Sicuramente posso confermare che le porte USB del mio PC sono 2.0 e che io sappia la tensione d'uscita di tali porte è di 5V e 100mA. Semplicemente non capisco come mai con gli altri LED blu e verdi nella stessa configurazione (quattro in parallelo con singola resistenza e collegati alla porta USB del PC) il problema non si presenta, mentre ripeto, l'unico modo che ho trovato per far funzionare i quattro rossi in parallelo è utilizzando un alimentatore USB da 5V (330mA).
Avatar utente
Foto Utentesabre
0 2
 
Messaggi: 6
Iscritto il: 3 set 2018, 9:53

0
voti

[5] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto UtenteJAndrea » 3 set 2018, 14:06

calcola la corrente che assorbono i led in ciascuna delle configurazioni.
In secondo luogo io sconsiglio l'utilizzo di una sorgente come il PC per alimentare dispositivi di dubbia affidabilità…
Ad ogni modo, un indicazione sulla corrente erogata la puoi trovare da windows.
Se tu apri gestione dispositivi, nelle proprietà di ciascun hub USB c'è una sezione alimentazione con il resoconto degli assorbimenti misurati. (non so quanto siano precisi)
Cattura.PNG
Avatar utente
Foto UtenteJAndrea
2.757 2 5 9
Master
Master
 
Messaggi: 1454
Iscritto il: 16 giu 2011, 15:25
Località: Rovigo

0
voti

[6] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto Utentesabre » 3 set 2018, 14:39

Il calcolo è molto semplice, come ho scritto sopra, i blu e i verdi consumano uguale corrente, cioè 3.2V e 20mA (secondo il manuale del venditore), che NON moltiplico per 4 (anche se tanti ne sto usando) perché messi in parallelo, quindi come tensione e ampere direi che ci siamo (correggetemi se sbaglio). I rossi addirittura consumano meno e cioè 1.8V e 20mA, quindi tirando le somme, 5V e 100mA di output dalle porte USB meno 3.2V e 20mA voluti dai 4 led blu (o verdi) in parallelo mi lasciano un margine di 1.8V e 80mA che vado a limitare con la resistenza da 100Ω, mentre facendo lo stesso calcolo con i LED rossi mi rimangono 3.2V e 80mA da limitare con la resistenza da 150Ω, ma li spunta il problema. Ci tengo a precisare che non si tratta esattamente di un "dispositivo" con interruttori o componenti elettronici di mezzo che vanno rilevati dal PC, ma di un semplice circuito elettrico con l'unico scopo prendere la corrente dalla porta USB ed usarla per alimentare i bulbi LED.
Avatar utente
Foto Utentesabre
0 2
 
Messaggi: 6
Iscritto il: 3 set 2018, 9:53

0
voti

[7] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto UtenteJAndrea » 3 set 2018, 15:05

Ci tengo a precisare che non si tratta esattamente di un "dispositivo" con interruttori o componenti elettronici di mezzo che vanno rilevati dal PC, ma di un semplice circuito elettrico con l'unico scopo prendere la corrente dalla porta USB ed usarla per alimentare i bulbi LED

Come ti ho spiegato, è proprio questo il problema, il PC vede un oggetto non identificato che assorbe corrente e non vede di buon occhio la cosa, per cui ti taglia la corrente.


Considera poi, che sia la tensione diretta dei led, sia le resistenze utilizzate hanno una tolleranza, per cui il calcolo di 20mA a led può non essere così vero.
Il miglior modo per saperlo con "certezza" è misurarlo.

Facendo il conto, i tuoi led verdi (a valori nominali) assorbirebbero 18,5 mA, i rossi 21,5 mA, ti accorgi che moltiplicando per 4 non fa 80 in nessuno dei due casi.
I rossi quindi assorbono 86mA, che potrebbero essere di più a causa delle tolleranze di qualche componente.
Avatar utente
Foto UtenteJAndrea
2.757 2 5 9
Master
Master
 
Messaggi: 1454
Iscritto il: 16 giu 2011, 15:25
Località: Rovigo

0
voti

[8] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto Utentesabre » 3 set 2018, 15:31

Quindi dici che potrebbe essere un problema di ampere e che i 100mA erogati dalla porta USB 2.0 non sono abbastanza per compensare gli ipotetici 86mA voluti dai 4 LED rossi? Oltretutto credevo che gli ampere della porta USB non si dividessero se mandati ai LED collegati in parallelo e che giungesse la stessa quantità ad ogni bulbo, proprio come per i volt. Mi confermi che è cosi? Eventualmente potrei provare ad alimentare i LED rossi da una porta USB 3.0 da 150mA (se ne trovo una) per vedere se cambia qualcosa...
Avatar utente
Foto Utentesabre
0 2
 
Messaggi: 6
Iscritto il: 3 set 2018, 9:53

0
voti

[9] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto UtenteIlGuru » 3 set 2018, 15:41

E' come dici tu, la corrente si divide ( se i diodi fossero ideali ) in 4, quindi 5 mA per ogni led. Con quella corrente probabilmente il diodo non riesce a tenere gli 1.8V di caduta, saranno un po' meno, questo fa aumentare la corrente che li attraversa che si stabilizzerà in qualche punto li intorno, ma questo è già indicativo del fatto che illuminino poco.
Però, dome è stato ampiamente ribadito, alla porta USB del PC, non piace alimentare gli sconosciuti, quindi si spegne da sola. La porta USB non è un alimentatore a 5V, è una porta USB, fatta per comunicazioni seriali con dispositivi noti a cui fornire la corrente necessaria.
\Gamma\nu\tilde{\omega}\theta\i\ \sigma\epsilon\alpha\upsilon\tau\acute{o}\nu
Avatar utente
Foto UtenteIlGuru
3.920 1 9 13
Master
Master
 
Messaggi: 1240
Iscritto il: 31 lug 2015, 23:32

0
voti

[10] Re: Problema con LED rossi ad alta luminosità

Messaggioda Foto Utentesabre » 3 set 2018, 15:48

Ma questo non spiega perché con gli altri LED funzioni... Se fosse come dici tu non dovrebbe fare accendere nemmeno i LED blu e verdi, invece con quelli non ho alcun problema, posso alimentarli sia con le USB del PC che con l'alimentatore. Anche con i LED bianchi funziona tutto benissimo.
Avatar utente
Foto Utentesabre
0 2
 
Messaggi: 6
Iscritto il: 3 set 2018, 9:53

Prossimo

Torna a Elettrotecnica generale

Chi c’è in linea

Visitano il forum: Google [Bot] e 18 ospiti