Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Millefori e Disturbi

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteBrunoValente

0
voti

[1] Millefori e Disturbi

Messaggioda Foto UtenteTekonoris » 15 mag 2019, 9:20

Salve,
mi rendo conto che la domanda è un po generica, ma non so da che parte cominciare...

Il problema è che tenstando un circuito su breadboard e poi passandolo su una millefori mi aspettavo che i disturbi calassero. Come potete immaginare invece è successo il contrario.

La domanda è: immagino ci siano dei criteri da rispettare nell' assemblaggio di una Millefori. Potreste indicarmi una guida su questo argomento ?
Inteso come criteri di collegamento, distanze tra componenti da rispettare, componenti che non possono stare vicini, ecc.
Tendenzialmente "ammasso" il tutto più vicino possibile per evitare collegamenti lunghi e saldare da piazzola a piazzola.

comunque nei prossimi giorni ri-verifico le saldature e tutto il resto. Anche l'onda quadra in uscita dal Comparatore è molto disturbata.

Grazie

Allego due screenshot, prima e dopo...
Il circuito in questione crea un'onda sinusoidale da un circuito LC, il quale attraverso un comparatore, viene utilizzato come base per altre misurazioni.
Allegati
b.png
Breadboard
a.png
Millefori
Avatar utente
Foto UtenteTekonoris
43 6
Frequentatore
Frequentatore
 
Messaggi: 105
Iscritto il: 19 ott 2018, 10:31

3
voti

[2] Re: Millefori e Disturbi

Messaggioda Foto UtenteDarwinNE » 15 mag 2019, 9:35

Beh, dipende molto dal circuito. Puoi mostrare almeno lo schema? Magari i disturbi vengono più da un giro di massa esterno che dal circuito in questione. Oppure dall'alimentazione. Magari mostra anche una foto delle due realizzazioni e del setup di misura.

Comunque, per i circuiti tosti, la migliore trattazione che io conosca delle tecniche di breadbording è alla fine della AN47 di Jim Williams:

https://www.analog.com/media/en/technic ... an47fa.pdf

appendice 7, pagina 98
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
25,2k 5 11 13
G.Master EY
G.Master EY
 
Messaggi: 3526
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

1
voti

[3] Re: Millefori e Disturbi

Messaggioda Foto UtenteBrunoValente » 15 mag 2019, 9:39

Non si capisce granché dalla tua descrizione e dagli oscillogrammi, comunque le precauzioni da prendere per ridurre i disturbi dipendono solo in parte dal supporto utilizzato per il cablaggio, dipendono anche e molto dal circuito in questione, le cause dei disturbi sono tante e diverse da un circuito all'altro.
Avatar utente
Foto UtenteBrunoValente
31,5k 6 10 13
G.Master EY
G.Master EY
 
Messaggi: 6062
Iscritto il: 8 mag 2007, 14:48

0
voti

[4] Re: Millefori e Disturbi

Messaggioda Foto UtenteBrunoValente » 15 mag 2019, 9:40

ops, mi sono sovrapposto alla risposta di Foto UtenteDarwinNE
Avatar utente
Foto UtenteBrunoValente
31,5k 6 10 13
G.Master EY
G.Master EY
 
Messaggi: 6062
Iscritto il: 8 mag 2007, 14:48

1
voti

[5] Re: Millefori e Disturbi

Messaggioda Foto UtenteTekonoris » 15 mag 2019, 9:58

Infatti ... La domanda è generica, per cominciare ad approfondire l'argomento.

Comunque il circuito in questione è questo:



Però è inserito in uno più grande (Alimentazione 7805, processore, display OLED, ecc) . Allego foto.

Grazie DarwinNE, appena riesco leggo... :D

DarwinNE ha scritto:Beh, dipende molto dal circuito. Puoi mostrare almeno lo schema? Magari i disturbi vengono più da un giro di massa esterno che dal circuito in questione. Oppure dall'alimentazione. Magari mostra anche una foto delle due realizzazioni e del setup di misura.


Sicuramente giri di masse ce ne sono molte ... proverò a "staccare" qualche cosa. Nella foto c'è il programmatore, il circuito base, una millefori con componenti campione presaldati e l'oscilloscopio ...


BrunoValente ha scritto:Non si capisce granché dalla tua descrizione e dagli oscillogrammi, ...

Gli oscillogrammi ripropongono solo due prove di misura in tempi diversi. Uno è "senza" disturbi, il secondo è disturbatissimo...
La domanda voleva essere generica e non riferita espressamente a questo circuito... Anche perché se qualche cosa ho sbagliato (sicuro) non posso correggere questo, ma devo ricominciare (col piede giusto però).
Allegati
dd.png
cc.png
Avatar utente
Foto UtenteTekonoris
43 6
Frequentatore
Frequentatore
 
Messaggi: 105
Iscritto il: 19 ott 2018, 10:31

2
voti

[6] Re: Millefori e Disturbi

Messaggioda Foto UtenteDarwinNE » 15 mag 2019, 11:25

Direi che non mi pare un circuito criticissimo, ma c'è sicuramente da fare attenzione a qualche dettaglio.

In linea generale, la millefori è di solito migliore della breadboard se il circuito è montato bene, ma nel tuo caso i disturbi vengono secondo me dal setup di misura. La massa della sonda è scollegata? Vedo poi la sonda dell'oscilloscopio collegata ad un filino, capti di tutto con quella tecnica :?

Non hai indicato nello schema i condensatori di bypass sull'alimentazione. Fai sempre molta attenzione alla "massa" del circuito. 0V non sono 0V dappertutto :-) Qui un'utile lettura:

https://www.electroyou.it/isidorokz/wik ... iferimento

Attenzione ai comparatori, se non c'è un riferimento solido e un bypass corretto sull'alimentazione, possono fare un po' di tutto. Ho visto dei LM311 che "rimbalzavano" ed invece di dare un solo impulso in uscita ne davano parecchi, non a causa del segnale in ingresso, ma a causa dell'alimentazione che veniva disturbata dal primo fronte all'uscita dell'integrato, certe soglie ne venivano perturbate ed il comparatore ne era quindi ingannato.
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
25,2k 5 11 13
G.Master EY
G.Master EY
 
Messaggi: 3526
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

0
voti

[7] Re: Millefori e Disturbi

Messaggioda Foto UtenteTekonoris » 15 mag 2019, 11:48

DarwinNE ha scritto:... vengono secondo me dal setup di misura. La massa della sonda è scollegata? Vedo poi la sonda dell'oscilloscopio collegata ad un filino, capti di tutto con quella tecnica

La massa del OSC è il coccodrillo nero attaccato all'altro filo... :cry:
Quindi se capisco bene dovrei spostare l'OSC direttamente sul circuito eliminando i fili ?

DarwinNE ha scritto:Non hai indicato nello schema i condensatori di bypass sull'alimentazione. Fai sempre molta attenzione alla "massa" del circuito. 0V non sono 0V dappertutto :-)

Il comparatore ha il suo Condensatore sull'alimentazione (100nF) e il 7805 ne ha uno in ingresso e uno in uscita (Elettrolitici 100u / 10uF).
Proverò a razionalizzare il piano di massa ... Aggiungo un multistrato ?

DarwinNE ha scritto:Attenzione ai comparatori, se non c'è un riferimento solido e un bypass corretto sull'alimentazione, possono fare un po' di tutto. Ho visto dei LM311 che "rimbalzavano" ed invece di dare un solo impulso in uscita ne davano parecchi, non a causa del segnale in ingresso, ma a causa dell'alimentazione che veniva disturbata dal primo fronte all'uscita dell'integrato, certe soglie ne venivano perturbate ed il comparatore ne era quindi ingannato.

Ho controllato l'uscita del Comparatore (nei test di ieri notte) e non mi ero accorto che l'uscita non sembra corretta... (foto) Mi ero concentrato sul circuito LC. :roll:
Mi sarei aspettato un (grossomodo) +5 / 0V di onda quadra, invece ho 134 mV.
Devo aver commesso qualche errore ... Attualmente non capisco la causa.
Il circuito però funziona e non capisco come un 134 mV possa far funzionare correttamente la lettura della frequenza al processore... (ingresso settato in digitale.
Allegati
Osc.png
Uscita Comparatore
Osc.png (330.55 KiB) Osservato 216 volte
Avatar utente
Foto UtenteTekonoris
43 6
Frequentatore
Frequentatore
 
Messaggi: 105
Iscritto il: 19 ott 2018, 10:31

0
voti

[8] Re: Millefori e Disturbi

Messaggioda Foto UtenteEcoTan » 15 mag 2019, 12:33

Mi è capitato un disturbo simile ed era dovuto ad uno scanner tenuto alimentato vicino all'oscilloscopio.
Avatar utente
Foto UtenteEcoTan
5.325 4 10 13
Expert EY
Expert EY
 
Messaggi: 3153
Iscritto il: 29 gen 2014, 8:54

0
voti

[9] Re: Millefori e Disturbi

Messaggioda Foto UtenteDarwinNE » 15 mag 2019, 12:55

Tekonoris ha scritto:La massa del OSC è il coccodrillo nero attaccato all'altro filo... :cry:
Quindi se capisco bene dovrei spostare l'OSC direttamente sul circuito eliminando i fili ?


Inizia a:

1 - verificare il circuito per correggere eventuali errori
2 - fai le misure con la massa dell'oscilloscopio collegata alla sonda, tieni il più possibile corte le connessioni
3 - tieniti lontano da alimentazioni switching
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
25,2k 5 11 13
G.Master EY
G.Master EY
 
Messaggi: 3526
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

0
voti

[10] Re: Millefori e Disturbi

Messaggioda Foto UtenteTekonoris » 15 mag 2019, 13:06

DarwinNE ha scritto:Inizia a:

1 - verificare il circuito per correggere eventuali errori
2 - fai le misure con la massa dell'oscilloscopio collegata alla sonda, tieni il più possibile corte le connessioni
3 - tieniti lontano da alimentazioni switching


1) ok. stasera ripasso il circuito. Inoltre stacco il programmatore e il gruppo di misura (meno collegamenti).
3) Alimento a batteria.

2) non capisco... Io attacco solo il coccodrillo della sonda al riferimento e la pinzetta sul punto di misura. Giusto ?
Avatar utente
Foto UtenteTekonoris
43 6
Frequentatore
Frequentatore
 
Messaggi: 105
Iscritto il: 19 ott 2018, 10:31

Prossimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 22 ospiti