Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Circuito per lampeggio non funziona.

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto Utenteg.schgor, Foto UtenteIsidoroKZ, Foto UtenteBrunoValente

0
voti

[61] Re: Circuito per lampeggio non funziona.

Messaggioda Foto Utenteelfo » 26 lug 2020, 12:42

USUL ha scritto: mi spieghi perché ci stiamo complicando la vita quando ieri sera andava tutto bene'????

Questa domanda e' facile :D

Perche' vogliamo capire la (e) causa(e) del malfunzionamento.
Ho fatto inizialmente varie ipotesi sulla(e) causa(e) del malfunzionamento del circuito originale (non funzionante) ed ho proposto varie modifiche in contemporanea (le 4 resistenze) per "accelerare" i tempi nel cercare di trovare la soluzione.

Non sono sicuro che tutte le modifiche (che tutte e 4 le resistenze) siano necessarie per far funzionare il circuito da cui la ultima prova con solo una resistenza (una sola modifica).

Potresti per favore rifare le misure del post [42] sul circuito del post [58]?
Avatar utente
Foto Utenteelfo
3.597 2 5 7
Master
Master
 
Messaggi: 1539
Iscritto il: 15 lug 2016, 13:27

0
voti

[62] Re: Circuito per lampeggio non funziona.

Messaggioda Foto UtenteUSUL » 26 lug 2020, 13:00

0) Commutatore posizione centrale -> frecce spente? SI
1) Commutatore Sx -> freccia Sx lampeggia? SI lentamente
2) Commutatore Dx -> freccia Dx lampeggia? SI normale
3) Commutatore Sx e poi velocemente a Dx -> Sx spente, rele acceso fisso , Dx lampeggia? SI
4) Che tensione misuri sul punto Z nella condizione 0) 0
5) Che tensione misuri sul punto Z nella condizione 1) 0
6) Che tensione misuri sul punto Z nella condizione 2) 0--12
7) Che tensione misuri sul punto Z nella condizione 3) 0-12

i led si sono bruciati

grazie
Avatar utente
Foto UtenteUSUL
0 3
New entry
New entry
 
Messaggi: 70
Iscritto il: 6 lug 2020, 18:34

0
voti

[63] Re: Circuito per lampeggio non funziona.

Messaggioda Foto Utenteelfo » 26 lug 2020, 13:08

Grazie per le misure.

Cerco di "confezionare" una risposta.

Ci sentiamo dopo pranzo (e pennica :D ).
Avatar utente
Foto Utenteelfo
3.597 2 5 7
Master
Master
 
Messaggi: 1539
Iscritto il: 15 lug 2016, 13:27

0
voti

[64] Re: Circuito per lampeggio non funziona.

Messaggioda Foto UtenteUSUL » 26 lug 2020, 13:14

rifatte prove con led funzionanti, e tutto regolare

a sto punto...come mai si bruciano i led???

grazie
Avatar utente
Foto UtenteUSUL
0 3
New entry
New entry
 
Messaggi: 70
Iscritto il: 6 lug 2020, 18:34

0
voti

[65] Re: Circuito per lampeggio non funziona.

Messaggioda Foto Utenteelfo » 26 lug 2020, 15:39

USUL ha scritto:rifatte prove con led funzionanti, e tutto regolare

So fa so good.

La tue esperienze di circuiti che hanno funzionamento "erratico" mi offrono il destro per alcune note di realizzazione.

Guarda lo schema qui sotto Fig. 1a (e' l'ultima versione ridisegnata - spero corretta):

alcuni componenti sono stati "ricollocati" come disposizione nello schema per farli "entrare" nel rettangolo rosso.

Tutto quello che e' esterno al rettangolo rosso e' l'impianto originale delle frecce.
Nel rettangolo rosso c'e' il circuito "add-on" che implementa la modifica.
Sono stati messi in evidenza i 4 collegamenti "in derivazione" all'impianto originale - collegamenti che possono essere realizzati tramite connettore.

1 +Bat
2 - Bat
3 Freccia Sx
4 Freccia Dx

La resistenza da 1 k e' stata "spostata" (pur rimanendo sempre elettricamente in parallelo alla freccia Dx) all'interno del rettangolo rosso.

Questo rettangolo rappresenta anche un metodo di costruzione fisica.

Tutti i componenti all'interno del rettangolo sono montati su una singola cartolina con un risultato finale "robusto".

E' un modulo autoconsistente che puo' essere costruito e verificato a banco prima di essere applicato all'impianto frecce ed in caso di problemi puo' essere facilmente scollegato per ulteriori verifiche.

Questo metodo di lavoro porta a verifiche agevoli e risultati consistenti e ripetibili.

Riguardo ai led che si bruciano, non ho la risposta ma anche qui si tratta di un "metodo".

Un led, in genere, per essere alimentato, richiede una resistenza in serie.

Se le resistenza e' "lontana" sono possibili "miswiring".
Se, come in Fig. 1b, "integri" la resistenza nel led racchiudendo il tutto in una guaina termorestringente ed hai in uscita solo i due fili che vanno all'alimentazione ottieni un modulo comodo da utilizzare e tollerante anche rispetto ad errori come ad es. una eventale alimentazione invertita (scambio + con -)
Avatar utente
Foto Utenteelfo
3.597 2 5 7
Master
Master
 
Messaggi: 1539
Iscritto il: 15 lug 2016, 13:27

0
voti

[66] Re: Circuito per lampeggio non funziona.

Messaggioda Foto UtenteUSUL » 26 lug 2020, 16:11

le resistenze da 1k devono essere due, perché altrimenti il circuito di sinistra non funziona correttamente
grazie
Avatar utente
Foto UtenteUSUL
0 3
New entry
New entry
 
Messaggi: 70
Iscritto il: 6 lug 2020, 18:34

0
voti

[67] Re: Circuito per lampeggio non funziona.

Messaggioda Foto Utenteelfo » 26 lug 2020, 16:55

Due varianti sul tema (da sperimentare per verificarne il corretto funzionamento):

- Fig. 1a

Il rele' potrebbe essere sostituito con un transistor (o mosfet) di media potenza (5 A)

- Fig. 1b

-- tolto un transistor
-- tolta la resistenza da 100 ohm
-- aggiunto un diodo
-- sostituito un transistor con un mosfet (con un transistor al posto del mosfet il circuito NON funziona)
-- i valori delle resistenze sono aumentati di un fattore 20
-- il valore della capacita' e' ridotto di un fattore 40

Le varianti dei due circuiti possono essere "fuse insieme"

Infine - ma e' l'aspetto piu' importante - mi permetto di ricordare quello che ha scritto per primo Foto UtenteFranco012 e che quanto scritto in questo post e nei precedenti ha valore puramente di studio.
Franco012 ha scritto:tieni presente che il Codice della Strada non permette modifiche agli impianti soggetti ad omologazione (come gli indicatori di direzione)


Grazie di tutto e buon lavoro!

Avatar utente
Foto Utenteelfo
3.597 2 5 7
Master
Master
 
Messaggi: 1539
Iscritto il: 15 lug 2016, 13:27

0
voti

[68] Re: Circuito per lampeggio non funziona.

Messaggioda Foto UtenteUSUL » 26 lug 2020, 17:00

ti disturbo ancora un attimo poi ti lascio stare finché non faccio le prove
mi servirebbe il valore delle resistenze e sapere una sigla per il mosfet del transistor da 5A

grazie
Avatar utente
Foto UtenteUSUL
0 3
New entry
New entry
 
Messaggi: 70
Iscritto il: 6 lug 2020, 18:34

0
voti

[69] Re: Circuito per lampeggio non funziona.

Messaggioda Foto UtenteUSUL » 26 lug 2020, 17:07

in casa ho:
TIP31C, TIP127, IRLB3034S20C45C
Avatar utente
Foto UtenteUSUL
0 3
New entry
New entry
 
Messaggi: 70
Iscritto il: 6 lug 2020, 18:34

0
voti

[70] Re: Circuito per lampeggio non funziona.

Messaggioda Foto UtenteUSUL » 26 lug 2020, 18:01



non so se è giusto fatto cosi', ma vorrei sapere i valori delle resistenze, e i codici del mosfet e del transistor da 5 A

grazie
Avatar utente
Foto UtenteUSUL
0 3
New entry
New entry
 
Messaggi: 70
Iscritto il: 6 lug 2020, 18:34

PrecedenteProssimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti