Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Problema circuito startup di alimentatore switching

Tecniche per la costruzione e la riparazione di apparecchiature elettriche e non. Ricerca guasti. Adattamenti e riutilizzazioni

Moderatore: Foto Utentestefanob70

0
voti

[1] Problema circuito startup di alimentatore switching

Messaggioda Foto UtenteDarwinNE » 15 ago 2020, 0:40

Ciao a tutti,
sto riparando un vecchio monitor monocromatico Apple (è il modello per Macintosh, del 1992) e l'alimentatore switching che contiene ha delle difficoltà a "partire".

Si tratta di un circuito flyback basato su un TDA4605-3, ho alimentato il monitor con un trasformatore di isolamento ed ho dato un'occhiata a quello che succede su tutti i piedini dell'integrato. Mi sono accorto che la tensione al piedino di alimentazione (il 6) è troppo bassa (9,16V) rispetto alla soglia dichiarata nel datasheet perché l'integrato possa attivare la procedura di accensione (la soglia dovrebbe essere dalle parti di 12V).

Non ho purtroppo lo schema del circuito del monitor (si trova il service manual, ma non contiene lo schema), questo è quello di un'applicazione tipica preso da un datasheet:

pwm-qrictda4605-3.jpg


Nel monitor Apple, lo schema attorno al piedino 6 è leggermente diverso (per semplicità, non ho rappresentato alcuni filtri all'ingresso della tensione di rete):



Il componente che ho indicato come "NTC" è questa cosa qui:

20200815_000608.jpg

20200815_000650.jpg


Si tratta di una pastiglietta montata all'interno di un supporto plastico. Le piste sul lato saldature sono allargate, probabilmente per dissipare calore. Misuro 11,9 V ai capi dello zener, il che è coerente con una tensione troppo bassa per permettere al circuito di partire. Se applico 18V ai capi dello zener, il monitor si accende senza problemi.

A temperatura ambiente, sulla NTC misuro una resistenza dell'ordine di 5kohm. Aumentando la temperatura, la resistenza diminuisce, il che appunto caratterizza una NTC.

Ora, non capisco molto bene il perché ci sarebbe una NTC in quel punto, capirei al massimo una PTC, dato che dopo il ciclo di partenza l'integrato viene alimentato dalla tensione prelevata dal secondario del trasformatore flyback.

Ho provato a fare questa modifica ed il monitor si accende, ma la resistenza da 33kohm si scalda (potrei aumentarla, ma non ne avevo di adatte a dissipare 1 o 2 W):



Qualcuno ha esperienza con circuiti del genere? Il problema viene secondo voi da quella specie di NTC (senza sigla) che è invecchiata e fuori specifica?

(allego datasheet Siemens)
Allegati
Tda4605-2.pdf
(560.9 KiB) Scaricato 20 volte
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
26,9k 6 11 13
G.Master EY
G.Master EY
 
Messaggi: 3776
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

0
voti

[2] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto Utenteelfo » 15 ago 2020, 10:47

DarwinNE ha scritto:A temperatura ambiente, sulla NTC misuro una resistenza dell'ordine di 5kohm. Aumentando la temperatura, la resistenza diminuisce, il che appunto caratterizza una NTC.

Ora, non capisco molto bene il perché ci sarebbe una NTC in quel punto, capirei al massimo una PTC, dato che dopo il ciclo di partenza l'integrato viene alimentato dalla tensione prelevata dal secondario del trasformatore flyback.

Io ragionerei (??? cosi' - se sragiono e' solo colpa del caldo :mrgreen: )

Nello schema qui sotto si hanno due casi:

- rosso alimentatore "alla partenza"
- celeste alimentatore "partito")

Alla partenza V = 0 e dopo partito V e' ovviamente V > 0

di conseguenza la corrente che circola nell'NTC

- alla partenza e' "max"
- ad alimentatore "partito" si riduce perche' c'e' il contributo dal secondario

Questo vuol dire che la NTC (ad alimentatore partito) si scalda "meno" (minore corrente) e quindi aumenta la sua resistenza.

In questo modo - ad alimentatore acceso - il contributo di corrente per lo zener proveniente direttamente dai 230 V e' minimo.

CVD :D
Avatar utente
Foto Utenteelfo
3.762 2 5 7
Master
Master
 
Messaggi: 1655
Iscritto il: 15 lug 2016, 13:27

0
voti

[3] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto UtenteDarwinNE » 16 ago 2020, 14:08

Quello che mi lascia perplesso è che a freddo la resistenza della NTC è bassa (anche se 5kohm per me sono molto pochi).

Mi lascia perplesso anche la scelta di utilizzare la tensione a monte del ponte (così è una tensione pulsante rispetto alla massa). Forse perché la tensione media è più bassa e si dissipa meno potenza nella resistenza?
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
26,9k 6 11 13
G.Master EY
G.Master EY
 
Messaggi: 3776
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

0
voti

[4] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto Utentemaxmix69 » 16 ago 2020, 14:30

Ci sono i moduli NTC/PTC che si usano per smagnetizzare i TV a colori con tubo catodico. Nello stesso contenitore plastico avevano sia una NTC che una PTC, con un terminale in comune. Ne recuperi uno, ti assicuri che la resistenza a freddo non sia troppo bassa e vedi se il tuo circuito funziona meglio con la NTC o con la PTC. Diversamente un relè con mezzo secondo di temporizzazione che ti inserisce una resistenza di startup. Soluzioni non proprio ortodosse le mie, ma sicuramente funzionali. Sempre nei TV color si usava a volte un interruttore di accensione che a fondo corsa premeva un pulsante, tale pulsante lo puoi usare per inserire temporaneamente la solita resistenza di startup. L'interruttore spesso lo trovi da quelli che vendono ricambi per elettrodomestici.
Avatar utente
Foto Utentemaxmix69
95 1 5
Frequentatore
Frequentatore
 
Messaggi: 187
Iscritto il: 6 lug 2013, 20:18

0
voti

[5] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto UtenteDarwinNE » 16 ago 2020, 16:17

Grazie dei suggerimenti, Foto Utentemaxmix69, penso che opterò per una semplice resistenza per la riparazione, dopotutto va nella direzione del circuito con il datasheet Siemens.

Tuttavia vorrei capire di più sul ruolo di quel componente e sulla dinamica del guasto.
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
26,9k 6 11 13
G.Master EY
G.Master EY
 
Messaggi: 3776
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

0
voti

[6] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto Utenteelfo » 16 ago 2020, 16:28

Potresti fare un "ibrido":

mettere in parallelo alla NTC esistente una resistenza con il valore massimo che fa "partire" l'alimentatore.
Avatar utente
Foto Utenteelfo
3.762 2 5 7
Master
Master
 
Messaggi: 1655
Iscritto il: 15 lug 2016, 13:27

0
voti

[7] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto UtenteDarwinNE » 16 ago 2020, 16:32

Già fatto. L'oscillatore parte, ma ho dovuto mettere una resistenza molto più piccola di quello che mi aspettavo (dalle parti di 2,2kohm).

Mi chiedo se il problema non venga dal TDA4605 che per una ragione o per un'altra richiede molta più corrente del normale per partire.
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
26,9k 6 11 13
G.Master EY
G.Master EY
 
Messaggi: 3776
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

0
voti

[8] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto UtenteIsidoroKZ » 16 ago 2020, 16:41

Dopo che e` partito, se togli la resistenza, continua a funzionare?

Darei comunque un'occhiata al circuito formato da diodo e condensatore.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
106,8k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18853
Iscritto il: 17 ott 2009, 0:00

0
voti

[9] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto Utentemaxmix69 » 16 ago 2020, 16:59

DarwinNE ha scritto:Mi chiedo se il problema non venga dal TDA4605 che per una ragione o per un'altra richiede molta più corrente del normale per partire.

Io davo per scontato che hai già controllato i componento intorno all'integrato!!!
Avatar utente
Foto Utentemaxmix69
95 1 5
Frequentatore
Frequentatore
 
Messaggi: 187
Iscritto il: 6 lug 2013, 20:18

0
voti

[10] Re: Problema circuito startup di alimentatore switching

Messaggioda Foto UtenteDarwinNE » 16 ago 2020, 23:41

Ho controllato lo zener, il condensatore, le resistenze che ho indicato sullo schema. Ho anche controllato tutti i diodi del ponte e quello che viene dal secondario del trasformatore flyback.

Ieri pensavo che il TDA4605 funzionasse bene perché riuscivo a farlo partire con la resistenza che ho mostrato nell'ultimo schema del mio primo messaggio (per rispondere ad Foto UtenteIsidoroKZ, sì, una volta che il circuito partiva rimaneva acceso anche togliendo la resistenza). Oggi ho riprovato e non è più così, non si riesce proprio più ad accendere. Non mi pare di averlo maltrattato troppo tra ieri ed oggi, ma magari per una ragione o per un'altra c'era già un comportamento borderline.

Mi sa proprio che il problema è il TDA4605, lo cambio e vediamo.
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
26,9k 6 11 13
G.Master EY
G.Master EY
 
Messaggi: 3776
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

Prossimo

Torna a Costruzione, riparazione, riutilizzo

Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti