Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Diagramma di Bode problematico con OTA

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utenteg.schgor, Foto UtenteIsidoroKZ, Foto UtenteBrunoValente, Foto Utentecarloc

0
voti

[1] Diagramma di Bode problematico con OTA

Messaggioda Foto Utentemazzons98 » 9 ott 2020, 15:04

Sto provando a simulare un OTA, progettato passo passo seguendo un esempio guidato per la realizzazione. La simulazione è svolta in LTSpice con parametri usati di livello 1. Il problema che mi si presenta riguarda il diagramma di Bode una volta che eseguo .ac. Da progetto la banda dovrebbe essere 5MHz e proprio con questa ricavo alcuni parametri per la realizzazione dei circuito. Eppure il risultato non coincide. Non so se ho sbagliato a mettere i parametri... dove sto sbagliando? Allego gli screen dell'esercizio/esempio di progetto e il file LTSpice usato.

Parametri di progetto:
A_v>5000V/V; GB=5MHz; V_out range=+/-2V V_DD=2.5V C_L=10pF ICMR=-1 to 2 V; V_SS=-2.5V SR>10V/us; P_diss<=2mW

Parametri spice level 1:
esempio PMOS: .model <Nome-MOS> PMOS (VT0=-0.85 KP=50e-6 tox=14n gamma=0.57 lambda=0.05 phi=0.4 CGSO=220p CGDO=220p CGBO=700p cj=560u cjsw=350p mj=0.5 mjsw=0.35 ad=36p pd=19.8u as=36p ps=19.8u)

esempio NMOS: .model <Nome-MOS> NMOS (VT0=0.85 KP=110e-6 tox=14n gamma=0.4 lambda=0.04 phi=0.35 CGSO=220p CGDO=220p CGBO=700p cj=770u cjsw=380p mj=0.5 mjsw=0.38 ad=33.6p pd=18.8u as=33.6p ps=18.8u)

Soluzione/circuito: vedi allegato
Anteprima LTSpice: vedi allegato
Diagramma Bode: vedi allegato
Allegati
Schermata 2020-10-09 alle 15.02.16.png
Schermata 2020-10-09 alle 14.59.53.png
IMG_1186.jpg
Avatar utente
Foto Utentemazzons98
5 2
 
Messaggi: 12
Iscritto il: 9 ott 2020, 9:29

0
voti

[2] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto UtenteIsidoroKZ » 10 ott 2020, 1:28

A me sembra che vada bene. Quando si parla di banda di un operazionale di solito si intende il prodotto guadagno banda, non la frequenza del polo dominante dell'operazionale ad anello aperto.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
107,8k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 19033
Iscritto il: 17 ott 2009, 0:00

0
voti

[3] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto Utentemazzons98 » 10 ott 2020, 11:25

Ok in effetti 80dB=10^4 e a 500Hz sono 5MHz. Grazie
Avatar utente
Foto Utentemazzons98
5 2
 
Messaggi: 12
Iscritto il: 9 ott 2020, 9:29

0
voti

[4] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto UtenteMarcoD » 10 ott 2020, 12:39

A cosa corrisponde l'acronimo OTA ?
Intendevi OPA ? OPerational Amplifier ? o quaalcosa d'altro?
O_/
Avatar utente
Foto UtenteMarcoD
7.608 4 8 13
Master EY
Master EY
 
Messaggi: 3467
Iscritto il: 9 lug 2015, 16:58
Località: Torino

0
voti

[5] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto Utentemazzons98 » 10 ott 2020, 14:57

Operational Transconductance Amplifier, amplificatore a transconduttanza
Avatar utente
Foto Utentemazzons98
5 2
 
Messaggi: 12
Iscritto il: 9 ott 2020, 9:29

0
voti

[6] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto UtentePietroBaima » 10 ott 2020, 15:02

Da quale fonte proviene lo schema elettrico del primo post?
Generatore codice per articoli:
nomi
emoticon
citazioni
formule latex

Io capisco le cose per come le scrivete. Per esempio: K sono kelvin e non chilo, h.z è la costante di Planck per zepto o per la zeta di Riemann e l'inverso di una frequenza non si misura in siemens.
Avatar utente
Foto UtentePietroBaima
80,5k 6 12 13
G.Master EY
G.Master EY
 
Messaggi: 10167
Iscritto il: 12 ago 2012, 1:20
Località: Londra

0
voti

[7] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto Utentemazzons98 » 11 ott 2020, 11:15

È un circuito di transistor preso da un libro (CMOS Analog Circuit Design, Allen, Holberg, OXFORD U.P.). C'è un capitolo dedicato alla progettazione dati i parametri.
Avatar utente
Foto Utentemazzons98
5 2
 
Messaggi: 12
Iscritto il: 9 ott 2020, 9:29

0
voti

[8] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto UtentePietroBaima » 11 ott 2020, 12:04

mazzons98 ha scritto:CMOS Analog Circuit Design, Allen, Holberg, OXFORD U.P.

I KNEW IT. :D
Bellissimo libro, bravo.
Generatore codice per articoli:
nomi
emoticon
citazioni
formule latex

Io capisco le cose per come le scrivete. Per esempio: K sono kelvin e non chilo, h.z è la costante di Planck per zepto o per la zeta di Riemann e l'inverso di una frequenza non si misura in siemens.
Avatar utente
Foto UtentePietroBaima
80,5k 6 12 13
G.Master EY
G.Master EY
 
Messaggi: 10167
Iscritto il: 12 ago 2012, 1:20
Località: Londra

0
voti

[9] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto Utentemazzons98 » 12 ott 2020, 9:24

Un'altra cosa. Mi rendo conto dal diagramma di Bode che il problema è il margine di fase. Secondo il progetto che ho seguito dovrebbe essere almeno 60° (per avere questo margine di fase si inserisce CM>0.22*CL; in questo caso CM deve essere più grande di 2.2 pF, quindi si sceglie 3pF). Invece ritorna 47°... è un problema di Spice? Oppure mi sfugge qualcosa?
PS: ho corretto i parametri dei MOS relativi al perimetro e all'area di drain e source, ma il problema persiste
Avatar utente
Foto Utentemazzons98
5 2
 
Messaggi: 12
Iscritto il: 9 ott 2020, 9:29

0
voti

[10] Re: Diagramma di Bode problematico con OTA

Messaggioda Foto UtenteIsidoroKZ » 13 ott 2020, 23:47

Non ho sotto mano lo Allen Holberg, e` possibile che il condensatore di compensazione sia determinato con qualche approssimazione, prova a fare una spazzolata dei valori di CM e vedere che cosa capita al margine di fase.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
107,8k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 19033
Iscritto il: 17 ott 2009, 0:00


Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 70 ospiti