Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Oscillatore onda quadra con TL082

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteBrunoValente

1
voti

[1] Oscillatore onda quadra con TL082

Messaggioda Foto Utenterusty » 13 gen 2012, 18:05

Salve ragazzi, ho realizzato su piastra sperimentale un oscillatore a onda quadra con un TL082, che accende alternativamente due led alla frequenza di circa 1 Hz, o meglio dovrebbe! Pechè sulla carta tutto funziona mentre quando vado a dare alimentazione non succede proprio nulla. I valori e le connessioni del tutto sono corrette, ho un dubbio sul funzionamento del TL082, che sia lui bruciato?
Appena do' corrente all'accrocchio noto che i led lampeggiano molto piu' velocemente di 1 Hz, direi 5 o 6 Hz a occhio (ma non posso essere preciso ovviamente) e con una intensita' luminosa molto molto bassa, si vedono a malapena al buio: i led sono i classici led rossi. Quale potrebbe essere il problema? Il mio TL082 si mette ad autooscillare? Posto schema fidocad e simulazioni.

Grazie a tutti.



Immagine.jpg
Schema in LTSpice
Immagine.jpg (35.77 KiB) Osservato 3882 volte


Immagine2.jpg
Tensione al nodo tra i led
Immagine2.jpg (49.46 KiB) Osservato 3882 volte


Immagine3.jpg
Corrente attraverso uno dei led
Immagine3.jpg (46.13 KiB) Osservato 3882 volte
Avatar utente
Foto Utenterusty
4.077 2 9 11
Utente disattivato per decisione dell'amministrazione proprietaria del sito
 
Messaggi: 1578
Iscritto il: 25 gen 2009, 13:10

4
voti

[2] Re: Oscillatore onda quadra con TL082

Messaggioda Foto UtenteIsidoroKZ » 13 gen 2012, 18:20

Benvenuto nel mondo reale, dove gli operazionali non si comportano come i modelli spice :)

L'impedenza del potenziale 0V e` troppo elevata, metti un voltage follower dopo il partitore che crea lo 0V e spera che ce la faccia.

Collegherei i due led con due resistenze alle alimentazioni, e l'uscita dell'operazionale in mezzo, ma non sono sicuro che con dei led rossi si riescano a spegnere.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
104,0k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18479
Iscritto il: 17 ott 2009, 0:00

1
voti

[3] Re: Oscillatore onda quadra con TL082

Messaggioda Foto Utenterusty » 13 gen 2012, 18:58

Ciao Isidoro, eh gia'... è proprio il caso di dire "welcome to the real world!" [cit. Matrix] :D
Ho modificato lo schema come segue, usando l'altro opamp del tl082, ma come da te previsto i led non riescono a spegnersi, vedo che "brillano un pochino meno" nell'oscillazione, ma proprio impercettibilmente.
Pensavo fosse un circuitino semplice semplice, ed invece mi sta fregando alla grande! ;-)
BTW ora si accendono, non so se i valori e le modifiche sono proprio quelle che intendevi, grazie comunque :ok:

Avatar utente
Foto Utenterusty
4.077 2 9 11
Utente disattivato per decisione dell'amministrazione proprietaria del sito
 
Messaggi: 1578
Iscritto il: 25 gen 2009, 13:10

1
voti

[4] Re: Oscillatore onda quadra con TL082

Messaggioda Foto UtenteIsidoroKZ » 13 gen 2012, 19:49

La resistenza da 10k in serie all'uscita dell'operazionale non serve, le resistenze da 220 ohm in serie ai led mettile da almeno 1kohm.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
104,0k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18479
Iscritto il: 17 ott 2009, 0:00

2
voti

[5] Re: Oscillatore onda quadra con TL082

Messaggioda Foto UtenteIsidoroKZ » 13 gen 2012, 22:29

Alla fine dei conti funziona il circuito, con le resistenze che dicevo nel messaggio precedente (anzi, meglio, 2.2kohm).

Problema interessante: perche' in simulazione funziona e nella realta` no? Dov'e` il problema nel modello?
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
104,0k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18479
Iscritto il: 17 ott 2009, 0:00

0
voti

[6] Re: Oscillatore onda quadra con TL082

Messaggioda Foto Utenterusty » 14 gen 2012, 1:47

Grande Isidoro! Ora funziona perfettamente in "real", tutto ok. Ma la simulazione, caso strano, ora non torna. Ho provato a simularlo per sfizio, e vedo che la corrente che scorre attraverso i led (ad esempio quello in alto nello schema) è di soli 4 mA e mezzo... come diavolo fa ad accendersi il led? Presumo ci sia qualche discrepanza tra modello dei led, del tl082, o qualcos'altro (ma cosa?). Un bell'inghippo :?

Posto schema fidocad, simulazione in LTSpice e relativi modelli usati.



schema.jpg
Schema simulato
schema.jpg (43.92 KiB) Osservato 3826 volte


corrente.jpg
Corrente LED
corrente.jpg (47.75 KiB) Osservato 3826 volte


Modello del led è:
.MODEL LED1 D (IS=93.2P RS=42M N=3.73 BV=4 IBV=10U CJO=2.97P VJ=.75 M=.333 TT=4.32U)

Modello TL082.sub è:
Codice: Seleziona tutto
* TL082 OPERATIONAL AMPLIFIER "MACROMODEL" SUBCIRCUIT
* CREATED USING PARTS RELEASE 4.01 ON 06/16/89 AT 13:08
* (REV N/A)      SUPPLY VOLTAGE: +/-15V
* CONNECTIONS:   NON-INVERTING INPUT
*                | INVERTING INPUT
*                | | POSITIVE POWER SUPPLY
*                | | | NEGATIVE POWER SUPPLY
*                | | | | OUTPUT
*                | | | | |
.SUBCKT TL082    1 2 3 4 5
*
  C1   11 12 3.498E-12
  C2    6  7 15.00E-12
  DC    5 53 DX
  DE   54  5 DX
  DLP  90 91 DX
  DLN  92 90 DX
  DP    4  3 DX
  EGND 99  0 POLY(2) (3,0) (4,0) 0 .5 .5
  FB    7 99 POLY(5) VB VC VE VLP VLN 0 4.715E6 -5E6 5E6 5E6 -5E6
  GA    6  0 11 12 282.8E-6
  GCM   0  6 10 99 8.942E-9
  ISS   3 10 DC 195.0E-6
  HLIM 90  0 VLIM 1K
  J1   11  2 10 JX
  J2   12  1 10 JX
  R2    6  9 100.0E3
  RD1   4 11 3.536E3
  RD2   4 12 3.536E3
  RO1   8  5 150
  RO2   7 99 150
  RP    3  4 2.143E3
  RSS  10 99 1.026E6
  VB    9  0 DC 0
  VC    3 53 DC 2.200
  VE   54  4 DC 2.200
  VLIM  7  8 DC 0
  VLP  91  0 DC 25
  VLN   0 92 DC 25
.MODEL DX D(IS=800.0E-18)
.MODEL JX PJF(IS=15.00E-12 BETA=270.1E-6 VTO=-1)
.ENDS TL082


BTW il tutto ora funziona perfettamente in real, anche se non capisco questa discrepanza con la simulazione.
Grazie infinite Isidoro :ok:
Avatar utente
Foto Utenterusty
4.077 2 9 11
Utente disattivato per decisione dell'amministrazione proprietaria del sito
 
Messaggi: 1578
Iscritto il: 25 gen 2009, 13:10

3
voti

[7] Re: Oscillatore onda quadra con TL082

Messaggioda Foto UtentePiercarlo » 14 gen 2012, 1:55

rusty ha scritto:...e vedo che la corrente che scorre attraverso i led (ad esempio quello in alto nello schema) è di soli 4 mA e mezzo... come diavolo fa ad accendersi il led?


Con 4.5 mA i LED si accendono eccome!

Ciao
Piercarlo
Avatar utente
Foto UtentePiercarlo
21,8k 6 10 13
CRU - Account cancellato su Richiesta utente
 
Messaggi: 5951
Iscritto il: 30 mar 2010, 19:23
Località: Milano

1
voti

[8] Re: Oscillatore onda quadra con TL082

Messaggioda Foto UtenteIsidoroKZ » 14 gen 2012, 1:55

La corrente nel led in realta` e` ancora meno di 4.5mA, bastano anche solo 2mA per accendere un led normale, non a piena luce, ma sicuramente ben visibile. Ho tenuto la corrente bassa perche' e` quella che arriva da un operazionale alimentato a tensione bassa, non so quanto riesca a tirare fuori, non sono andato a leggere il data sheet, e volevo garantire che l'altro led si spegnesse (e ancora avevo qualche dubbio).

Edit: ho modificato le righe successive rispetto alla stesura originale

Perche' senza il buffer sullo 0V la simulazione diceva che la prima versione funzionava mentre il circuito non andava (o andava molto male)?

Probabilmente adesso con la nuova configurazione dei led e le resistenze del partitore piu` basse funziona anche senza buffer sullo 0V.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
104,0k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18479
Iscritto il: 17 ott 2009, 0:00

0
voti

[9] Re: Oscillatore onda quadra con TL082

Messaggioda Foto Utenterusty » 15 gen 2012, 23:32

Grazie ragazzi, mi sono accorto della mia stupidita'. Non so per quale motivo ero ormai convinto che ad un led standard di quel tipo dovessi dare 20mA, non pensando che il led si accende anche con molta meno corrente, addirittura di un ordine di grandezza inferiore alla corrente nominale.
Mi ricordero' per il futuro di questa mia defiance, non so perché nel primissimo schema il mio circuito funzionava male, ora funziona tutto come dovrebbe e senza il voltage follower.
Grazie Foto UtenteIsidoroKZ
Avatar utente
Foto Utenterusty
4.077 2 9 11
Utente disattivato per decisione dell'amministrazione proprietaria del sito
 
Messaggi: 1578
Iscritto il: 25 gen 2009, 13:10

0
voti

[10] Re: Oscillatore onda quadra con TL082

Messaggioda Foto UtenteIsidoroKZ » 15 gen 2012, 23:38

No, il problema non e` quello. Anche mettendo 5mA sui led, il primo circuito funziona in simulazione e non in realta`. La ragione non e` il livello della corrente e` qualcosa di piu` malefico e nascosto.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
104,0k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18479
Iscritto il: 17 ott 2009, 0:00

Prossimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 22 ospiti