Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Problema equazioni di stato

Circuiti e campi elettromagnetici

Moderatori: Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteEdmondDantes

0
voti

[1] Problema equazioni di stato

Messaggioda Foto Utentejoopdf » 24 lug 2012, 13:54

Buon giorno a tutti, ho dei problemi a ricavare le equazioni di stato di questo circuito, di cui, di seguito, ho anche aggiunto il c. resistivo associato e la scomposizione a valle dell'applicazione del principio di sovrapposizione degli effetti:


Avendo usato queste convenzioni, le relazioni caratteristiche saranno:
i_C = -C\frac{\mathrm{d} v_C}{\mathrm{d} t}
v_L = -L\frac{\mathrm{d} i_L}{\mathrm{d} t}

Ora scrivo i_C e v_L in funzione di v_C e i_L usando la sovrapposizione degli effetti:

i_C = \frac{E}{R_1 + R_2} + \frac{v_C}{R_1 + R_2} + \frac{i_L R_2}{R_1 + R_2}
v_L = E\frac{R_2}{R_1+R_2} + v_C\frac{R_2}{R_1+R_2} - i_L\frac{R_1R_2}{R_1 + R_2}

Il problema è che quando tento di ricavare l'equazione differenziale del secondo ordine in i_L, ottengo sia coefficienti negativi e sia che il forzamento E, al secondo membro, si annulla... Non riesco a capire dove sbaglio a scrivere le equazioni. Nello specifico ottengo questo: (avendo posto R_1 = R_2 = 4 \Omega)

2LC\frac{\mathrm{d^2}i_L }{\mathrm{d} t^2} + (\frac{1}{4}L - 4C)\frac{\mathrm{d} i_L}{\mathrm{d} x} - \frac{1}{2}i_L = 0

Come mai?
Avatar utente
Foto Utentejoopdf
5 3
 
Messaggi: 15
Iscritto il: 19 lug 2012, 13:38

0
voti

[2] Re: Problema equazioni di stato

Messaggioda Foto UtenteRenzoDF » 24 lug 2012, 14:32

Anche se non capisco il perché di quella scelta per le convenzioni, direi che l'equazione di stato relativa a vL ha tutti i segni errati a secondo membro; potresti anche usarla così com'è usando però come relazione costitutiva per il bipolo induttore la classica

v_{L}=L\frac{\text{d}i_{L}}{\text{d}t}
"Il circuito ha sempre ragione" (Luigi Malesani)
Avatar utente
Foto UtenteRenzoDF
51,5k 8 12 13
G.Master EY
G.Master EY
 
Messaggi: 12281
Iscritto il: 4 ott 2008, 9:55

0
voti

[3] Re: Problema equazioni di stato

Messaggioda Foto Utentejoopdf » 24 lug 2012, 14:45

D'accordo che i segni sono sbagliati sulla relazione di vL, ma non riesco a capire il motivo. Il primo termine, ad esempio, lo ottengo usando un partitore di tensione ai capi della resistenza R_2. I versi delle tensione E e della tensione v_R_2, secondo questa convenzione, risultano concordi. Non devo usare il segno positivo?! Per l'ultimo termine, ad esempio, ho usato il partitore di corrente nel ramo in cui è presente R_2. I versi della corrente sono concordi al nodo. Non devo usare il segno negativo in questo caso ?!
Avatar utente
Foto Utentejoopdf
5 3
 
Messaggi: 15
Iscritto il: 19 lug 2012, 13:38

0
voti

[4] Re: Problema equazioni di stato

Messaggioda Foto UtenteRenzoDF » 24 lug 2012, 14:47

Ti rispondo con una domanda: vista quella tua scelta per la relazione costitutiva del bipolo induttore, ando' sta il positivo della vL ?
"Il circuito ha sempre ragione" (Luigi Malesani)
Avatar utente
Foto UtenteRenzoDF
51,5k 8 12 13
G.Master EY
G.Master EY
 
Messaggi: 12281
Iscritto il: 4 ott 2008, 9:55

0
voti

[5] Re: Problema equazioni di stato

Messaggioda Foto Utentejoopdf » 24 lug 2012, 14:52

Forse ho capito dove sbaglio, ti prego di darmi una conferma. Io ho scritto quelle relazioni considerando la tensione ai capi della resistenza R_2, dove ho usato la convenzione dell'utilizzatore (sulla resistenza). Secondo ciò che ho scritto, la vL, è opposta alla tensione ai capi della resistenza R_2. Quindi è giustificato il cambio di segno a tutti i termini...
Avatar utente
Foto Utentejoopdf
5 3
 
Messaggi: 15
Iscritto il: 19 lug 2012, 13:38

1
voti

[6] Re: Problema equazioni di stato

Messaggioda Foto UtenteRenzoDF » 24 lug 2012, 14:53

:ok: ... se posso darti un consiglio, indica sempre le convenzioni sullo schema per esempio in questo caso la vL corredata di segno "+" e segno "-", e non usare per il verso dei GIC il "+", ma usa invece una freccia.

BTW mi spieghi il perché di quelle scelte per le convenzioni su C e su L? ... io penso di non averle mai usate in vita mia ;-)
"Il circuito ha sempre ragione" (Luigi Malesani)
Avatar utente
Foto UtenteRenzoDF
51,5k 8 12 13
G.Master EY
G.Master EY
 
Messaggi: 12281
Iscritto il: 4 ott 2008, 9:55

0
voti

[7] Re: Problema equazioni di stato

Messaggioda Foto Utentejoopdf » 24 lug 2012, 15:11

Perché quando realizzo la rete resistiva associata, ottengo sui generatori la convenzione del generatore e mi risulta più facile (essendo alle prime armi e, ahimè, sbagliando parecchio) calcolare le tensioni e le correnti. Devo fare un po' di esercizio a calcolare tensioni e correnti quando sui generatori è presente la convenzione dell'utilizzatore perché purtroppo mi confondo con i segni ! :cry:
Avatar utente
Foto Utentejoopdf
5 3
 
Messaggi: 15
Iscritto il: 19 lug 2012, 13:38

0
voti

[8] Re: Problema equazioni di stato

Messaggioda Foto Utentejoopdf » 24 lug 2012, 15:35

Provando a ragionare secondo la convenzione opposta da te suggerita, non riesco a capire perché, ad esempio, nella prima equazione che descrive i_C, il primo termine (che si ottiene lasciando acceso soltanto il forzamento del generatore E) deve cambiare di segno dato che sto usando sempre la convenzione del generatore sul generatore di tensione E (cioè uso la stessa configurazione di prima, con la convenzione adottata da me). La corrente i_C, non ha lo stesso verso della corrente che passa attraverso il generatore E ? Ovviamente, però, se non inverto il segno a tutti e tre i termini la relazione non è più giusta...
Avatar utente
Foto Utentejoopdf
5 3
 
Messaggi: 15
Iscritto il: 19 lug 2012, 13:38

1
voti

[9] Re: Problema equazioni di stato

Messaggioda Foto UtenteRenzoDF » 25 lug 2012, 10:21

joopdf ha scritto:... non riesco a capire perché,...

In elettrotecnica si ragiona con formule e schemi, non con parole.
"Il circuito ha sempre ragione" (Luigi Malesani)
Avatar utente
Foto UtenteRenzoDF
51,5k 8 12 13
G.Master EY
G.Master EY
 
Messaggi: 12281
Iscritto il: 4 ott 2008, 9:55

0
voti

[10] Re: Problema equazioni di stato

Messaggioda Foto Utentejoopdf » 25 lug 2012, 12:57



Ecco a te lo schema con le convenzioni opposte a quelle che avevo applicato io.

vL, in questo caso, è concorde alla tensione su R2. Quando applico la sovrapposizione degli effetti, ottengo quei tre schemi.

In particolare, dal secondo schema :



Volendo trovare la vL, applico il partitore di tensione ai capi della serie R1 ed R2 e ricavo la tensione su R2. Vedendo la tensione ai capi della serie, dalla parte del generatore, il nodo A risulta quello a potenziale più alto e quindi la tensione totale vC risulta discorde a quella che sto trovando su R2. Non dovrei mettere un segno meno? Cioè: v^{ii}_L = -v_C\frac{R_2}{R_2+R_1}\frac{}{}

Stesso discorso sul terzo schema... Avendo la corrente totale iL ai capi del parallelo ed essendo la corrente che scorre sul ramo in cui c'è R2 concorde con iL, non dovrei porre un segno meno?. Qui c'è il segno meno nell'equazione [1], quindi sono d'accordo.
Avatar utente
Foto Utentejoopdf
5 3
 
Messaggi: 15
Iscritto il: 19 lug 2012, 13:38

Prossimo

Torna a Elettrotecnica generale

Chi c’è in linea

Visitano il forum: Google [Bot] e 9 ospiti