Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

[Arduino + Powerbank + LED] 3.7V sulla linea dei 5V

Progetti, interfacciamento, discussioni varie su questa piattaforma.

Moderatori: Foto UtenteMassimoB, Foto UtenteWALTERmwp, Foto Utentexyz

0
voti

[1] [Arduino + Powerbank + LED] 3.7V sulla linea dei 5V

Messaggioda Foto UtenteDani88 » 16 giu 2016, 9:42

Ciao a tutti,
avrei bisogno del parere di persone più esperte di me su un problema che non riesco a capire.
Ho un circuito fatto con Arduino che pilota 15 led WS2812 (quelli che Adafruit chiama NeoPixel).
Attaccando il tutto ad un alimentatore ATX che uso come "da banco", misurando con il tester, in fase di funzionamento i led assorbono circa 300mA.

Il tutto dovrà essere trasportabile, quindi al momento ho deciso di utilizzare un powerbank come fonte di alimentazione. Nello specifico il powerbank è questo:
Anker PowerCore 13000

Il problema è che quando alimento col powerbank, misurando sul PCB la linea dei 5V ne trovo 3.4/3.7V.
Non riesco a capire se è il powerbank che non ce la fa o se c'è qualche protezione interna.
Avatar utente
Foto UtenteDani88
10 3
New entry
New entry
 
Messaggi: 68
Iscritto il: 26 set 2010, 20:37

0
voti

[2] Re: [Arduino + Powerbank + LED] 3.7V sulla linea dei 5 V

Messaggioda Foto UtenteSjuanez » 16 giu 2016, 12:48

Ti dispiace linkare/spiegare anche che arduino stai usando? Hai collegato l'ingresso USB?

Ho lo stesso powerbank e posso farti qualche prova. ;-)

O_/ O_/ O_/
Più so e più mi accorgo di non sapere.

Qualsiasi cosa abbia scritto, tieni presente che sono ancora al mio primo rocchetto di stagno.
Avatar utente
Foto UtenteSjuanez
11,3k 5 8 13
G.Master EY
G.Master EY
 
Messaggi: 3480
Iscritto il: 18 mar 2015, 13:48

0
voti

[3] Re: [Arduino + Powerbank + LED] 3.7V sulla linea dei 5 V

Messaggioda Foto UtenteDani88 » 16 giu 2016, 13:04

Sto utilizzando Arduino 2009.
Per quanto riguarda l'alimentazione in pratica il prototipo è una shield per Arduino e integra una porta USB Type B, quindi i 5V li prendo da li (non uso la porta USB della scheda Arduino).
Dalla mia shield i 5V poi vengono inviati alla scheda di Arduino per far funzionare il micro e utilizzati per alimentare il resto della shield, tra cui la striscia di 15 led.

Mi hanno spostato il thread qui in Arduino, ma dubito fortemente che il problema sia legato al microcontroller :)
Avatar utente
Foto UtenteDani88
10 3
New entry
New entry
 
Messaggi: 68
Iscritto il: 26 set 2010, 20:37

0
voti

[4] Re: [Arduino + Powerbank + LED] 3.7V sulla linea dei 5 V

Messaggioda Foto UtenteSjuanez » 16 giu 2016, 13:42

Il thread non l'ho spostato io, ma qui sta bene perché il problema è comunque legato ad un Arduino. È solo per tenere ordinato il forum.

Dunque, io non sono un esperto, ma come te ho trafficato con neopixel e power bank.

Quello che misuri, secondo me, è la tensione del powerbank "a riposo". Cioè secondo lui non sta alimentando nulla.

Ebbi lo stesso problema con questo progetto: http://www.electroyou.it/sjuanez/wiki/r ... y-a-colori

Lo risolsi mettendo in corto i D+ e D- dell'USB tra loro. Questo faceva in modo che il powerbank "pensava" di star caricando un dispositivo ed erogava la potenza necessaria di conseguenza.

Vuoi provare a verificare la cosa con il multimetro?

O_/ O_/ O_/
Più so e più mi accorgo di non sapere.

Qualsiasi cosa abbia scritto, tieni presente che sono ancora al mio primo rocchetto di stagno.
Avatar utente
Foto UtenteSjuanez
11,3k 5 8 13
G.Master EY
G.Master EY
 
Messaggi: 3480
Iscritto il: 18 mar 2015, 13:48

0
voti

[5] Re: [Arduino + Powerbank + LED] 3.7V sulla linea dei 5 V

Messaggioda Foto Utentealev » 16 giu 2016, 14:12

Il thread non l'ho spostato io

Infatti l'ho spostato io, esattamente per le ragioni indicate da te....perspicace, eh :mrgreen:
Avatar utente
Foto Utentealev
4.160 2 8 12
free expert
 
Messaggi: 4140
Iscritto il: 19 lug 2010, 14:38
Località: Altrove

0
voti

[6] Re: [Arduino + Powerbank + LED] 3.7V sulla linea dei 5 V

Messaggioda Foto UtenteDani88 » 16 giu 2016, 14:23

Ci avevo pensato anch'io alla cosa di D+ e D-, però non ho provato a metterli in corto ancora. Appena riesco provo :)

Non ho capito invece cosa intendi con
Quello che misuri, secondo me, è la tensione del powerbank "a riposo". Cioè secondo lui non sta alimentando nulla.

Aspetta provo a spiegarmi meglio :D
• alimentatore ATX (5V) --> shield alimentata --> sul PCB nei 5V misuro 4.7V, i LED consumano circa 0.3A
• Powerbank --> shield alimentata --> sul PCB nei 5V misuro 3.4/3.7V, i LED consumano circa 0.19/0.2A

È come se ci fosse una caduta ti tensione e/o il powerbank non riuscisse ad alimentare il circuito con la potenza richiesta (anche se mi sembra strano essendo le uscite da oltre 1A)
Avatar utente
Foto UtenteDani88
10 3
New entry
New entry
 
Messaggi: 68
Iscritto il: 26 set 2010, 20:37

0
voti

[7] Re: [Arduino + Powerbank + LED] 3.7V sulla linea dei 5 V

Messaggioda Foto UtenteSjuanez » 16 giu 2016, 14:28

Se ho ragione, misurando i pin del powerbank scollegato dalla scheda con il tester, otterrai proprio quella tensione e non i 5 volt del power bank "a lavoro "

Scusa la risposta stringata

O_/ O_/ O_/
Più so e più mi accorgo di non sapere.

Qualsiasi cosa abbia scritto, tieni presente che sono ancora al mio primo rocchetto di stagno.
Avatar utente
Foto UtenteSjuanez
11,3k 5 8 13
G.Master EY
G.Master EY
 
Messaggi: 3480
Iscritto il: 18 mar 2015, 13:48

0
voti

[8] Re: [Arduino + Powerbank + LED] 3.7V sulla linea dei 5 V

Messaggioda Foto UtenteDani88 » 17 giu 2016, 12:31

Allora ho fatto un po di test: il powerbank a vuoto (senza essere attaccato a nulla) segna 5.2V che scendono a 3.7 quando collego il tutto.
Se stasera riesco provo a saldare insieme i pin D+ e D- e vedere se cambia qualcosa.
Nel frattempo ho pure scritto alla Anker chiedendo se i loro powerbank richiedono una configurazione particolare sui canali D+ e D-
Avatar utente
Foto UtenteDani88
10 3
New entry
New entry
 
Messaggi: 68
Iscritto il: 26 set 2010, 20:37

0
voti

[9] Re: [Arduino + Powerbank + LED] 3.7V sulla linea dei 5 V

Messaggioda Foto Utentedaniele1996 » 26 set 2016, 14:04

Occhio a quello che colleghi, all 99,9% dei casi le power bank usano un convertitore DC/DC che porta da 3.7V a 5V, per quanto riguarda il D+e il D- sono lasciati "liberi" quindi non usati (di solito). Il tuo problema mi sembra piú legato a questo convertitore... anche io ho doverse power bank e anche se scrivono 1A su ogni uscita, collegando giá piú dispositivi noto che fa fatica... per caso diventa caldo?
Chi non sa dove è diretto non arriva da nessuna parte.
Avatar utente
Foto Utentedaniele1996
570 2 7 11
Sostenitore
Sostenitore
 
Messaggi: 1143
Iscritto il: 29 ago 2011, 11:29


Torna a Arduino

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti