Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Problemi con NE555 MONOSTABILE

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto Utenteg.schgor, Foto UtenteBrunoValente

0
voti

[1] Problemi con NE555 MONOSTABILE

Messaggioda Foto UtenteOsvaldo » 21 apr 2019, 23:43

Salve,
ho costruito il circuito che si vede in foto 1 per automatizzare la movimentazione delle tapparelle sui miei abbaini. Per misurare il tempo che vado a comandare i relè di carico per i motori delle imposte (non visibili in foto) ho impiegato due circuiti analoghi utilizzando gli NE555 in monostabile, secondo il circuito di foto 2. Ci sono anche dei sensori per luce e pioggia, ma questi non danno problemi.
Tutto sembrava in ottima funzionalità, impossibilità di doppio comando simultaneo e regolari tempi di spegnimento, se non che al completamento del montaggio mi si presentano 2 grossi inconvenienti: 1° alla prima accensione o a brevi interruzioni e ripristino dell’energia si attivano entrambi i timer; 2° a volte alla fine di una salita o discesa, comandato da un timer, improvvisamente si attiva l’altro senza avergli dato nessun comando.
Ho più volte controllato i circuiti ma non trovo nessun errore; ho anche provato ad unire i pin 6 e 7 degli integrati, come da notizia ricavata qui in un tutorial specifico per gli NE555 ma nulla cambia. Ripeto, a scheda non collegata al lavoro l’istantanea inversione del movimento non avviene. C’è però qualche caso di partenza di entrambe i timer per capricci della rete elettrica (cosa non rara qui in montagna)
Ho letto da qualche parte che questo circuito risente di disturbi esterni ma sia schermando la scheda che mettendola a terra nessun beneficio ne traggo.
Cosa posso ancora provare?
Ringrazio sin da ora chi o coloro che potranno aiutarmi, ben segnalando che non sono conoscitore della materia, solo un appassionato praticone.
Osvaldo – IK3ZYM
Allegati
schema per NE555 MONOSTABILE.png
Foto 2
Scheda per tapparelle ridimensionata..jpg
Foto 1
Avatar utente
Foto UtenteOsvaldo
70 4
New entry
New entry
 
Messaggi: 70
Iscritto il: 1 mag 2017, 18:01

0
voti

[2] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto Utentelelerelele » 22 apr 2019, 16:42

premesso che gli schemi qua devono essere fatti con fidocadj.

supponendo che il problema sia un disturbo, se è in alimentazione sarà un problema da trovare e risolvere, il condensatore tra + e - da 0.1uF c'è già, poi conviene eliminare la possibilità che sia un disturbo preso dall'ingresso, prova a ridurre R2 portandola ad 1K.

saluti.
Avatar utente
Foto Utentelelerelele
2.091 2 7 8
Expert EY
Expert EY
 
Messaggi: 2360
Iscritto il: 8 giu 2011, 8:57
Località: Reggio Emilia

0
voti

[3] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto UtenteOsvaldo » 22 apr 2019, 19:26

Grazie
Avatar utente
Foto UtenteOsvaldo
70 4
New entry
New entry
 
Messaggi: 70
Iscritto il: 1 mag 2017, 18:01

0
voti

[4] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto UtenteOsvaldo » 22 apr 2019, 22:55

Purtroppo riducendo R2 a 1K peggiorano le cose perché ogni temporizzatore, scaduto il tempo prefissato, immediatamente si autoeccita nuovamente per 3 - 4 volte. Ho provato anche a eliminare sia uno solo che entrambi i condensatori elettrolitici C3 (forse una leggera riduzione dell'inconveniente sulla automatica partenza di un temporizzatore alla fine del precedente). Credo il problema sia l’eccessiva sensibilità che arriva al piedino 2 perché basta toccare il punto caldo del pulsante col solo cacciavite e la partenza avviene.
Nuovamente grazie.
Osvaldo IK3ZYM
Avatar utente
Foto UtenteOsvaldo
70 4
New entry
New entry
 
Messaggi: 70
Iscritto il: 1 mag 2017, 18:01

0
voti

[5] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto UtenteOsvaldo » 23 apr 2019, 23:22

Ho dovuto abbandonare questo progetto perché troppo soggetto a disturbi di ogni genere. Ho sostituito il tutto operando gran parte col solo Arduino Nano.
Grazie a tutti comunque.
Osvaldo - IK3ZYM
Avatar utente
Foto UtenteOsvaldo
70 4
New entry
New entry
 
Messaggi: 70
Iscritto il: 1 mag 2017, 18:01

0
voti

[6] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto Utentelelerelele » 24 apr 2019, 8:43

mi pare certo che il problema sia dato da disturbi in alimentazione. avrai alimentato il circuito senza stabilizzazione.

come farai ad alimentare arduino se permangono questi distrurbi? come funzionerà? come lo interfaccerai?

saluti.
Avatar utente
Foto Utentelelerelele
2.091 2 7 8
Expert EY
Expert EY
 
Messaggi: 2360
Iscritto il: 8 giu 2011, 8:57
Località: Reggio Emilia

0
voti

[7] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto UtenteOsvaldo » 1 mag 2019, 15:36

Arduino lo alimento tra IN e GRD a 7,3 volt partendo dall'alimentazione generale a 12 volt riducendola a tale valore con un dispositivo precostruito che si trova in commercio (già impiegato in vari altri usi ed affidabile ed identificabile in basso a Dx nella foto allegata). I 12 V. dal 220 li ricavo ugualmente con uno stadio precostrito e trovato in commercio, prima di questo per maggior sicureza, pur avendo fatto prove risultate prive di disturbi, ho inserito un antidisturbo costituito da 2 bobinette da 1,2 mH avvolte separatamente sullo stesso torroide. Tra Arduino ed i relé ho inserito 2 optoisolatori 4N35 correttamete collegati alla base di relativi BC547.
La primaria scelta di inserire 2 temporizzatori separati usando NE555 era determinata dalla totale mia incapacità di programmare Arduino ma, con l'aiuto di mio figlio del mestiere, ho capito che tutte le mie necessità potevano essere condensate in tale dispositivo. Sono soddisfatto e il sistema, pur sottoposto a vari "maltrattamenti" elettrici ed elettronici, non perde un colpo.
Saluti.
Osvaldo - IK3ZYM
Allegati
dispositivo per tapparelle.jpg
Nuova soluzione
Avatar utente
Foto UtenteOsvaldo
70 4
New entry
New entry
 
Messaggi: 70
Iscritto il: 1 mag 2017, 18:01

0
voti

[8] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto UtenteOsvaldo » 18 mag 2019, 16:12

Sul tavolo di lavoro, con anche collegati i 12 relè, nessun problema si era presentato; messo in funzione batte in testa! Mi vien detto che Arduino non può sbagliare (non sono in grado di affermare il contrario) comunque ne combina di tutti i colori senza apparente logica, non so più che provare. Allego lo schema di cosa ho costruito con la speranza che qualcuno mi possa dare consigli.
Ringrazio e saluto.
Osvaldo
Allegati
Automatismo per persiane con Nano.pdf
(42.08 KiB) Scaricato 15 volte
Avatar utente
Foto UtenteOsvaldo
70 4
New entry
New entry
 
Messaggi: 70
Iscritto il: 1 mag 2017, 18:01

0
voti

[9] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto Utenteabusivo » 18 mag 2019, 18:06

Osvaldo ha scritto:Sul tavolo di lavoro ... nessun problema ... messo in funzione batte in testa!

In un caso molto simile al tuo, mi è stato fatto notare proprio su questo forum, che il 555 è molto sensibile alla variazioni/anomalie che si presentano sulla tensione di alimentazione.
Ho risolto filtrando e stabilizzando l'alimentazione solo di questo integrato.
Nel tuo caso non saprei dirti.
Avatar utente
Foto Utenteabusivo
8.785 4 4 7
Master
Master
 
Messaggi: 4896
Iscritto il: 16 ott 2012, 18:43
Località: L'Aquila

0
voti

[10] Re: Problemi con NE555 MONOSTABILE

Messaggioda Foto Utenteelektronik » 19 mag 2019, 8:38

C'è da dire che ci sono diversi tipi di 555 quelli meno sensibili alle interferenze sono gli NE555 che purtroppo si trovano molto meno degli altri
Avatar utente
Foto Utenteelektronik
3.344 3 5 7
Expert
Expert
 
Messaggi: 1984
Iscritto il: 12 mag 2015, 22:26

Prossimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Google Feedfetcher e 32 ospiti